]> git.pld-linux.org Git - packages/python-casttube.git/blame - python-casttube.spec
rebuild with tests and docs
[packages/python-casttube.git] / python-casttube.spec
CommitLineData
6f5d4702
AM
1# Conditional build:
2%bcond_without tests # unit tests
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module casttube
7%define egg_name casttube
8%define pypi_name casttube
9Summary: casttube provides a way to interact with the Youtube Chromecast api
10Name: python-%{module}
11Version: 0.2.0
64645368 12Release: 5
6f5d4702
AM
13License: MIT
14Group: Libraries/Python
15Source0: https://pypi.debian.net/casttube/%{pypi_name}-%{version}.tar.gz
16# Source0-md5: 4bb24ba1639d16c8fa367537bf3b88a6
17URL: https://pypi.org/project/casttube/
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-modules
22BuildRequires: python-setuptools
23%endif
24%if %{with python3}
25BuildRequires: python3-modules
26BuildRequires: python3-setuptools
27%endif
28Requires: python-modules
29BuildArch: noarch
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33casttube provides a way to interact with the Youtube Chromecast api.
34
35Features:
36- Play video
37- Play a playlist
38- Add video to the end of the play queue
39- Play next
40- Remove video
41- Clear the entire queue
42
43%package -n python3-%{module}
44Summary: casttube provides a way to interact with the Youtube Chromecast api
45Group: Libraries/Python
46Requires: python3-modules
47
48%description -n python3-%{module}
49casttube provides a way to interact with the Youtube Chromecast api.
50
51Features:
52- Play video
53- Play a playlist
54- Add video to the end of the play queue
55- Play next
56- Remove video
57- Clear the entire queue
58
59%prep
60%setup -q -n %{pypi_name}-%{version}
61
62%build
63%if %{with python2}
64%py_build %{?with_tests:test}
65%endif
66
67%if %{with python3}
68%py3_build %{?with_tests:test}
69%endif
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74%if %{with python2}
75%py_install
76%endif
77
78%if %{with python3}
79%py3_install
80%endif
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%if %{with python2}
86%files
87%defattr(644,root,root,755)
88%doc README.md
89%{py_sitescriptdir}/%{module}
90%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
91%endif
92
93%if %{with python3}
94%files -n python3-%{module}
95%defattr(644,root,root,755)
96%doc README.md
97%{py3_sitescriptdir}/%{module}
98%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
99%endif
This page took 0.133513 seconds and 4 git commands to generate.