]> git.pld-linux.org Git - packages/python-casttube.git/blame - python-casttube.spec
- updated to 0.2.1, added pl
[packages/python-casttube.git] / python-casttube.spec
CommitLineData
08b8424e 1#
6f5d4702 2# Conditional build:
6f5d4702
AM
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module casttube
7%define egg_name casttube
8%define pypi_name casttube
08b8424e
JB
9Summary: casttube - a way to interact with the Youtube Chromecast API
10Summary(pl.UTF-8): casttube - sposób interakcji z API Youtube Chromecast
6f5d4702 11Name: python-%{module}
08b8424e
JB
12Version: 0.2.1
13Release: 1
6f5d4702
AM
14License: MIT
15Group: Libraries/Python
08b8424e
JB
16#Source0Download: https://pypi.org/simple/casttube/
17Source0: https://files.pythonhosted.org/packages/source/c/casttube/%{pypi_name}-%{version}.tar.gz
18# Source0-md5: 37f86084a36e0dbd72d45b0452b4b676
6f5d4702
AM
19URL: https://pypi.org/project/casttube/
20BuildRequires: rpm-pythonprov
21BuildRequires: rpmbuild(macros) >= 1.714
22%if %{with python2}
23BuildRequires: python-modules
24BuildRequires: python-setuptools
25%endif
26%if %{with python3}
27BuildRequires: python3-modules
28BuildRequires: python3-setuptools
29%endif
30Requires: python-modules
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
08b8424e 35casttube provides a way to interact with the Youtube Chromecast API.
6f5d4702
AM
36
37Features:
38- Play video
39- Play a playlist
40- Add video to the end of the play queue
41- Play next
42- Remove video
43- Clear the entire queue
44
08b8424e
JB
45%description -l pl.UTF-8
46casttube udostępnia sposób interakcji z API Youtube Chromecast.
47
48Możliwości:
49- odtwarzanie filmów
50- odtwarzanie z listy
51- dodawanie filmów na końcu kolejki odtwarzania
52- odtwarzanie następnego filmu
53- usuwanie filmu
54- czyszczenie całej kolejki
55
6f5d4702 56%package -n python3-%{module}
08b8424e
JB
57Summary: casttube - a way to interact with the Youtube Chromecast API
58Summary(pl.UTF-8): casttube - sposób interakcji z API Youtube Chromecast
6f5d4702
AM
59Group: Libraries/Python
60Requires: python3-modules
61
62%description -n python3-%{module}
08b8424e 63casttube provides a way to interact with the Youtube Chromecast API.
6f5d4702
AM
64
65Features:
66- Play video
67- Play a playlist
68- Add video to the end of the play queue
69- Play next
70- Remove video
71- Clear the entire queue
72
08b8424e
JB
73%description -n python3-%{module} -l pl.UTF-8
74casttube udostępnia sposób interakcji z API Youtube Chromecast.
75
76Możliwości:
77- odtwarzanie filmów
78- odtwarzanie z listy
79- dodawanie filmów na końcu kolejki odtwarzania
80- odtwarzanie następnego filmu
81- usuwanie filmu
82- czyszczenie całej kolejki
83
6f5d4702
AM
84%prep
85%setup -q -n %{pypi_name}-%{version}
86
87%build
88%if %{with python2}
08b8424e 89%py_build
6f5d4702
AM
90%endif
91
92%if %{with python3}
08b8424e 93%py3_build
6f5d4702
AM
94%endif
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99%if %{with python2}
100%py_install
101%endif
102
103%if %{with python3}
104%py3_install
105%endif
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%if %{with python2}
111%files
112%defattr(644,root,root,755)
08b8424e 113%doc LICENSE README.md
6f5d4702
AM
114%{py_sitescriptdir}/%{module}
115%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
116%endif
117
118%if %{with python3}
119%files -n python3-%{module}
120%defattr(644,root,root,755)
08b8424e 121%doc LICENSE README.md
6f5d4702
AM
122%{py3_sitescriptdir}/%{module}
123%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
124%endif
This page took 0.150034 seconds and 4 git commands to generate.