]> git.pld-linux.org Git - packages/python-cassandra.git/blame - python-cassandra.spec
Release 6 (by relup.sh)
[packages/python-cassandra.git] / python-cassandra.spec
CommitLineData
f6349ee6
MK
1# TODO:
2# - Fix tests (seems require mock <= 1.0.1)
3# - Cleanup cython leftovers
2737d47e
MK
4#
5# Conditional build:
6%bcond_with doc # don't build doc
516febf1 7%bcond_with tests # do not perform "make test"
7ec9e6e1 8%bcond_without python2 # CPython 2.x module
2737d47e 9%bcond_without python3 # CPython 3.x module
f6349ee6 10# NOTE: 3.7.1 R: mock<=1.0.1 for tests :/
2737d47e 11
083f071e 12%define module cassandra
2737d47e 13Summary: A Python client driver for Apache Cassandra
eff47a4d 14Summary(pl.UTF-8): Moduł Pythona dla klientów Apache Cassandra
2737d47e 15Name: python-%{module}
083f071e 16Version: 3.20.0
3d6dab57 17Release: 6
2737d47e
MK
18License: Apache v2.0
19Group: Libraries/Python
083f071e
JR
20Source0: https://github.com/datastax/python-driver/archive/%{version}/%{module}-%{version}.tar.gz
21# Source0-md5: e812c012c153c3dd1bdb49378cb9ffc5
2737d47e 22URL: http://github.com/datastax/python-driver
7ec9e6e1 23BuildRequires: libev-devel
2737d47e 24BuildRequires: rpm-pythonprov
95580df3 25BuildRequires: rpmbuild(macros) >= 1.710
2737d47e 26%if %{with python2}
7ec9e6e1 27## BuildRequires: python-futures
2737d47e
MK
28BuildRequires: python-PyYAML
29BuildRequires: python-devel
30BuildRequires: python-distribute
2737d47e
MK
31BuildRequires: python-pytz
32BuildRequires: python-six
7ec9e6e1 33BuildRequires: python-sure
516febf1 34Requires: python-futures
f6349ee6 35Requires: python-modules
516febf1
MK
36# mock<=1.0.1
37
2737d47e
MK
38%endif
39%if %{with python3}
40# BuildRequires: python3-futures # Only 3.0 and 3.1
969f6dec 41BuildRequires: python3-PyYAML
2737d47e 42BuildRequires: python3-devel
969f6dec 43BuildRequires: python3-mock
2737d47e
MK
44BuildRequires: python3-modules
45BuildRequires: python3-pytz
eff47a4d 46BuildRequires: python3-six >= 1.6
7ec9e6e1 47BuildRequires: python3-sure
2737d47e 48%endif
eff47a4d
MK
49Suggests: python-blist
50
2737d47e
MK
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
7ec9e6e1
MK
54A Python client driver for Apache Cassandra. This driver works
55exclusively with the Cassandra Query Language v3 (CQL3) and
56Cassandra's native protocol. Cassandra versions 1.2 through 2.1 are
57supported. The driver supports Python 2.6, 2.7, 3.3, and 3.4.
2737d47e 58
7ec9e6e1
MK
59%description -l pl.UTF-8
60Interfejs klienta dla Apache Cassandra. Działa wyłacznie w oparciu
61Cassandra Query Languages v3 (CQL3) i z natywnym protkołem Cassandry.
62Wspiera Cassndry w wersjach od 1.2 w góre i działa z Pythonem 2.6,
632.7, 3.3, 3.4 .
2737d47e
MK
64
65%package -n python3-%{module}
eff47a4d
MK
66Summary: A Python client driver for Apache Cassandra
67Summary(pl.UTF-8): Moduł Pythona dla klientów Apache Cassandra
2737d47e 68Group: Libraries/Python
eff47a4d
MK
69Requires: python3-six >= 1.6
70Suggests: python3-blist
71
2737d47e
MK
72
73%description -n python3-%{module}
7ec9e6e1
MK
74A Python client driver for Apache Cassandra. This driver works
75exclusively with the Cassandra Query Language v3 (CQL3) and
76Cassandra's native protocol. Cassandra versions 1.2 through 2.1 are
77supported. The driver supports Python 2.6, 2.7, 3.3, and 3.4.
78
79%description -n python3-%{module} -l pl.UTF-8
80Interfejs klienta dla Apache Cassandra. Działa wyłacznie w oparciu
81Cassandra Query Languages v3 (CQL3) i z natywnym protkołem Cassandry.
82Wspiera Cassndry w wersjach od 1.2 w góre i działa z Pythonem 2.6,
832.7, 3.3, 3.4 .
2737d47e 84
2737d47e
MK
85
86%package apidocs
87Summary: %{module} API documentation
88Summary(pl.UTF-8): Dokumentacja API %{module}
89Group: Documentation
90
eff47a4d 91
2737d47e
MK
92%description apidocs
93API documentation for %{module}.
94
95%description apidocs -l pl.UTF-8
96Dokumentacja API %{module}.
97
98%prep
516febf1 99%setup -q -n python-driver-%{version}
2737d47e 100
2737d47e
MK
101%build
102%if %{with python2}
679a8f72 103%py_build %{?with_tests:test}
2737d47e
MK
104%endif
105
106%if %{with python3}
679a8f72 107%py3_build %{?with_tests:test}
2737d47e
MK
108%endif
109
110%if %{with doc}
111cd docs
112%{__make} -j1 html
113rm -rf _build/html/_sources
114%endif
115
116%install
117rm -rf $RPM_BUILD_ROOT
2737d47e 118%if %{with python2}
679a8f72 119%py_install
2737d47e
MK
120%py_postclean
121%endif
122
123%if %{with python3}
679a8f72 124%py3_install
2737d47e
MK
125%endif
126
2737d47e
MK
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%if %{with python2}
131%files
132%defattr(644,root,root,755)
7ec9e6e1
MK
133%doc README.rst
134%dir %{py_sitedir}/%{module}
135%{py_sitedir}/%{module}/*.py[co]
aabebf2e
AM
136%{py_sitedir}/%{module}/*.pxd
137%{py_sitedir}/%{module}/*.pyx
516febf1 138%attr(755,root,root) %{py_sitedir}/%{module}/*.so
7ec9e6e1
MK
139%dir %{py_sitedir}/%{module}/cqlengine
140%{py_sitedir}/%{module}/cqlengine/*.py[co]
083f071e
JR
141%dir %{py_sitedir}/%{module}/datastax
142%{py_sitedir}/%{module}/datastax/*.py[co]
143%dir %{py_sitedir}/%{module}/datastax/cloud
144%{py_sitedir}/%{module}/datastax/cloud/*.py[co]
7ec9e6e1
MK
145%dir %{py_sitedir}/%{module}/io
146%{py_sitedir}/%{module}/io/*.py[co]
147%attr(755,root,root) %{py_sitedir}/%{module}/io/libevwrapper.so
7ec9e6e1 148%{py_sitedir}/cassandra_driver-%{version}-py*.egg-info
2737d47e 149%endif
2737d47e
MK
150
151%if %{with python3}
152%files -n python3-%{module}
153%defattr(644,root,root,755)
7ec9e6e1 154%doc README.rst
2737d47e
MK
155%dir %{py3_sitedir}/%{module}
156%{py3_sitedir}/%{module}/*.py
aabebf2e
AM
157%{py3_sitedir}/%{module}/*.pxd
158%{py3_sitedir}/%{module}/*.pyx
516febf1 159%attr(755,root,root) %{py3_sitedir}/%{module}/*.cpython-*.so
2737d47e
MK
160%{py3_sitedir}/%{module}/__pycache__/
161%dir %{py3_sitedir}/%{module}/io
162%{py3_sitedir}/%{module}/io/*.py
7ec9e6e1 163%attr(755,root,root) %{py3_sitedir}/%{module}/io/libevwrapper.cpython-*.so
2737d47e 164%{py3_sitedir}/%{module}/io/__pycache__
7ec9e6e1
MK
165%dir %{py3_sitedir}/%{module}/cqlengine
166%{py3_sitedir}/%{module}/cqlengine/*.py
167%{py3_sitedir}/%{module}/cqlengine/__pycache__
083f071e
JR
168%dir %{py3_sitedir}/%{module}/datastax
169%{py3_sitedir}/%{module}/datastax/*.py
170%{py3_sitedir}/%{module}/datastax/__pycache__
171%dir %{py3_sitedir}/%{module}/datastax/cloud
172%{py3_sitedir}/%{module}/datastax/cloud/*.py
173%{py3_sitedir}/%{module}/datastax/cloud/__pycache__
2737d47e 174%{py3_sitedir}/cassandra_driver-%{version}-py*.egg-info
2737d47e
MK
175%endif
176
177%if %{with doc}
178%files apidocs
179%defattr(644,root,root,755)
180%doc docs/_build/html/*
181%endif
This page took 0.152158 seconds and 4 git commands to generate.