]> git.pld-linux.org Git - packages/python-case.git/blame - python-case.spec
rebuild with python 3.10
[packages/python-case.git] / python-case.spec
CommitLineData
1abb7085
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_with tests # unit tests (not included in sdist)
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: Python unittest utilities
9Summary(pl.UTF-8): Pythonowe narzędzia do testów jednostkowych
10Name: python-case
11Version: 1.5.3
9938e35b 12Release: 3
1abb7085
JB
13License: BSD
14Group: Libraries/Python
15#Source0Download: https://pypi.org/simple/case/
16Source0: https://files.pythonhosted.org/packages/source/c/case/case-%{version}.tar.gz
17# Source0-md5: 169acc1fe087b8938cdf31da8ab426be
18URL: https://pypi.org/project/case/
19%if %{with python2}
20BuildRequires: python-modules >= 1:2.6
f192bae0 21BuildRequires: python-setuptools >= 1:20.6.7
1abb7085
JB
22%if %{with tests}
23BuildRequires: python-mock >= 2.0
24BuildRequires: python-nose >= 1.3.7
25BuildRequires: python-pytest
26BuildRequires: python-six
27%endif
28%endif
29%if %{with python3}
30BuildRequires: python3-modules >= 1:3.3
f192bae0 31BuildRequires: python3-setuptools >= 1:20.6.7
1abb7085
JB
32%if %{with tests}
33BuildRequires: python3-nose >= 1.3.7
34BuildRequires: python3-pytest
35BuildRequires: python3-six
36%endif
37%endif
38BuildRequires: rpm-pythonprov
39BuildRequires: rpmbuild(macros) >= 1.714
40%if %{with doc}
41BuildRequires: python3-sphinx_celery >= 1.1
42BuildRequires: sphinx-pdg-3
43%endif
44Requires: python-modules >= 1:2.6
45BuildArch: noarch
46BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48%description
49Python unittest utilities.
50
51%description -l pl.UTF-8
52Pythonowe narzędzia do testów jednostkowych.
53
54%package -n python3-case
55Summary: Python unittest utilities
56Summary(pl.UTF-8): Pythonowe narzędzia do testów jednostkowych
57Group: Libraries/Python
58Requires: python3-modules >= 1:3.3
59
60%description -n python3-case
61Python unittest utilities.
62
63%description -n python3-case -l pl.UTF-8
64Pythonowe narzędzia do testów jednostkowych.
65
66%package apidocs
67Summary: API documentation for Python case module
68Summary(pl.UTF-8): Dokumentacja API modułu Pythona case
69Group: Documentation
70
71%description apidocs
72API documentation for Python case module.
73
74%description apidocs -l pl.UTF-8
75Dokumentacja API modułu Pythona case.
76
77%prep
78%setup -q -n case-%{version}
79
80%build
81%if %{with python2}
82%py_build
83
84%if %{with tests}
85%{__python} -m nose case/tests
86%endif
87%endif
88
89%if %{with python3}
90%py3_build
91
92%if %{with tests}
93%{__python3} -m nose case/tests
94%endif
95%endif
96
97%if %{with doc}
98%{__make} -C docs html \
99 SPHINXBUILD=sphinx-build-3
100%endif
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
105%if %{with python2}
106%py_install
107
108%py_postclean
109%endif
110
111%if %{with python3}
112%py3_install
113%endif
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%if %{with python2}
119%files
120%defattr(644,root,root,755)
121%doc Changelog LICENSE README.rst
122%{py_sitescriptdir}/case
123%{py_sitescriptdir}/case-%{version}-py*.egg-info
124%endif
125
126%if %{with python3}
127%files -n python3-case
128%defattr(644,root,root,755)
129%doc Changelog LICENSE README.rst
130%{py3_sitescriptdir}/case
131%{py3_sitescriptdir}/case-%{version}-py*.egg-info
132%endif
133
134%if %{with doc}
135%files apidocs
136%defattr(644,root,root,755)
137%doc docs/_build/html/{_modules,_static,reference,*.html,*.js}
138%endif
This page took 0.812406 seconds and 4 git commands to generate.