]> git.pld-linux.org Git - packages/python-boltons.git/blame - python-boltons.spec
rebuild with python 3.10
[packages/python-boltons.git] / python-boltons.spec
CommitLineData
6c3353c3
JB
1#
2# Conditional build:
3%bcond_without tests # unit tests
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
6
7Summary: When they're not builtins, they're boltons
8Summary(pl.UTF-8): To, co nie jest wbudowane, jest w boltons
9Name: python-boltons
10Version: 21.0.0
a59e88d1 11Release: 2
6c3353c3
JB
12License: BSD
13Group: Libraries/Python
14#Source0Download: https://pypi.org/simple/boltons/
15Source0: https://files.pythonhosted.org/packages/source/b/boltons/boltons-%{version}.tar.gz
16# Source0-md5: c7a17577f80a5c3316b8cb61b79d09c9
17URL: https://pypi.org/project/boltons/
18%if %{with python2}
19BuildRequires: python-modules >= 1:2.7
20BuildRequires: python-setuptools
21%if %{with tests}
22BuildRequires: python-pytest
23%endif
24%endif
25%if %{with python3}
26BuildRequires: python3-modules >= 1:3.4
27BuildRequires: python3-setuptools
28%if %{with tests}
29BuildRequires: python3-pytest
30%endif
31%endif
32BuildRequires: rpm-pythonprov
33BuildRequires: rpmbuild(macros) >= 1.714
34Requires: python-modules >= 1:2.7
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Functionality that should be in the standard library. Like builtins,
40but Boltons.
41
42%description -l pl.UTF-8
43Funkcjonalność, która powinna być w bibliotece standardowej, Podobnie
44jak builtins, ale to są Boltons.
45
46%package -n python3-boltons
47Summary: When they're not builtins, they're boltons
48Summary(pl.UTF-8): To, co nie jest wbudowane, jest w boltons
49Group: Libraries/Python
50Requires: python3-modules >= 1:3.4
51
52%description -n python3-boltons
53Functionality that should be in the standard library. Like builtins,
54but Boltons.
55
56%description -n python3-boltons -l pl.UTF-8
57Funkcjonalność, która powinna być w bibliotece standardowej, Podobnie
58jak builtins, ale to są Boltons.
59
60%prep
61%setup -q -n boltons-%{version}
62
63%build
64%if %{with python2}
65%py_build
66
67%if %{with tests}
68PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
69%{__python} -m pytest --doctest-modules boltons
70%endif
71%endif
72
73%if %{with python3}
74%py3_build
75
76%if %{with tests}
77PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
78%{__python3} -m pytest --doctest-modules boltons
79%endif
80%endif
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85%if %{with python2}
86%py_install
87
88%py_postclean
89%endif
90
91%if %{with python3}
92%py3_install
93%endif
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%if %{with python2}
99%files
100%defattr(644,root,root,755)
101%doc CHANGELOG.md LICENSE README.md TODO.rst
102%{py_sitescriptdir}/boltons
103%{py_sitescriptdir}/boltons-%{version}-py*.egg-info
104%endif
105
106%if %{with python3}
107%files -n python3-boltons
108%defattr(644,root,root,755)
109%doc CHANGELOG.md LICENSE README.md TODO.rst
110%{py3_sitescriptdir}/boltons
111%{py3_sitescriptdir}/boltons-%{version}-py*.egg-info
112%endif
This page took 0.110897 seconds and 4 git commands to generate.