]> git.pld-linux.org Git - packages/python-blist.git/blame - python-blist.spec
- drop python3-distribute deps
[packages/python-blist.git] / python-blist.spec
CommitLineData
d5ca9cfd
MK
1#
2# Conditional build:
3%bcond_with doc # don't build doc
4%bcond_without tests # do not perform "make test"
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8%define module blist
9Summary: The blist is a drop-in replacement for the Python list that provides better performance when modifying large lists
10Summary(pl.UTF-8): Blist jest zamiennikiem dla Pythonowych list który jest szybszy przy modifikacjach dużych list
11Name: python-%{module}
12Version: 1.3.6
d30b2056 13Release: 9
d5ca9cfd
MK
14License: BSD
15Group: Libraries/Python
16Source0: http://pypi.python.org/packages/source/b/%{module}/%{module}-%{version}.tar.gz
17# Source0-md5: a538f1a24b9191e3c40252e9397408a9
18URL: http://stutzbachenterprises.com/blist/
19BuildRequires: rpm-pythonprov
20# if py_postclean is used
cd7b9fa4 21BuildRequires: rpmbuild(macros) >= 1.710
d5ca9cfd
MK
22%if %{with python2}
23BuildRequires: python-devel
24BuildRequires: python-distribute
25%endif
26%if %{with python3}
27BuildRequires: python3-devel
d5ca9cfd
MK
28BuildRequires: python3-modules
29%endif
30Requires: python-modules
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34The blist is a drop-in replacement for the Python list that provides better performance when modifying large lists.
35The blist package also provides sortedlist, sortedset, weaksortedlist, weaksortedset, sorteddict, and btuple types
36
37%description -l pl.UTF-8
38Blist jest zamiennikiem dla Pythonowych list który jest szybszy przy modifikacjach dużych list.
39Pakiet blist udostępnia też typy: sortedlist, sortedset, weaksortedlist, weaksortedset, sorteddict, and btuple.
40
41%package -n python3-%{module}
42Summary: -
43Summary(pl.UTF-8): -
44Group: Libraries/Python
45Requires: python3-modules
46
47%description -n python3-%{module}
48The blist is a drop-in replacement for the Python list that provides better performance when modifying large lists
49
50%description -n python3-%{module} -l pl.UTF-8
51Blist jest zamiennikiem dla Pythonowych list który jest szybszy przy modifikacjach dużych list.
52Pakiet blist udostępnia też typy: sortedlist, sortedset, weaksortedlist, weaksortedset, sorteddict, and btuple.
53
54%package apidocs
55Summary: %{module} API documentation
56Summary(pl.UTF-8): Dokumentacja API %{module}
57Group: Documentation
58
59%description apidocs
60API documentation for %{module}.
61
62%description apidocs -l pl.UTF-8
63Dokumentacja API %{module}.
64
65%prep
66%setup -q -n %{module}-%{version}
67
68%build
69%if %{with python2}
1306d80a 70%py_build %{?with_tests:test}
d5ca9cfd
MK
71%endif
72
73%if %{with python3}
1306d80a 74%py3_build %{?with_tests:test}
d5ca9cfd
MK
75%endif
76
77%if %{with doc}
78cd docs
79%{__make} -j1 html
80rm -rf _build/html/_sources
81%endif
82
83%install
84rm -rf $RPM_BUILD_ROOT
85
86%if %{with python2}
1306d80a 87%py_install
d5ca9cfd
MK
88
89%py_postclean
90%endif
91
92%if %{with python3}
1306d80a 93%py3_install
d5ca9cfd
MK
94%endif
95
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%if %{with python2}
101%files
102%defattr(644,root,root,755)
103%doc README.rst
104%dir %{py_sitedir}/%{module}
105%{py_sitedir}/%{module}/*.py[co]
106%attr(755,root,root) %{py_sitedir}/%{module}/_blist.so
107%if "%{py_ver}" > "2.4"
108%{py_sitedir}/%{module}-%{version}-py*.egg-info
109%endif
110%endif
111
112%if %{with python3}
113%files -n python3-%{module}
114%defattr(644,root,root,755)
115%doc README.rst
116%dir %{py3_sitedir}/%{module}
117%{py3_sitedir}/%{module}/*.py
118%{py3_sitedir}/%{module}/__pycache__
119%attr(755,root,root) %{py3_sitedir}/%{module}/_blist.cpython-*.so
120%{py3_sitedir}/%{module}-%{version}-py*.egg-info
121%endif
122
123%if %{with doc}
124%files apidocs
125%defattr(644,root,root,755)
126%doc docs/_build/html/*
127%endif
This page took 0.160243 seconds and 4 git commands to generate.