]> git.pld-linux.org Git - packages/python-astroid.git/blame - python-astroid.spec
BR: python-pytest-runner
[packages/python-astroid.git] / python-astroid.spec
CommitLineData
86ae2efd 1#
797e8d54
JK
2# Conditional build:
3%bcond_without python2 # Python 2.x module
4%bcond_without python3 # Python 3.x module
5
935ded5d 6%define module astroid
424da304
JB
7Summary: An abstract syntax tree for Python 2 with inference support
8Summary(pl.UTF-8): Abstrakcyjnego drzewa składniowe dla Pythona 2 z obsługą wywodu
935ded5d 9Name: python-%{module}
4537d2ca
MK
10Version: 2.0.4
11Release: 1
f33b8242 12License: LGPL v2.1+
f3ce12d1 13Group: Development/Languages/Python
424da304 14#Source0Download: https://pypi.python.org/pypi/astroid/
00f52389 15Source0: https://files.pythonhosted.org/packages/source/a/astroid/astroid-%{version}.tar.gz
4537d2ca 16# Source0-md5: eb1c4312019809696634b33d639eee9d
935ded5d 17URL: http://www.astroid.org/
797e8d54 18%if %{with python2}
b42224b7
JB
19BuildRequires: python-devel >= 1:2.7
20BuildRequires: python-modules >= 1:2.7
aab70606 21BuildRequires: python-pytest-runner
efa8ca83 22BuildRequires: python-setuptools >= 7.0
797e8d54
JK
23%endif
24%if %{with python3}
b42224b7 25BuildRequires: python3-devel >= 1:3.3
b42224b7 26BuildRequires: python3-modules >= 1:3.3
aab70606 27BuildRequires: python3-pytest-runner
efa8ca83 28BuildRequires: python3-setuptools >= 7.0
8dd567ae 29BuildRequires: rpm-pythonprov
93287a34 30BuildRequires: rpmbuild(macros) >= 1.710
797e8d54 31%endif
b42224b7
JB
32Requires: python-modules >= 1:2.7
33Requires: python-six
ea88bfee 34Obsoletes: python-logilab-astng
f3ce12d1
KK
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
00f52389
JK
38# current Python 3.x provides all these
39%define _noautoreq python3egg.backports.functools-lru-cache python3egg.enum34 python3egg.singledispatch
40
f3ce12d1 41%description
8dd567ae 42The aim of this module is to provide a common base representation of
86ae2efd 43Python source code for projects such as pychecker, pyreverse,
8dd567ae
AF
44pylint... Well, actually the development of this library is
45essentially governed by pylint's needs. It used to be called
46logilab-astng.
f3ce12d1 47
9522705c
JR
48%description -l pl.UTF-8
49Celem tego modułu jest dostarczenie wspólnej bazowej reprezentacji
50kodu źródłowego Pythona dla projektów takich jak pychecker, pyreverse,
51pylint... Właściwie tworzenie tej biblioteki jest istotnie kierowane
86ae2efd 52potrzebami pylinta. Dawniej nazywała się logilab-astng.
8504e807 53
797e8d54 54%package -n python3-%{module}
424da304
JB
55Summary: An abstract syntax tree for Python 3 with inference support
56Summary(pl.UTF-8): Abstrakcyjnego drzewa składniowe dla Pythona 3 z obsługą wywodu
797e8d54 57Group: Development/Languages/Python
b42224b7
JB
58Requires: python3-modules >= 1:3.3
59Requires: python3-six
ea88bfee 60Obsoletes: python3-logilab-astng
797e8d54
JK
61
62%description -n python3-%{module}
8dd567ae 63The aim of this module is to provide a common base representation of
86ae2efd 64Python source code for projects such as pychecker, pyreverse,
8dd567ae
AF
65pylint... Well, actually the development of this library is
66essentially governed by pylint's needs. It used to be called
67logilab-astng.
797e8d54
JK
68
69%description -n python3-%{module} -l pl.UTF-8
70Celem tego modułu jest dostarczenie wspólnej bazowej reprezentacji
71kodu źródłowego Pythona dla projektów takich jak pychecker, pyreverse,
72pylint... Właściwie tworzenie tej biblioteki jest istotnie kierowane
86ae2efd 73potrzebami pylinta. Dawniej nazywała się logilab-astng.
797e8d54 74
f3ce12d1 75%prep
abbaad7a 76%setup -q -n %{module}-%{version}
60fa4681 77
f5edbecb 78# drop python 2.5 egg deps
389dcac9 79%{__rm} */*/*/*/*/*py2.5.egg
f3ce12d1
KK
80
81%build
797e8d54 82%if %{with python2}
08f50e0d 83%py_build
797e8d54
JK
84%endif
85%if %{with python3}
08f50e0d 86%py3_build --build-base=build3
797e8d54 87%endif
f3ce12d1
KK
88
89%install
90rm -rf $RPM_BUILD_ROOT
91
797e8d54 92%if %{with python3}
cd33eed2 93%py3_install
797e8d54
JK
94%endif
95
96%if %{with python2}
08f50e0d 97%py_install
f3ce12d1 98
5a062cc9 99%py_postclean
797e8d54 100%endif
f3ce12d1 101
f3ce12d1
KK
102%clean
103rm -rf $RPM_BUILD_ROOT
104
8f194190 105%if %{with python2}
f3ce12d1
KK
106%files
107%defattr(644,root,root,755)
00f52389 108%doc ChangeLog README.rst
935ded5d
AF
109%{py_sitescriptdir}/astroid
110%{py_sitescriptdir}/astroid-%{version}-py*.egg-info
8f194190 111%endif
797e8d54 112
8f194190 113%if %{with python3}
797e8d54
JK
114%files -n python3-%{module}
115%defattr(644,root,root,755)
00f52389 116%doc ChangeLog README.rst
935ded5d
AF
117%{py3_sitescriptdir}/astroid
118%{py3_sitescriptdir}/astroid-%{version}-py*.egg-info
8f194190 119%endif
This page took 0.109964 seconds and 4 git commands to generate.