]> git.pld-linux.org Git - packages/python-astroid.git/blame - python-astroid.spec
- up to 1.3.2
[packages/python-astroid.git] / python-astroid.spec
CommitLineData
86ae2efd 1#
797e8d54
JK
2# Conditional build:
3%bcond_without python2 # Python 2.x module
4%bcond_without python3 # Python 3.x module
5
935ded5d 6%define module astroid
86ae2efd
JB
7Summary: Rebuild a new abstract syntax tree from Python's AST
8Summary(pl.UTF-8): Tworzenie nowego abstrakcyjnego drzewa składniowego z pythonowego AST
935ded5d 9Name: python-%{module}
389dcac9
AM
10Version: 1.3.2
11Release: 1
f33b8242 12License: LGPL v2.1+
f3ce12d1 13Group: Development/Languages/Python
8dd567ae 14Source0: https://pypi.python.org/packages/source/a/astroid/astroid-%{version}.tar.gz
389dcac9 15# Source0-md5: 2ab96129a977b6eba27765a15d1a9bf2
935ded5d 16URL: http://www.astroid.org/
797e8d54 17%if %{with python2}
f3ce12d1 18BuildRequires: python-devel
b3a57614 19BuildRequires: python-modules >= 1:2.5
797e8d54
JK
20%endif
21%if %{with python3}
797e8d54
JK
22BuildRequires: python3-2to3
23BuildRequires: python3-devel
24BuildRequires: python3-distribute
25BuildRequires: python3-modules >= 1:3.1
8dd567ae
AF
26BuildRequires: rpm-pythonprov
27BuildRequires: rpmbuild(macros) >= 1.219
797e8d54 28%endif
86ae2efd 29Requires: python-logilab-common >= 0.60.0
8dd567ae 30Requires: python-modules
ea88bfee 31Obsoletes: python-logilab-astng
f3ce12d1
KK
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%description
8dd567ae 36The aim of this module is to provide a common base representation of
86ae2efd 37Python source code for projects such as pychecker, pyreverse,
8dd567ae
AF
38pylint... Well, actually the development of this library is
39essentially governed by pylint's needs. It used to be called
40logilab-astng.
f3ce12d1 41
9522705c
JR
42%description -l pl.UTF-8
43Celem tego modułu jest dostarczenie wspólnej bazowej reprezentacji
44kodu źródłowego Pythona dla projektów takich jak pychecker, pyreverse,
45pylint... Właściwie tworzenie tej biblioteki jest istotnie kierowane
86ae2efd 46potrzebami pylinta. Dawniej nazywała się logilab-astng.
8504e807 47
797e8d54 48%package -n python3-%{module}
86ae2efd
JB
49Summary: Rebuild a new abstract syntax tree from Python's AST
50Summary(pl.UTF-8): Tworzenie nowego abstrakcyjnego drzewa składniowego z pythonowego AST
797e8d54 51Group: Development/Languages/Python
86ae2efd 52Requires: python3-logilab-common >= 0.60.0
8dd567ae 53Requires: python3-modules
ea88bfee 54Obsoletes: python3-logilab-astng
797e8d54
JK
55
56%description -n python3-%{module}
8dd567ae 57The aim of this module is to provide a common base representation of
86ae2efd 58Python source code for projects such as pychecker, pyreverse,
8dd567ae
AF
59pylint... Well, actually the development of this library is
60essentially governed by pylint's needs. It used to be called
61logilab-astng.
797e8d54
JK
62
63%description -n python3-%{module} -l pl.UTF-8
64Celem tego modułu jest dostarczenie wspólnej bazowej reprezentacji
65kodu źródłowego Pythona dla projektów takich jak pychecker, pyreverse,
66pylint... Właściwie tworzenie tej biblioteki jest istotnie kierowane
86ae2efd 67potrzebami pylinta. Dawniej nazywała się logilab-astng.
797e8d54 68
f3ce12d1 69%prep
abbaad7a 70%setup -q -n %{module}-%{version}
f5edbecb 71# drop python 2.5 egg deps
389dcac9 72%{__rm} */*/*/*/*/*py2.5.egg
f3ce12d1
KK
73
74%build
797e8d54 75%if %{with python2}
f33b8242 76%{__python} setup.py build
797e8d54
JK
77%endif
78%if %{with python3}
79%{__python3} setup.py build --build-base=build3
80%endif
f3ce12d1
KK
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
797e8d54
JK
85%if %{with python3}
86%{__python3} setup.py build --build-base=build3 install \
87 --optimize=2 \
88 --root=$RPM_BUILD_ROOT
797e8d54
JK
89%endif
90
91%if %{with python2}
f33b8242 92%{__python} setup.py install \
f3ce12d1
KK
93 --optimize=2 \
94 --root=$RPM_BUILD_ROOT
95
5a062cc9 96%py_postclean
797e8d54 97%endif
f3ce12d1 98
f3ce12d1
KK
99%clean
100rm -rf $RPM_BUILD_ROOT
101
8f194190 102%if %{with python2}
f3ce12d1
KK
103%files
104%defattr(644,root,root,755)
105%doc ChangeLog README
935ded5d
AF
106%{py_sitescriptdir}/astroid
107%{py_sitescriptdir}/astroid-%{version}-py*.egg-info
8f194190 108%endif
797e8d54 109
8f194190 110%if %{with python3}
797e8d54
JK
111%files -n python3-%{module}
112%defattr(644,root,root,755)
113%doc ChangeLog README
935ded5d
AF
114%{py3_sitescriptdir}/astroid
115%{py3_sitescriptdir}/astroid-%{version}-py*.egg-info
8f194190 116%endif
This page took 0.066577 seconds and 4 git commands to generate.