]> git.pld-linux.org Git - packages/python-apsw.git/blame - python-apsw.spec
- release 8 (by relup.sh)
[packages/python-apsw.git] / python-apsw.spec
CommitLineData
b3b3252f
AM
1#
2# Conditional build:
3%bcond_with tests # do not perform "make test"
4%bcond_without python2 # CPython 2.x module
5%bcond_without python3 # CPython 3.x module
61b31c29
AM
6
7%define module apsw
b3b3252f 8%define sqlite_ver 3.8.5
61b31c29
AM
9
10Summary: Another Python SQLite Wrapper
10dcd257 11Summary(pl.UTF-8): Another Python SQLite Wrapper - jeszcze jeden pythonowy wrapper dla SQLite
61b31c29 12Name: python-%{module}
b3b3252f 13Version: 3.8.5
372d5f2e 14Release: 8
61b31c29 15License: Free
b3b3252f
AM
16Group: Libraries/Python
17Source0: https://github.com/rogerbinns/apsw/archive/%{version}-r1.tar.gz
18# Source0-md5: 09eb9f39d7cf9d320ee8e89f9e9ab7ea
19URL: http://rogerbinns.github.io/apsw/
72254a0b 20BuildRequires: rpmbuild(macros) >= 1.710
31293ab1 21BuildRequires: rpm-pythonprov
f8bb72a1 22BuildRequires: sqlite3-devel >= %{sqlite_ver}
4809cf98 23BuildRequires: unzip
b3b3252f
AM
24%if %{with python2}
25BuildRequires: python-devel
26BuildRequires: python-distribute
27%endif
28%if %{with python3}
29BuildRequires: python3-devel
30BuildRequires: python3-distribute
31BuildRequires: python3-modules
32%endif
33Requires: python-modules
f8bb72a1 34Requires: sqlite3 >= %{sqlite_ver}
61b31c29
AM
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38APSW provides an SQLite 3 wrapper that provides the thinnest layer
39over SQLite 3 possible. Everything you can do from the C API to SQLite
403, you can do from Python. Although APSW looks vaguely similar to the
41DBAPI, it is not compliant with that API and instead works the way
42SQLite 3 does.
43
30b51d00
JR
44%description -l pl.UTF-8
45APSW udostępnia wrapper SQLite 3 dostarczający najcieńszą jak to tylko
46możliwe warstwę ponad SQLite 3. Wszystko co można zrobić z poziomu API
47C SQLite 3 można zrobić także z poziomu Pythona. Chociaż APSQ wygląda
48dosyć podobnie do DBAPI, nie jest kompatybilne z tym API, natomiast
49działa tak, jak SQLite 3.
f174cdd6 50
b3b3252f
AM
51%package -n python3-%{module}
52Summary: -
53Summary(pl.UTF-8): -
54Group: Libraries/Python
55Requires: sqlite3 >= %{sqlite_ver}
56
57%description -n python3-%{module}
58APSW provides an SQLite 3 wrapper that provides the thinnest layer
59over SQLite 3 possible. Everything you can do from the C API to SQLite
603, you can do from Python. Although APSW looks vaguely similar to the
61DBAPI, it is not compliant with that API and instead works the way
62SQLite 3 does.
63
64%description -n python3-%{module} -l pl.UTF-8
65APSW udostępnia wrapper SQLite 3 dostarczający najcieńszą jak to tylko
66możliwe warstwę ponad SQLite 3. Wszystko co można zrobić z poziomu API
67C SQLite 3 można zrobić także z poziomu Pythona. Chociaż APSQ wygląda
68dosyć podobnie do DBAPI, nie jest kompatybilne z tym API, natomiast
69działa tak, jak SQLite 3.
70
71%package apidocs
72Summary: %{module} API documentation
73Summary(pl.UTF-8): Dokumentacja API %{module}
74Group: Documentation
75
76%description apidocs
77API documentation for %{module}.
78
79%description apidocs -l pl.UTF-8
80Dokumentacja API %{module}.
81
61b31c29
AM
82%prep
83%setup -q -n %{module}-%{version}-r1
84
85%build
b3b3252f 86%if %{with python2}
6541522c 87%py_build %{?with_tests:test}
b3b3252f
AM
88%endif
89
90%if %{with python3}
6541522c 91%py3_build %{?with_tests:test}
b3b3252f
AM
92%endif
93
94%if %{with doc}
95cd docs
96%{__make} -j1 html
97rm -rf _build/html/_sources
98%endif
61b31c29
AM
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
b3b3252f 103%if %{with python2}
6541522c 104%py_install
b3b3252f
AM
105
106%py_postclean
107%endif
108
109%if %{with python3}
6541522c 110%py3_install
b3b3252f 111%endif
61b31c29
AM
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
b3b3252f 116%if %{with python2}
61b31c29
AM
117%files
118%defattr(644,root,root,755)
b3b3252f
AM
119%doc LICENSE README.rst
120%attr(755,root,root) %{py_sitedir}/*.so
121%if "%{py_ver}" > "2.4"
967a04f7 122%{py_sitedir}/%{module}-*.egg-info
b3b3252f
AM
123%endif
124%endif
125
126%if %{with python3}
127%files -n python3-%{module}
128%defattr(644,root,root,755)
129%doc LICENSE README.rst
130%{py3_sitedir}/%{module}*.so
131%{py3_sitedir}/%{module}-%{version}*-py*.egg-info
132%endif
133
134%if %{with doc}
135%files apidocs
136%defattr(644,root,root,755)
137%doc docs/_build/html/*
138%endif
This page took 0.119985 seconds and 4 git commands to generate.