]> git.pld-linux.org Git - packages/python-application.git/blame - python-application.spec
- release 3 (by relup.sh)
[packages/python-application.git] / python-application.spec
CommitLineData
45a597c5
JK
1%define module application
2Summary: Basic building blocks for python applications
3Name: python-%{module}
b2ccb9e8 4Version: 1.3.1
f3e82a04 5Release: 3
45a597c5
JK
6License: LGPL
7Group: Development/Languages/Python
8Source0: http://pypi.python.org/packages/source/p/python-application/%{name}-%{version}.tar.gz
b2ccb9e8 9# Source0-md5: 615d670fcda2aa5a01de7bc12baa1fdf
45a597c5 10URL: http://pypi.python.org/pypi/python-application
b2ccb9e8 11BuildRequires: python-devel >= 1:2.5
45a597c5 12BuildRequires: rpm-pythonprov
684f9bcf 13BuildRequires: rpmbuild(macros) >= 1.710
45a597c5
JK
14Requires: python-modules
15BuildArch: noarch
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%description
b2ccb9e8
ŁK
19This package is a collection of modules that are useful when building
20python applications. Their purpose is to eliminate the need to divert
21resources into implementing the small tasks that every application
22needs to do in order to run successfully and focus instead on the
23application logic itself.
45a597c5
JK
24
25The modules that the application package provides are:
26
b2ccb9e8
ŁK
271. process - UNIX process and signal management. 2. python - python
28utility classes and functions. 3. configuration - a simple interface
29to handle configuration files. 4. log - an extensible system logger
30for console and syslog. 5. debug - memory troubleshooting and
31execution timing. 6. system - interaction with the underlying
32operating system. 7. notification - an application wide notification
33system.
45a597c5
JK
34
35%prep
36%setup -q
37
38%build
4f2da407 39%py_build
45a597c5
JK
40
41%install
42rm -rf $RPM_BUILD_ROOT
4f2da407 43%py_install
45a597c5
JK
44
45%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
46%py_comp $RPM_BUILD_ROOT%{py_sitedir}
47%py_postclean
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%files
53%defattr(644,root,root,755)
54%doc ChangeLog NEWS README
55%dir %{py_sitescriptdir}/%{module}
56%{py_sitescriptdir}/%{module}/*.py[co]
57%dir %{py_sitescriptdir}/%{module}/configuration
58%{py_sitescriptdir}/%{module}/configuration/*.py[co]
59%dir %{py_sitescriptdir}/%{module}/debug
60%{py_sitescriptdir}/%{module}/debug/*.py[co]
b2ccb9e8
ŁK
61%dir %{py_sitescriptdir}/%{module}/log
62%{py_sitescriptdir}/%{module}/log/*.py[co]
63%dir %{py_sitescriptdir}/%{module}/log/extensions
64%{py_sitescriptdir}/%{module}/log/extensions/*.py[co]
65%dir %{py_sitescriptdir}/%{module}/log/extensions/twisted
66%{py_sitescriptdir}/%{module}/log/extensions/twisted/*.py[co]
45a597c5
JK
67%dir %{py_sitescriptdir}/%{module}/python
68%{py_sitescriptdir}/%{module}/python/*.py[co]
69%{py_sitescriptdir}/*-*.egg-info
This page took 0.065609 seconds and 4 git commands to generate.