]> git.pld-linux.org Git - packages/python-absl.git/blame - python-absl.spec
rebuild with python 3.10
[packages/python-absl.git] / python-absl.spec
CommitLineData
9bf4e61e
JB
1#
2# Conditional build:
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6Summary: Abseil Python Common Libraries
7Summary(pl.UTF-8): Wspólne biblioteki Abseil dla Pythona
8Name: python-absl
9Version: 0.9.0
2e9166de 10Release: 3
9bf4e61e
JB
11License: Apache v2.0
12Group: Libraries/Python
13#Source0Download: https://pypi.org/simple/absl-py/
14Source0: https://files.pythonhosted.org/packages/source/a/absl-py/absl-py-%{version}.tar.gz
15# Source0-md5: 4ba3484409252ec502b08f8ef8e48ab4
16URL: https://github.com/abseil/abseil-py
17%if %{with python2}
18BuildRequires: python-modules >= 1:2.7
19BuildRequires: python-setuptools
20%endif
21%if %{with python3}
22BuildRequires: python3-modules >= 1:3.4
23BuildRequires: python3-setuptools
24%endif
25BuildRequires: rpm-pythonprov
26BuildRequires: rpmbuild(macros) >= 1.714
27Requires: python-modules >= 1:2.7
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Abseil Python is a collection of Python library code for building
33Python applications. The code is collected from Google's own Python
34code base, and has been extensively tested and used in production.
35
36%description -l pl.UTF-8
37Abseil Python to biblioteka Pythona będąca zbiorem kodu do tworzenia
38aplikacji pythonowych. Kod bibliotek został zebrany z własnego kodu
39Google'a w Pythonie, obszernie przetestowany i jest używany
40produkcyjnie.
41
42%package -n python3-absl
43Summary: Abseil Python Common Libraries
44Summary(pl.UTF-8): Wspólne biblioteki Abseil dla Pythona
45Group: Libraries/Python
46Requires: python3-modules >= 1:3.4
47
48%description -n python3-absl
49Abseil Python is a collection of Python library code for building
50Python applications. The code is collected from Google's own Python
51code base, and has been extensively tested and used in production.
52
53%description -n python3-absl -l pl.UTF-8
54Abseil Python to biblioteka Pythona będąca zbiorem kodu do tworzenia
55aplikacji pythonowych. Kod bibliotek został zebrany z własnego kodu
56Google'a w Pythonie, obszernie przetestowany i jest używany
57produkcyjnie.
58
59%prep
60%setup -q -n absl-py-%{version}
61
62%build
63%if %{with python2}
64%py_build
65%endif
66
67%if %{with python3}
68%py3_build
69%endif
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74%if %{with python2}
75%py_install
76
77%py_postclean
78%endif
79
80%if %{with python3}
81%py3_install
82%endif
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%if %{with python2}
88%files
89%defattr(644,root,root,755)
90%doc README.md
91%{py_sitescriptdir}/absl
92%{py_sitescriptdir}/absl_py-%{version}-py*.egg-info
93%endif
94
95%if %{with python3}
96%files -n python3-absl
97%defattr(644,root,root,755)
98%doc README.md
99%{py3_sitescriptdir}/absl
100%{py3_sitescriptdir}/absl_py-%{version}-py*.egg-info
101%endif
This page took 0.105631 seconds and 4 git commands to generate.