]> git.pld-linux.org Git - packages/python-WSGIProxy2.git/blame - python-WSGIProxy2.spec
rebuild with python 3.10
[packages/python-WSGIProxy2.git] / python-WSGIProxy2.spec
CommitLineData
800a36fb
JB
1#
2# Conditional build:
3%bcond_without doc # Sphinx documentation
4%bcond_without tests # unit tests
5%bcond_without python2 # CPython 2.x module
6%bcond_without python3 # CPython 3.x module
7
8Summary: WSGI Proxy with various HTTP client backends
9Summary(pl.UTF-8): Proxy WSGI z różnymi backendami klienta HTTP
10Name: python-WSGIProxy2
11Version: 0.4.4
6a53d596 12Release: 4
800a36fb
JB
13License: MIT
14Group: Libraries/Python
15#Source0Download: https://pypi.org/simple/wsgiproxy2/
16Source0: https://files.pythonhosted.org/packages/source/W/WSGIProxy2/WSGIProxy2-%{version}.tar.gz
17# Source0-md5: 888f225f00a7923445e24f0979d92a45
18URL: https://github.com/gawel/WSGIProxy2/
19%if %{with python2}
20BuildRequires: python-modules >= 1:2.6
21BuildRequires: python-setuptools
22%if %{with tests}
23BuildRequires: python-WebOb
24BuildRequires: python-requests
25BuildRequires: python-six
26BuildRequires: python-urllib3
27BuildRequires: python-webtest
28%endif
29%endif
30%if %{with python3}
31BuildRequires: python3-modules >= 1:3.2
32BuildRequires: python3-setuptools
33%if %{with tests}
34BuildRequires: python3-WebOb
35BuildRequires: python3-requests
36BuildRequires: python3-six
37BuildRequires: python3-urllib3
38BuildRequires: python3-webtest
39%endif
40%endif
41BuildRequires: rpm-pythonprov
42BuildRequires: rpmbuild(macros) >= 1.714
43%if %{with doc}
44BuildRequires: sphinx-pdg
45%endif
46Requires: python-modules >= 1:2.6
47BuildArch: noarch
48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50%description
51WSGI Proxy with various HTTP client backends.
52
53%description -l pl.UTF-8
54Proxy WSGI z różnymi backendami klienta HTTP.
55
56%package -n python3-WSGIProxy2
57Summary: WSGI Proxy with various HTTP client backends
58Summary(pl.UTF-8): Proxy WSGI z różnymi backendami klienta HTTP
59Group: Libraries/Python
60Requires: python3-modules >= 1:3.2
61
62%description -n python3-WSGIProxy2
63WSGI Proxy with various HTTP client backends.
64
65%description -n python3-WSGIProxy2 -l pl.UTF-8
66Proxy WSGI z różnymi backendami klienta HTTP.
67
68%package apidocs
69Summary: API documentation for Python WSGIProxy2 module
70Summary(pl.UTF-8): Dokumentacja API modułu Pythona WSGIProxy2
71Group: Documentation
72
73%description apidocs
74API documentation for Python WSGIProxy2 module.
75
76%description apidocs -l pl.UTF-8
77Dokumentacja API modułu Pythona WSGIProxy2.
78
79%prep
80%setup -q -n WSGIProxy2-%{version}
81
82%build
83%if %{with python2}
84%py_build %{?with_tests:test}
85%endif
86
87%if %{with python3}
88%py3_build %{?with_tests:test}
89%endif
90
91%if %{with doc}
92%{__make} -C docs html \
93 SPHINXBUILD=sphinx-build
94%endif
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99%if %{with python2}
100%py_install
101
102%py_postclean
103%endif
104
105%if %{with python3}
106%py3_install
107%endif
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%if %{with python2}
113%files
114%defattr(644,root,root,755)
115%doc CHANGES.rst COPYING README.rst
116%{py_sitescriptdir}/wsgiproxy
117%{py_sitescriptdir}/WSGIProxy2-%{version}-py*.egg-info
118%endif
119
120%if %{with python3}
121%files -n python3-WSGIProxy2
122%defattr(644,root,root,755)
123%doc CHANGES.rst COPYING README.rst
124%{py3_sitescriptdir}/wsgiproxy
125%{py3_sitescriptdir}/WSGIProxy2-%{version}-py*.egg-info
126%endif
127
128%if %{with doc}
129%files apidocs
130%defattr(644,root,root,755)
131%doc docs/_build/html/{_static,*.html,*.js}
132%endif
This page took 0.106035 seconds and 4 git commands to generate.