]> git.pld-linux.org Git - packages/python-PyQt5.git/blame - python-PyQt5.spec
up to 5.12.2
[packages/python-PyQt5.git] / python-PyQt5.spec
CommitLineData
cd4d2f82 1# TODO:
4d758709
MK
2# - __pycache__ for python3-PyQt5-uic
3# - Fix /usr/local/lib64/python3.6/site-packages/PyQt5/*.pyi files.
06b02645 4#
61afc5d4
JB
5# Conditional build:
6%bcond_without python2 # CPython 2.x modules
7%bcond_without python3 # CPython 3.x modules
d26f705d 8%bcond_without webkit # QT5WebKit support
61afc5d4 9
a0dd6b04
JR
10%define module PyQt5
11# minimal required sip version
443e6b04 12%define sip_ver 2:4.19.14-1
61afc5d4 13# last qt version covered by these bindings (minimal required is currently 5.0.0)
4d758709 14# %define qt_ver %{version}
443e6b04 15%define qt_ver 5.12.0
4d758709 16
61afc5d4
JB
17Summary: Python 2 bindings for the Qt5 toolkit
18Summary(pl.UTF-8): Wiązania Pythona 2 do toolkitu Qt5
a0dd6b04 19Name: python-%{module}
e0ef9cc9
JP
20Version: 5.12.2
21Release: 1
61afc5d4 22License: GPL v3
a0dd6b04 23Group: Libraries/Python
e0ef9cc9
JP
24Source0: https://www.riverbankcomputing.com/static/Downloads/PyQt5/%{version}/PyQt5_gpl-%{version}.tar.gz
25# Source0-md5: 385bd628a5a6382fd06d9994df3ba143
8a4f48aa 26Patch0: install.patch
a0dd6b04
JR
27URL: http://www.riverbankcomputing.com/software/pyqt/
28# most of BR comes from configure.py
6c47e556 29BuildRequires: Qt5Bluetooth-devel >= %{qt_ver}
a0dd6b04
JR
30BuildRequires: Qt5Core-devel >= %{qt_ver}
31BuildRequires: Qt5DBus-devel >= %{qt_ver}
6c47e556 32BuildRequires: Qt5Designer-devel >= %{qt_ver}
a0dd6b04 33BuildRequires: Qt5Gui-devel >= %{qt_ver}
6c47e556 34BuildRequires: Qt5Help-devel >= %{qt_ver}
0904a6dd 35BuildRequires: Qt5Location-devel >= %{qt_ver}
6c47e556
JR
36BuildRequires: Qt5Multimedia-devel >= %{qt_ver}
37BuildRequires: Qt5MultimediaWidgets-devel >= %{qt_ver}
a0dd6b04 38BuildRequires: Qt5Network-devel >= %{qt_ver}
0904a6dd 39BuildRequires: Qt5Nfc-devel >= %{qt_ver}
a0dd6b04 40BuildRequires: Qt5OpenGL-devel >= %{qt_ver}
6c47e556 41BuildRequires: Qt5Positioning-devel >= %{qt_ver}
6f470a9b 42BuildRequires: Qt5PrintSupport-devel >= %{qt_ver}
6c47e556
JR
43BuildRequires: Qt5Qml-devel >= %{qt_ver}
44BuildRequires: Qt5Quick-devel >= %{qt_ver}
45BuildRequires: Qt5Sensors-devel >= %{qt_ver}
46BuildRequires: Qt5SerialPort-devel >= %{qt_ver}
a0dd6b04 47BuildRequires: Qt5Sql-devel >= %{qt_ver}
6c47e556 48BuildRequires: Qt5Svg-devel >= %{qt_ver}
a0dd6b04 49BuildRequires: Qt5Test-devel >= %{qt_ver}
8a4f48aa 50BuildRequires: Qt5UiTools-devel >= %{qt_ver}
0904a6dd 51BuildRequires: Qt5WebChannel-devel >= %{qt_ver}
d26f705d 52%{?with_webkit:BuildRequires: Qt5WebKit-devel >= %{qt_ver}}
6c47e556
JR
53BuildRequires: Qt5WebSockets-devel >= %{qt_ver}
54BuildRequires: Qt5Widgets-devel >= %{qt_ver}
55BuildRequires: Qt5X11Extras-devel >= %{qt_ver}
a0dd6b04 56BuildRequires: Qt5Xml-devel >= %{qt_ver}
6c47e556 57BuildRequires: Qt5XmlPatterns-devel >= %{qt_ver}
0904a6dd 58BuildRequires: dbus-devel >= 1
a0dd6b04 59BuildRequires: pkgconfig
c131c8d9
AM
60# configure.py does: "from PyQt5 import sip" but sip doesn't provide PyQt5/__init__.py file,
61# and thus sip cannot be import. That's why we require python-PyQt5 (which provides __init__.py)
62# here. Only for python2 since python3 can import from directory without __init__.py file.
700e1383 63%{?with_python2:BuildRequires: python-PyQt5 >= 5.11.2}
a0dd6b04 64BuildRequires: python-dbus-devel >= 0.80
bc2c35c3 65BuildRequires: python-PyQt5-sip >= %{sip_ver}
a0dd6b04 66BuildRequires: python-sip-devel >= %{sip_ver}
ad25adb4 67BuildRequires: python3-dbus >= 0.80
bc2c35c3 68BuildRequires: python3-PyQt5-sip >= %{sip_ver}
ad25adb4 69BuildRequires: python3-sip-devel >= %{sip_ver}
61afc5d4
JB
70BuildRequires: qt5-build >= %{qt_ver}
71BuildRequires: qt5-qmake >= %{qt_ver}
a0dd6b04
JR
72BuildRequires: rpm-pythonprov
73BuildRequires: rpmbuild(macros) >= 1.219
a0dd6b04 74Requires: python-dbus >= 0.80
cd4d2f82 75Requires: python-libs
bc2c35c3 76Requires: python-PyQt5-sip >= %{sip_ver}
a0dd6b04
JR
77BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
78
a0dd6b04
JR
79%define _sipfilesdir %{_datadir}/sip
80
81%description
82PyQt5 is a set of Python bindings for the Qt5 toolkit. The bindings
8a4f48aa
JR
83are implemented as a set of Python modules: Qt, QtBluetooth, QtCore,
84QtDBus, QtDesigner, QtGui, QtHelp, QtLocation, QtMultimedia,
0904a6dd 85QtMultimediaWidgets, QtNetwork, QtNfc, QtOpenGL, QtPositioning,
027041dc 86QtPrintSupport, QtQml, QtQuick, QtQuickWidgets, QtSensors,
443e6b04
JP
87QtSerialPort, QtSql, QtSvg, QtTest, QtWebChannel,
88QtWebSockets, QtX11Extras and QtXmlPatterns.
027041dc
JB
89
90This package contains Python 2 modules.
a0dd6b04
JR
91
92%description -l pl.UTF-8
93PyQt5 to zbiór dowiązań do Qt5 dla Pythona. Dowiązania zostały
8a4f48aa
JR
94zaimplementowane jako moduły Pythona: Qt, QtBluetooth, QtCore, QtDBus,
95QtDesigner, QtGui, QtHelp, QtLocation, QtMultimedia,
0904a6dd 96QtMultimediaWidgets, QtNetwork, QtNfc, QtOpenGL, QtPositioning,
027041dc 97QtPrintSupport, QtQml, QtQuick, QtQuickWidgets, QtSensors,
443e6b04
JP
98QtSerialPort, QtSql, QtSvg, QtTest, QtWebChannel,
99QtWebSockets, QtX11Extras oraz QtXmlPatterns.
027041dc
JB
100
101Ten pakiet zawiera moduły Pythona 2.
61afc5d4
JB
102
103%package uic
104Summary: pyuic5 development tool for Python 2
105Summary(pl.UTF-8): Narzędzie programistyczne pyuic5 dla Pythona 2
106Group: Development/Tools
107Requires: %{name} = %{version}-%{release}
108
109%description uic
110pyuic5 development tool for Python 2.
111
112%description uic -l pl.UTF-8
113Narzędzie programistyczne pyuic5 dla Pythona 2.
114
115%package -n python3-PyQt5
027041dc
JB
116Summary: Python 3 bindings for the Qt5 toolkit
117Summary(pl.UTF-8): Wiązania Pythona 3 do toolkitu Qt5
61afc5d4 118Group: Libraries/Python
61afc5d4 119Requires: python3-dbus >= 0.80
cd4d2f82 120Requires: python3-libs
bc2c35c3 121Requires: python3-PyQt5-sip >= %{sip_ver}
61afc5d4
JB
122
123%description -n python3-PyQt5
027041dc 124PyQt5 is a set of Python bindings for the Qt5 toolkit. The bindings
8a4f48aa
JR
125are implemented as a set of Python modules: Qt, QtBluetooth, QtCore,
126QtDBus, QtDesigner, QtGui, QtHelp, QtLocation, QtMultimedia,
0904a6dd 127QtMultimediaWidgets, QtNetwork, QtNfc, QtOpenGL, QtPositioning,
027041dc 128QtPrintSupport, QtQml, QtQuick, QtQuickWidgets, QtSensors,
443e6b04
JP
129QtSerialPort, QtSql, QtSvg, QtTest, QtWebChannel,
130QtWebSockets, QtX11Extras and QtXmlPatterns.
027041dc
JB
131
132This package contains Python 3 modules.
61afc5d4
JB
133
134%description -n python3-PyQt5 -l pl.UTF-8
027041dc 135PyQt5 to zbiór dowiązań do Qt5 dla Pythona. Dowiązania zostały
8a4f48aa
JR
136zaimplementowane jako moduły Pythona: Qt, QtBluetooth, QtCore, QtDBus,
137QtDesigner, QtGui, QtHelp, QtLocation, QtMultimedia,
0904a6dd 138QtMultimediaWidgets, QtNetwork, QtNfc, QtOpenGL, QtPositioning,
027041dc 139QtPrintSupport, QtQml, QtQuick, QtQuickWidgets, QtSensors,
443e6b04
JP
140QtSerialPort, QtSql, QtSvg, QtTest, QtWebChannel,
141QtWebSockets, QtX11Extras oraz QtXmlPatterns.
027041dc
JB
142
143Ten pakiet zawiera moduły Pythona 3.
61afc5d4
JB
144
145%package -n python3-PyQt5-uic
146Summary: pyuic5 development tool for Python 3
147Summary(pl.UTF-8): Narzędzie programistyczne pyuic5 dla Pythona 3
148Group: Development/Tools
149Requires: python3-PyQt5 = %{version}-%{release}
150
151%description -n python3-PyQt5-uic
152pyuic5 development tool for Python 3.
153
154%description -n python3-PyQt5-uic -l pl.UTF-8
155Narzędzie programistyczne pyuic5 dla Pythona 3.
a0dd6b04 156
a0dd6b04
JR
157%package devel-tools
158Summary: PyQt5 development tools
159Summary(pl.UTF-8): Narzędzia programistyczne PyQt5
61afc5d4
JB
160Group: Development/Tools
161Requires: Qt5Core >= %{qt_ver}
162Requires: Qt5Xml >= %{qt_ver}
1bef50b0
JK
163%if %{with python2}
164Requires: %{name} = %{version}-%{release}
165%else
166Requires: python3-PyQt5 = %{version}-%{release}
167%endif
a0dd6b04
JR
168
169%description devel-tools
61afc5d4
JB
170PyQt5 development tools: pylupdate5, pyrcc5.
171
172Note: this package doesn't depend on Python version.
a0dd6b04
JR
173
174%description devel-tools -l pl.UTF-8
61afc5d4
JB
175Narzędzia programistyczne PyQt5: pylupdate5, pyrcc5.
176
177Uwaga: ten pakiet nie jest zależny od wersji Pythona.
a0dd6b04
JR
178
179%package examples
180Summary: Examples for PyQt5
181Summary(pl.UTF-8): Przykłady do PyQt5
182Group: Libraries/Python
183Requires: %{name} = %{version}-%{release}
184
185%description examples
186Examples code demonstrating how to use the Python bindings for Qt5.
187
188%description examples -l pl.UTF-8
189Przykładowy kod demonstrujący jak używać PyQt5.
190
027041dc
JB
191%package -n sip-PyQt5
192Summary: SIP files needed to build other bindings based on Qt5
193Summary(pl.UTF-8): Pliki SIP potrzebne do budowania innych wiązań opartych na Qt5
194Group: Development/Languages/Python
195Requires: sip >= %{sip_ver}
196Obsoletes: python-PyQt5-devel < 5.3.2-4
197
198%description -n sip-PyQt5
199SIP files needed to build other bindings for C++ classes that inherit
200from any of the Qt5 classes (e.g. KDE or your own).
201
202%description -n sip-PyQt5 -l pl.UTF-8
203Pliki SIP potrzebne do budowania innych wiązań do klas C++
204dziedziczących z dowolnej klasy Qt5 (np. KDE lub własnych).
205
61afc5d4
JB
206%package -n Qt5Designer-plugin-pyqt5
207Summary: Qt5 Designer plugin for Python plugins with widgets
208Summary(pl.UTF-8): Wtyczka Qt5 Designera dla wtyczek Pythona zawierających widgety
209# can build only for one python version
210%if %{with python2}
211Requires: %{name} = %{version}-%{release}
212%else
213Requires: python3-PyQt5 = %{version}-%{release}
214%endif
215
216%description -n Qt5Designer-plugin-pyqt5
217This is the Qt5 Designer plugin that collects all the Python plugins
218it can find as a widget collection to Designer.
219
220%description -n Qt5Designer-plugin-pyqt5 -l pl.UTF-8
221Ten pakiet zawiera wtyczkę Qt5 Designera zbierającą wszystkie wtyczki
222Pythona, które jest w stanie znaleźć, jako zestaw widgetów dla
223Designera.
224
a0dd6b04
JR
225%package -n qscintilla2-%{module}-api
226Summary: PyQt5 API file for QScintilla
227Summary(pl.UTF-8): Plik API PyQt5 dla QScintilli
228Group: Libraries/Python
027041dc 229Requires: qscintilla2-qt5 >= 2.2-2
a0dd6b04
JR
230
231%description -n qscintilla2-%{module}-api
61afc5d4 232PyQt5 API file can be used by the QScintilla editor component to
a0dd6b04
JR
233enable the use of auto-completion and call tips when editing PyQt5
234code.
235
236%description -n qscintilla2-%{module}-api -l pl.UTF-8
61afc5d4 237Plik API PyQt5 może być używany przez komponent edytora QScintilla aby
a0dd6b04
JR
238umożliwić automatyczne dopełnianie i podpowiedzi przy modyfikowaniu
239kodu wykorzystującego PyQt5.
240
241%prep
4d758709 242%setup -q -n PyQt5_gpl-%{version}
8a4f48aa 243%patch0 -p1
a0dd6b04
JR
244
245%build
61afc5d4
JB
246%if %{with python2}
247install -d build-py2
248cd build-py2
249%{__python} ../configure.py \
a84a1f69 250 --no-dist-info \
61afc5d4 251 --verbose \
6c47e556 252 --assume-shared \
a0dd6b04
JR
253 --confirm-license \
254 -c -j 3 \
255 -a \
256 -b %{_bindir} \
257 -d %{py_sitedir} \
258 -q "%{_bindir}/qmake-qt5" \
259 -v %{_sipfilesdir}/%{module} \
260 LIBDIR_QT="%{_libdir}" \
261 CC="%{__cc}" \
262 CXX="%{__cxx}"
263
264%{__make}
61afc5d4
JB
265cd ..
266%endif
267
268%if %{with python3}
269install -d build-py3
270cd build-py3
271%{__python3} ../configure.py \
a84a1f69 272 --no-dist-info \
61afc5d4
JB
273 --verbose \
274 --assume-shared \
275 --confirm-license \
276 -c -j 3 \
277 -a \
278 -b %{_bindir} \
279 -d %{py3_sitedir} \
280 -q "%{_bindir}/qmake-qt5" \
281 -v %{_sipfilesdir}/%{module} \
282 LIBDIR_QT="%{_libdir}" \
283 CC="%{__cc}" \
284 CXX="%{__cxx}"
285
286%{__make}
287cd ..
288%endif
a0dd6b04
JR
289
290%install
291rm -rf $RPM_BUILD_ROOT
292install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
293
61afc5d4
JB
294%if %{with python3}
295%{__make} -C build-py3 install \
296 DESTDIR=$RPM_BUILD_ROOT \
297 INSTALL_ROOT=$RPM_BUILD_ROOT
298
299%{__mv} $RPM_BUILD_ROOT%{_bindir}/pyuic5{,-3}
300%endif
301
302%if %{with python2}
303%{__make} -C build-py2 install \
a0dd6b04
JR
304 DESTDIR=$RPM_BUILD_ROOT \
305 INSTALL_ROOT=$RPM_BUILD_ROOT
306
307%py_comp $RPM_BUILD_ROOT%{py_sitedir}
308%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
309
310# don't use py_postclean, leave *.py in %{py_sitedir}/PyQt4/uic/widget-plugins
311%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt5/*.py
312%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt5/uic/*.py
313%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt5/uic/Compiler/*.py
314%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt5/uic/Loader/*.py
315%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt5/uic/port_v2/*.py
316%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt5/uic/port_v3/*.py
61afc5d4 317%endif
a0dd6b04
JR
318
319cp -R examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
320
321%clean
322rm -rf $RPM_BUILD_ROOT
323
61afc5d4 324%if %{with python2}
a0dd6b04
JR
325%files
326%defattr(644,root,root,755)
327%doc NEWS README
6c47e556
JR
328%dir %{_libdir}/qt5/plugins/PyQt5
329%attr(755,root,root) %{_libdir}/qt5/plugins/PyQt5/libpyqt5qmlplugin.so
a0dd6b04 330%dir %{py_sitedir}/PyQt5
4d758709
MK
331%attr(755,root,root) %{py_sitedir}/PyQt5/pylupdate.so
332%attr(755,root,root) %{py_sitedir}/PyQt5/pyrcc.so
a0dd6b04 333%attr(755,root,root) %{py_sitedir}/PyQt5/Qt.so
61afc5d4 334%attr(755,root,root) %{py_sitedir}/PyQt5/QtBluetooth.so
a0dd6b04
JR
335%attr(755,root,root) %{py_sitedir}/PyQt5/QtCore.so
336%attr(755,root,root) %{py_sitedir}/PyQt5/QtDBus.so
337%attr(755,root,root) %{py_sitedir}/PyQt5/QtDesigner.so
338%attr(755,root,root) %{py_sitedir}/PyQt5/QtGui.so
339%attr(755,root,root) %{py_sitedir}/PyQt5/QtHelp.so
0904a6dd 340%attr(755,root,root) %{py_sitedir}/PyQt5/QtLocation.so
6c47e556
JR
341%attr(755,root,root) %{py_sitedir}/PyQt5/QtMultimedia.so
342%attr(755,root,root) %{py_sitedir}/PyQt5/QtMultimediaWidgets.so
61afc5d4 343%attr(755,root,root) %{py_sitedir}/PyQt5/QtNetwork.so
0904a6dd 344%attr(755,root,root) %{py_sitedir}/PyQt5/QtNfc.so
61afc5d4 345%attr(755,root,root) %{py_sitedir}/PyQt5/QtOpenGL.so
6c47e556
JR
346%attr(755,root,root) %{py_sitedir}/PyQt5/QtPositioning.so
347%attr(755,root,root) %{py_sitedir}/PyQt5/QtPrintSupport.so
348%attr(755,root,root) %{py_sitedir}/PyQt5/QtQml.so
349%attr(755,root,root) %{py_sitedir}/PyQt5/QtQuick.so
350%attr(755,root,root) %{py_sitedir}/PyQt5/QtQuickWidgets.so
351%attr(755,root,root) %{py_sitedir}/PyQt5/QtSensors.so
352%attr(755,root,root) %{py_sitedir}/PyQt5/QtSerialPort.so
61afc5d4 353%attr(755,root,root) %{py_sitedir}/PyQt5/QtSql.so
6c47e556 354%attr(755,root,root) %{py_sitedir}/PyQt5/QtSvg.so
61afc5d4 355%attr(755,root,root) %{py_sitedir}/PyQt5/QtTest.so
0904a6dd 356%attr(755,root,root) %{py_sitedir}/PyQt5/QtWebChannel.so
3da9f6d9 357%if %{with webkit}
d5e9c8f2
AM
358%attr(755,root,root) %{py_sitedir}/PyQt5/QtWebKit.so
359%attr(755,root,root) %{py_sitedir}/PyQt5/QtWebKitWidgets.so
3da9f6d9 360%endif
6c47e556 361%attr(755,root,root) %{py_sitedir}/PyQt5/QtWebSockets.so
61afc5d4 362%attr(755,root,root) %{py_sitedir}/PyQt5/QtWidgets.so
6c47e556 363%attr(755,root,root) %{py_sitedir}/PyQt5/QtX11Extras.so
ad25adb4 364%attr(755,root,root) %{py_sitedir}/PyQt5/QtXml.so
6c47e556 365%attr(755,root,root) %{py_sitedir}/PyQt5/QtXmlPatterns.so
61afc5d4 366%attr(755,root,root) %{py_sitedir}/PyQt5/_QOpenGLFunctions_2_0.so
ad25adb4
JR
367%attr(755,root,root) %{py_sitedir}/PyQt5/_QOpenGLFunctions_2_1.so
368%attr(755,root,root) %{py_sitedir}/PyQt5/_QOpenGLFunctions_4_1_Core.so
a0dd6b04 369%{py_sitedir}/PyQt5/__init__.py[co]
4d758709
MK
370%{py_sitedir}/PyQt5/pyrcc_main.py[co]
371%{py_sitedir}/PyQt5/pylupdate_main.py[co]
a0dd6b04
JR
372%attr(755,root,root) %{py_sitedir}/dbus/mainloop/pyqt5.so
373
61afc5d4
JB
374%files uic
375%defattr(644,root,root,755)
376%attr(755,root,root) %{_bindir}/pyuic5
377%{py_sitedir}/PyQt5/uic
378%endif
379
380%if %{with python3}
381%files -n python3-PyQt5
382%defattr(644,root,root,755)
383%if %{without python2}
384# if not building python2 module, this plugin is built in python3 version
385%dir %{_libdir}/qt5/plugins/PyQt5
386%attr(755,root,root) %{_libdir}/qt5/plugins/PyQt5/libpyqt5qmlplugin.so
387%endif
388%dir %{py3_sitedir}/PyQt5
4d758709
MK
389%attr(755,root,root) %{py3_sitedir}/PyQt5/pylupdate.so
390%attr(755,root,root) %{py3_sitedir}/PyQt5/pyrcc.so
61afc5d4
JB
391%attr(755,root,root) %{py3_sitedir}/PyQt5/Qt.so
392%attr(755,root,root) %{py3_sitedir}/PyQt5/QtBluetooth.so
393%attr(755,root,root) %{py3_sitedir}/PyQt5/QtCore.so
394%attr(755,root,root) %{py3_sitedir}/PyQt5/QtDBus.so
395%attr(755,root,root) %{py3_sitedir}/PyQt5/QtDesigner.so
396%attr(755,root,root) %{py3_sitedir}/PyQt5/QtGui.so
397%attr(755,root,root) %{py3_sitedir}/PyQt5/QtHelp.so
0904a6dd 398%attr(755,root,root) %{py3_sitedir}/PyQt5/QtLocation.so
61afc5d4
JB
399%attr(755,root,root) %{py3_sitedir}/PyQt5/QtMultimedia.so
400%attr(755,root,root) %{py3_sitedir}/PyQt5/QtMultimediaWidgets.so
401%attr(755,root,root) %{py3_sitedir}/PyQt5/QtNetwork.so
0904a6dd 402%attr(755,root,root) %{py3_sitedir}/PyQt5/QtNfc.so
61afc5d4
JB
403%attr(755,root,root) %{py3_sitedir}/PyQt5/QtOpenGL.so
404%attr(755,root,root) %{py3_sitedir}/PyQt5/QtPositioning.so
405%attr(755,root,root) %{py3_sitedir}/PyQt5/QtPrintSupport.so
406%attr(755,root,root) %{py3_sitedir}/PyQt5/QtQml.so
407%attr(755,root,root) %{py3_sitedir}/PyQt5/QtQuick.so
408%attr(755,root,root) %{py3_sitedir}/PyQt5/QtQuickWidgets.so
409%attr(755,root,root) %{py3_sitedir}/PyQt5/QtSensors.so
410%attr(755,root,root) %{py3_sitedir}/PyQt5/QtSerialPort.so
411%attr(755,root,root) %{py3_sitedir}/PyQt5/QtSql.so
412%attr(755,root,root) %{py3_sitedir}/PyQt5/QtSvg.so
413%attr(755,root,root) %{py3_sitedir}/PyQt5/QtTest.so
0904a6dd 414%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebChannel.so
3da9f6d9 415%if %{with webkit}
d5e9c8f2
AM
416%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebKit.so
417%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebKitWidgets.so
3da9f6d9 418%endif
61afc5d4
JB
419%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWebSockets.so
420%attr(755,root,root) %{py3_sitedir}/PyQt5/QtWidgets.so
421%attr(755,root,root) %{py3_sitedir}/PyQt5/QtX11Extras.so
ad25adb4 422%attr(755,root,root) %{py3_sitedir}/PyQt5/QtXml.so
61afc5d4
JB
423%attr(755,root,root) %{py3_sitedir}/PyQt5/QtXmlPatterns.so
424%attr(755,root,root) %{py3_sitedir}/PyQt5/_QOpenGLFunctions_2_0.so
ad25adb4
JR
425%attr(755,root,root) %{py3_sitedir}/PyQt5/_QOpenGLFunctions_2_1.so
426%attr(755,root,root) %{py3_sitedir}/PyQt5/_QOpenGLFunctions_4_1_Core.so
8a4f48aa
JR
427%attr(755,root,root) %{py3_sitedir}/dbus/mainloop/pyqt5.so
428%{py3_sitedir}/PyQt5/QtBluetooth.pyi
429%{py3_sitedir}/PyQt5/QtCore.pyi
430%{py3_sitedir}/PyQt5/QtDBus.pyi
431%{py3_sitedir}/PyQt5/QtDesigner.pyi
432%{py3_sitedir}/PyQt5/QtGui.pyi
433%{py3_sitedir}/PyQt5/QtHelp.pyi
434%{py3_sitedir}/PyQt5/QtLocation.pyi
435%{py3_sitedir}/PyQt5/QtMultimedia.pyi
436%{py3_sitedir}/PyQt5/QtMultimediaWidgets.pyi
437%{py3_sitedir}/PyQt5/QtNetwork.pyi
438%{py3_sitedir}/PyQt5/QtNfc.pyi
439%{py3_sitedir}/PyQt5/QtOpenGL.pyi
440%{py3_sitedir}/PyQt5/QtPositioning.pyi
441%{py3_sitedir}/PyQt5/QtPrintSupport.pyi
442%{py3_sitedir}/PyQt5/QtQml.pyi
443%{py3_sitedir}/PyQt5/QtQuick.pyi
444%{py3_sitedir}/PyQt5/QtQuickWidgets.pyi
445%{py3_sitedir}/PyQt5/QtSensors.pyi
446%{py3_sitedir}/PyQt5/QtSerialPort.pyi
447%{py3_sitedir}/PyQt5/QtSql.pyi
448%{py3_sitedir}/PyQt5/QtSvg.pyi
449%{py3_sitedir}/PyQt5/QtTest.pyi
450%{py3_sitedir}/PyQt5/QtWebChannel.pyi
3da9f6d9 451%if %{with webkit}
d5e9c8f2
AM
452%{py3_sitedir}/PyQt5/QtWebKit.pyi
453%{py3_sitedir}/PyQt5/QtWebKitWidgets.pyi
3da9f6d9 454%endif
8a4f48aa
JR
455%{py3_sitedir}/PyQt5/QtWebSockets.pyi
456%{py3_sitedir}/PyQt5/QtWidgets.pyi
457%{py3_sitedir}/PyQt5/QtX11Extras.pyi
458%{py3_sitedir}/PyQt5/QtXml.pyi
459%{py3_sitedir}/PyQt5/QtXmlPatterns.pyi
61afc5d4 460%{py3_sitedir}/PyQt5/__init__.py
4d758709
MK
461%{py3_sitedir}/PyQt5/pylupdate_main.py
462%{py3_sitedir}/PyQt5/pyrcc_main.py
61afc5d4
JB
463
464%files -n python3-PyQt5-uic
465%defattr(644,root,root,755)
466%attr(755,root,root) %{_bindir}/pyuic5-3
467%{py3_sitedir}/PyQt5/uic
468%endif
469
a0dd6b04
JR
470%files devel-tools
471%defattr(644,root,root,755)
472%attr(755,root,root) %{_bindir}/pylupdate5
473%attr(755,root,root) %{_bindir}/pyrcc5
a0dd6b04
JR
474
475%files examples
476%defattr(644,root,root,755)
477%{_examplesdir}/%{name}-%{version}
478
027041dc
JB
479%files -n sip-PyQt5
480%defattr(644,root,root,755)
481%{_sipfilesdir}/PyQt5
482
61afc5d4
JB
483%files -n Qt5Designer-plugin-pyqt5
484%defattr(644,root,root,755)
485%attr(755,root,root) %{_libdir}/qt5/plugins/designer/libpyqt5.so
486
a0dd6b04
JR
487%files -n qscintilla2-%{module}-api
488%defattr(644,root,root,755)
489%{_datadir}/qt5/qsci/api/python/PyQt5.api
8a4f48aa
JR
490
491
This page took 0.122542 seconds and 4 git commands to generate.