]> git.pld-linux.org Git - packages/python-PyQt4.git/blame - python-PyQt4.spec
- updated to 4.10.3
[packages/python-PyQt4.git] / python-PyQt4.spec
CommitLineData
cde8597a 1%define module PyQt4
9197faa6 2# minimal required sip version
838f959c 3%define sip_ver 2:4.15
9197faa6 4# last qt version covered by these bindings (minimal required is currently 4.1.0)
87096b1f 5%define qt_ver 4.8.4
cde8597a
KK
6
7Summary: Python bindings for the Qt4 toolkit
35f445d7 8Summary(pl.UTF-8): Dowiązania do toolkitu Qt4 dla Pythona
cde8597a 9Name: python-%{module}
838f959c 10Version: 4.10.3
31032967 11Release: 1
9197faa6 12License: GPL v2 or GPL v3 with FLOSS exception
cde8597a 13Group: Libraries/Python
58daffa5 14Source0: http://downloads.sourceforge.net/pyqt/PyQt-x11-gpl-%{version}.tar.gz
838f959c 15# Source0-md5: 8b13d2ab64e4d2fd0037b81b7e78c15c
7833726a 16Patch0: %{name}-dbuspath.patch
3d990fd2 17Patch1: %{name}-64bit.patch
ff0b534d 18URL: http://www.riverbankcomputing.com/software/pyqt/
233862fa 19# most of BR comes from configure.py
838f959c 20BuildRequires: QtAssistant-compat-devel >= 4.6.3
9197faa6 21BuildRequires: QtCore-devel >= %{qt_ver}
733b7fc7 22BuildRequires: QtDBus-devel >= %{qt_ver}
9197faa6
JB
23BuildRequires: QtDeclarative-devel >= %{qt_ver}
24BuildRequires: QtDesigner-devel >= %{qt_ver}
25BuildRequires: QtGui-devel >= %{qt_ver}
26BuildRequires: QtHelp-devel >= %{qt_ver}
27BuildRequires: QtMultimedia-devel >= %{qt_ver}
28BuildRequires: QtNetwork-devel >= %{qt_ver}
29BuildRequires: QtOpenGL-devel >= %{qt_ver}
30BuildRequires: QtScript-devel >= %{qt_ver}
31BuildRequires: QtScriptTools-devel >= %{qt_ver}
32BuildRequires: QtSql-devel >= %{qt_ver}
33BuildRequires: QtSvg-devel >= %{qt_ver}
34BuildRequires: QtTest-devel >= %{qt_ver}
35BuildRequires: QtWebKit-devel >= %{qt_ver}
36BuildRequires: QtXml-devel >= %{qt_ver}
37BuildRequires: QtXmlPatterns-devel >= %{qt_ver}
233862fa 38BuildRequires: phonon-devel
36d3212d 39BuildRequires: pkgconfig
3c1063ca 40BuildRequires: python-dbus-devel >= 0.80
9197faa6 41BuildRequires: python-sip-devel >= %{sip_ver}
7943e9de
JB
42BuildRequires: qt4-build >= 4.3.3-3
43BuildRequires: qt4-qmake >= 4.3.3-3
cde8597a
KK
44BuildRequires: rpm-pythonprov
45BuildRequires: rpmbuild(macros) >= 1.219
7a2a342d 46BuildRequires: sed >= 4.0
cde8597a 47%pyrequires_eq python-libs
9197faa6
JB
48Requires: python-dbus >= 0.80
49Requires: python-sip >= %{sip_ver}
cde8597a
KK
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52%define _noautoreqdep libGL.so.1 libGLU.so.1
53%define _sipfilesdir %{_datadir}/sip
54
55%description
56PyQt4 is a set of Python bindings for the Qt4 toolkit. The bindings
9197faa6
JB
57are implemented as a set of Python modules: QtCore, QtDeclarative,
58QtDesigner, QtGui, QtHelp, QtMultimedia, QtNetwork, QtOpenGL,
59QtScript, QtScriptTools, QtSql, QtSvg, QtTest, QtWebKit, QtXml,
60QtXmlPatterns and phonon.
36d3212d 61
7b7e25a5
JR
62%description -l pl.UTF-8
63PyQt4 to zbiór dowiązań do Qt4 dla Pythona. Dowiązania zostały
9197faa6
JB
64zaimplementowane jako moduły Pythona: QtCore, QtDeclarative,
65QtDesigner, QtGui, QtHelp, QtMultimedia, QtNetwork, QtOpenGL,
66QtScript, QtScriptTools, QtSql, QtSvg, QtTest, QtWebKit, QtXml,
67QtXmlPatterns oraz phonon.
cde8597a
KK
68
69%package devel
70Summary: Files needed to build other bindings based on Qt4
9197faa6 71Summary(pl.UTF-8): Pliki potrzebne do budowania innych dowiązań opartych na Qt4
cde8597a
KK
72Group: Development/Languages/Python
73Requires: %{name} = %{version}-%{release}
74Requires: python-sip-devel
75
76%description devel
77Files needed to build other bindings for C++ classes that inherit from
78any of the Qt4 classes (e.g. KDE or your own).
79
7b7e25a5
JR
80%description devel -l pl.UTF-8
81Pliki potrzebne do budowania innych dowiązań do klas C++
82dziedziczących z dowolnej klasy Qt4 (np. KDE lub własnych).
cde8597a 83
9197faa6
JB
84%package devel-tools
85Summary: PyQt4 development tools
86Summary(pl.UTF-8): Narzędzia programistyczne PyQt4
87Group: X11/Development/Libraries
88Requires: %{name} = %{version}-%{release}
89
90%description devel-tools
91PyQt4 development tools: pylupdate4, pyrcc4, pyuic4.
92
93%description devel-tools -l pl.UTF-8
94Narzędzia programistyczne PyQt4: pylupdate4, pyrcc4, pyuic4.
95
cde8597a
KK
96%package examples
97Summary: Examples for PyQt4
35f445d7 98Summary(pl.UTF-8): Przykłady do PyQt4
cde8597a
KK
99Group: Libraries/Python
100Requires: %{name} = %{version}-%{release}
101
102%description examples
103Examples code demonstrating how to use the Python bindings for Qt4.
104
7b7e25a5
JR
105%description examples -l pl.UTF-8
106Przykładowy kod demonstrujący jak używać PyQt4.
cde8597a 107
36d3212d
KK
108%package -n qscintilla2-%{module}-api
109Summary: PyQt4 API file for QScintilla
0110a319 110Summary(pl.UTF-8): Plik API PyQt4 dla QScintilli
36d3212d
KK
111Group: Libraries/Python
112Requires: python-qscintilla2 >= 2.2-2
113
114%description -n qscintilla2-%{module}-api
115PyQt4 API file can be used by the QScintilla editor component to
116enable the use of auto-completion and call tips when editing PyQt4
117code.
118
0110a319
JB
119%description -n qscintilla2-%{module}-api -l pl.UTF-8
120Plik API PyQt4 może być używany przez komponent edytora QScintilla aby
121umożliwić automatyczne dopełnianie i podpowiedzi przy modyfikowaniu
122kodu wykorzystującego PyQt4.
123
cde8597a 124%prep
268b959a 125%setup -q -n PyQt-x11-gpl-%{version}
7a2a342d 126%{__sed} -i 's,pyuic.py,pyuic.pyc,' configure.py
f83ff0a7 127# small hack to build for shared libs - symbol QT_SHARED not defined anymore?
68bdfd61 128%{__sed} -i 's/qt_shared = lines\[.*\]/qt_shared = "y"/' configure.py
0d988e33 129%{__sed} -i 's/resp = sys.stdin.readline.*/resp = "yes"/' configure.py
7833726a 130%patch0 -p1
3d990fd2 131%patch1 -p1
cde8597a
KK
132
133%build
9197faa6 134%{__python} configure.py \
233862fa 135 --confirm-license \
cde8597a 136 -c -j 3 \
36d3212d 137 -a \
cde8597a 138 -b %{_bindir} \
8b198666 139 -d %{py_sitedir} \
7943e9de 140 -q "%{_bindir}/qmake-qt4" \
268b959a 141 -v %{_sipfilesdir}/%{module} \
7833726a 142 --dbus-path="%{py_sitedir}/dbus/mainloop" \
abbf3bae 143 LIBDIR_QT="%{_libdir}" \
144 CC="%{__cc}" \
145 CXX="%{__cxx}"
cde8597a
KK
146
147%{__make}
148
149%install
150rm -rf $RPM_BUILD_ROOT
c694bf53 151install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
cde8597a
KK
152
153%{__make} install \
0110a319
JB
154 DESTDIR=$RPM_BUILD_ROOT \
155 INSTALL_ROOT=$RPM_BUILD_ROOT
cde8597a
KK
156
157%py_comp $RPM_BUILD_ROOT%{py_sitedir}
158%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
4d0bf668
AF
159
160# don't use py_postclean, leave *.py in %{py_sitedir}/PyQt4/uic/widget-plugins
9197faa6
JB
161%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/*.py
162%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/uic/*.py
163%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/uic/Compiler/*.py
164%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/uic/Loader/*.py
165%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/uic/port_v2/*.py
166%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/PyQt4/uic/port_v3/*.py
cde8597a 167
c694bf53 168cp -R examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
cde8597a
KK
169
170%clean
171rm -rf $RPM_BUILD_ROOT
172
173%files
174%defattr(644,root,root,755)
9197faa6 175%doc GPL_EXCEPTION.TXT NEWS OPENSOURCE-NOTICE.TXT README THANKS
838f959c 176%attr(755,root,root) %{_libdir}/qt4/plugins/designer/libpyqt4.so
c694bf53 177%dir %{py_sitedir}/PyQt4
9197faa6 178%attr(755,root,root) %{py_sitedir}/PyQt4/Qt.so
838f959c 179%attr(755,root,root) %{py_sitedir}/PyQt4/QtAssistant.so
9197faa6 180%attr(755,root,root) %{py_sitedir}/PyQt4/QtCore.so
733b7fc7 181%attr(755,root,root) %{py_sitedir}/PyQt4/QtDBus.so
9197faa6
JB
182%attr(755,root,root) %{py_sitedir}/PyQt4/QtDeclarative.so
183%attr(755,root,root) %{py_sitedir}/PyQt4/QtDesigner.so
184%attr(755,root,root) %{py_sitedir}/PyQt4/QtGui.so
185%attr(755,root,root) %{py_sitedir}/PyQt4/QtHelp.so
186%attr(755,root,root) %{py_sitedir}/PyQt4/QtMultimedia.so
187%attr(755,root,root) %{py_sitedir}/PyQt4/QtNetwork.so
188%attr(755,root,root) %{py_sitedir}/PyQt4/QtOpenGL.so
189%attr(755,root,root) %{py_sitedir}/PyQt4/QtScript.so
190%attr(755,root,root) %{py_sitedir}/PyQt4/QtScriptTools.so
191%attr(755,root,root) %{py_sitedir}/PyQt4/QtSql.so
192%attr(755,root,root) %{py_sitedir}/PyQt4/QtSvg.so
193%attr(755,root,root) %{py_sitedir}/PyQt4/QtTest.so
194%attr(755,root,root) %{py_sitedir}/PyQt4/QtWebKit.so
195%attr(755,root,root) %{py_sitedir}/PyQt4/QtXml.so
196%attr(755,root,root) %{py_sitedir}/PyQt4/QtXmlPatterns.so
197%attr(755,root,root) %{py_sitedir}/PyQt4/phonon.so
198%{py_sitedir}/PyQt4/__init__.py[co]
199%{py_sitedir}/PyQt4/pyqtconfig.py[co]
0110a319 200%attr(755,root,root) %{py_sitedir}/dbus/mainloop/qt.so
cde8597a
KK
201
202%files devel
203%defattr(644,root,root,755)
204%{_sipfilesdir}/PyQt4
205
9197faa6
JB
206%files devel-tools
207%defattr(644,root,root,755)
208%attr(755,root,root) %{_bindir}/pylupdate4
209%attr(755,root,root) %{_bindir}/pyrcc4
210%attr(755,root,root) %{_bindir}/pyuic4
211%{py_sitedir}/PyQt4/uic
212
cde8597a
KK
213%files examples
214%defattr(644,root,root,755)
c694bf53 215%{_examplesdir}/%{name}-%{version}
36d3212d
KK
216
217%files -n qscintilla2-%{module}-api
218%defattr(644,root,root,755)
219%{_datadir}/qt4/qsci/api/python/PyQt4.api
This page took 0.544325 seconds and 4 git commands to generate.