]> git.pld-linux.org Git - packages/puppet.git/blame - puppet.spec
up to 2.7.26, install to vendor dir; noarch package
[packages/puppet.git] / puppet.spec
CommitLineData
bb855c6f
BZ
1# TODO
2# for man - rst2man.py needed (docutils snap?)
5af968f3
ER
3# - puppet user/group
4# - initscripts
add5fc4a 5Summary: A network tool for managing many disparate systems
bb855c6f 6Name: puppet
c7e37b2f 7Version: 2.7.26
58574b31 8Release: 0.1
bb855c6f
BZ
9License: GPL v2+
10Group: Networking/Admin
c7e37b2f
ER
11Source0: https://downloads.puppetlabs.com/puppet/%{name}-%{version}.tar.gz
12# Source0-md5: 2307f891e45e82597dbd1e126b3381ab
add5fc4a 13URL: http://www.puppetlabs.com/
bb855c6f 14BuildRequires: docutils
5af968f3
ER
15BuildRequires: rpmbuild(macros) >= 1.484
16BuildRequires: ruby >= 1:1.8.6
add5fc4a
ER
17BuildRequires: ruby-facter >= 1.5
18Requires: ruby >= 1:1.8.1
19Requires: ruby-facter >= 1.5
20Requires: ruby-shadow
c7e37b2f 21BuildArch: noarch
bb855c6f
BZ
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
add5fc4a
ER
25Puppet lets you centrally manage every important aspect of your system
26using a cross-platform specification language that manages all the
27separate elements normally aggregated in different files, like users,
28cron jobs, and hosts, along with obviously discrete elements like
29packages, services, and files.
bb855c6f 30
add5fc4a
ER
31%package server
32Summary: Server for the puppet system management tool
33Group: Base
34Requires: %{name} = %{version}-%{release}
35Requires(post): /sbin/chkconfig
36Requires(preun): /sbin/chkconfig
37Requires: rc-scripts
38
39%description server
40Provides the central puppet server daemon which provides manifests to
41clients. The server can also function as a certificate authority and
42file server.
bb855c6f 43
5c16f30d
ER
44%package -n vim-syntax-puppet
45Summary: Vim syntax for puppet .pp files
46Group: Applications/Editors/Vim
47Requires: vim-rt >= 4:7.2.170
48
49%description -n vim-syntax-puppet
50Vim syntax for puppet .pp files
51
bb855c6f
BZ
52%prep
53%setup -q
54
9afa5e9f
ER
55# puppet-queue.conf is more of an example, used for stompserver
56mv conf/puppet-queue.conf examples/etc/puppet/
bb855c6f
BZ
57
58%install
59rm -rf $RPM_BUILD_ROOT
add5fc4a 60%{__ruby} install.rb \
08d42e39 61 --quick \
add5fc4a 62 --no-rdoc \
c7e37b2f 63 --sitelibdir=%{ruby_vendorlibdir} \
bb855c6f
BZ
64 --destdir=$RPM_BUILD_ROOT
65
17807372
ER
66install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/modules,%{_datadir}/%{name}/modules}
67
5c16f30d
ER
68# Install vim syntax files
69install -d $RPM_BUILD_ROOT%{_datadir}/vim/{ftdetect,syntax}
70cp -p ext/vim/ftdetect/puppet.vim $RPM_BUILD_ROOT%{_datadir}/vim/ftdetect/puppet.vim
71cp -p ext/vim/syntax/puppet.vim $RPM_BUILD_ROOT%{_datadir}/vim/syntax/puppet.vim
72
9afa5e9f
ER
73install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
74cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
75
bb855c6f
BZ
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%files
80%defattr(644,root,root,755)
9afa5e9f 81%doc README.md CHANGELOG
20b9dc2f 82%dir %{_sysconfdir}/%{name}
17807372 83%dir %{_sysconfdir}/%{name}/modules
20b9dc2f 84%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/auth.conf
bb855c6f 85%attr(755,root,root) %{_bindir}/filebucket
08d42e39 86%attr(755,root,root) %{_bindir}/pi
bb855c6f 87%attr(755,root,root) %{_bindir}/puppet
bb855c6f 88%attr(755,root,root) %{_bindir}/puppetdoc
bb855c6f 89%attr(755,root,root) %{_bindir}/ralsh
08d42e39
ER
90%attr(755,root,root) %{_sbindir}/puppetca
91%attr(755,root,root) %{_sbindir}/puppetd
17807372
ER
92%dir %{_datadir}/%{name}
93%{_datadir}/%{name}/modules
c7e37b2f
ER
94%{ruby_vendorlibdir}/puppet
95%{ruby_vendorlibdir}/puppet.rb
96%{ruby_vendorlibdir}/semver.rb
08d42e39
ER
97%{_mandir}/man5/puppet.conf.5*
98%{_mandir}/man8/filebucket.8*
99%{_mandir}/man8/pi.8*
9afa5e9f
ER
100%{_mandir}/man8/puppet-agent.8*
101%{_mandir}/man8/puppet-apply.8*
102%{_mandir}/man8/puppet-ca.8*
103%{_mandir}/man8/puppet-catalog.8*
104%{_mandir}/man8/puppet-cert.8*
105%{_mandir}/man8/puppet-certificate.8*
106%{_mandir}/man8/puppet-certificate_request.8*
107%{_mandir}/man8/puppet-certificate_revocation_list.8*
108%{_mandir}/man8/puppet-config.8*
109%{_mandir}/man8/puppet-describe.8*
110%{_mandir}/man8/puppet-device.8*
111%{_mandir}/man8/puppet-doc.8*
112%{_mandir}/man8/puppet-facts.8*
113%{_mandir}/man8/puppet-file.8*
114%{_mandir}/man8/puppet-filebucket.8*
115%{_mandir}/man8/puppet-help.8*
116%{_mandir}/man8/puppet-inspect.8*
117%{_mandir}/man8/puppet-instrumentation_data.8*
118%{_mandir}/man8/puppet-instrumentation_listener.8*
119%{_mandir}/man8/puppet-instrumentation_probe.8*
120%{_mandir}/man8/puppet-key.8*
121%{_mandir}/man8/puppet-kick.8*
122%{_mandir}/man8/puppet-man.8*
123%{_mandir}/man8/puppet-master.8*
124%{_mandir}/man8/puppet-module.8*
125%{_mandir}/man8/puppet-node.8*
126%{_mandir}/man8/puppet-parser.8*
127%{_mandir}/man8/puppet-plugin.8*
128%{_mandir}/man8/puppet-queue.8*
129%{_mandir}/man8/puppet-report.8*
130%{_mandir}/man8/puppet-resource.8*
131%{_mandir}/man8/puppet-resource_type.8*
132%{_mandir}/man8/puppet-secret_agent.8*
133%{_mandir}/man8/puppet-status.8*
08d42e39
ER
134%{_mandir}/man8/puppet.8*
135%{_mandir}/man8/puppetca.8*
136%{_mandir}/man8/puppetd.8*
137%{_mandir}/man8/puppetdoc.8*
138%{_mandir}/man8/ralsh.8*
9afa5e9f 139%{_examplesdir}/%{name}-%{version}
08d42e39
ER
140
141%files server
142%defattr(644,root,root,755)
143%attr(755,root,root) %{_sbindir}/puppetmasterd
144%attr(755,root,root) %{_sbindir}/puppetrun
145%attr(755,root,root) %{_sbindir}/puppetqd
146%{_mandir}/man8/puppetmasterd.8*
147%{_mandir}/man8/puppetrun.8*
148%{_mandir}/man8/puppetqd.8*
5c16f30d
ER
149
150%files -n vim-syntax-puppet
151%defattr(644,root,root,755)
152%{_datadir}/vim/ftdetect/puppet.vim
153%{_datadir}/vim/syntax/puppet.vim
This page took 0.116035 seconds and 4 git commands to generate.