]> git.pld-linux.org Git - packages/pugixml.git/blame - pugixml.spec
- updated to 1.10
[packages/pugixml.git] / pugixml.spec
CommitLineData
92afb597
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4#
1392c26d
JB
5Summary: C++ XML processing library
6Summary(pl.UTF-8): Biblioteka C++ do przetwarzania XML-a
7Name: pugixml
f109191a 8Version: 1.10
d51802d6 9Release: 1
1392c26d
JB
10License: MIT
11Group: Libraries
92afb597
JB
12#Source0Download: http://pugixml.org/
13Source0: http://github.com/zeux/pugixml/releases/download/v%{version}/%{name}-%{version}.tar.gz
f109191a 14# Source0-md5: f97237e9908201c6d8536210747b66af
151a21f5 15Patch0: longlong.patch
1392c26d 16URL: http://pugixml.org/
d51802d6 17BuildRequires: cmake >= 2.8.12
1392c26d 18BuildRequires: libstdc++-devel
1392c26d
JB
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22pugixml is a C++ XML processing library, which consists of a DOM-like
23interface with rich traversal/modification capabilities, an extremely
24fast XML parser which constructs the DOM tree from an XML file/buffer,
25and an XPath 1.0 implementation for complex data-driven tree queries.
26Full Unicode support is also available, with Unicode interface
27variants and conversions between different Unicode encodings (which
28happen automatically during parsing/saving).
29
30%description -l pl.UTF-8
31pugixml to biblioteka C++ do przetwarzania XML-a, składająca się z
32interfejsu w stylu DOM z dużymi możliwościami przeglądania i
33modyfikowania, bardzo szybkim analizatorem XML-a tworzącym drzewo DOM
34z pliku/bufora XML oraz implementacji XPath 1.0 do złożonych zapytań
35drzewiastych zależnych od danych. Dostępna jest też pełna obsługa
36Unikodu, z wariantowym interfejsem i przekształcaniem między różnymi
37kodowaniami Unikodu (co wykonywane jest automatycznie podczas
38analizy/zapisu).
39
40%package devel
41Summary: Header files for pugixml library
42Summary(pl.UTF-8): Pliki nagłówkowe biblioteki pugixml
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: libstdc++-devel
46
47%description devel
48Header files for pugixml library.
49
50%description devel -l pl.UTF-8
51Pliki nagłówkowe biblioteki pugixml.
52
53%package static
54Summary: Static pugixml library
55Summary(pl.UTF-8): Statyczna biblioteka pugixml
56Group: Development/Libraries
57Requires: %{name}-devel = %{version}-%{release}
58
59%description static
60Static pugixml library.
61
62%description static -l pl.UTF-8
63Statyczna biblioteka pugixml.
64
65%prep
46c0eb2c 66%setup -q
151a21f5 67%patch0 -p1
1392c26d
JB
68
69%build
92afb597
JB
70install -d build
71cd build
72%cmake .. \
92afb597
JB
73 -DBUILD_SHARED_LIBS=ON
74cd ..
75
76%if %{with static_libs}
77install -d build-static
78cd build-static
79%cmake .. \
80 -DBUILD_SHARED_LIBS=OFF
81cd ..
82%endif
1392c26d
JB
83
84%install
85rm -rf $RPM_BUILD_ROOT
1392c26d 86
92afb597
JB
87%if %{with static_libs}
88%{__make} -C build-static install \
89 DESTDIR=$RPM_BUILD_ROOT
90%endif
91
92%{__make} -C build install \
93 DESTDIR=$RPM_BUILD_ROOT
1392c26d
JB
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%post -p /sbin/ldconfig
99%postun -p /sbin/ldconfig
100
101%files
102%defattr(644,root,root,755)
103%doc readme.txt
92afb597
JB
104%attr(755,root,root) %{_libdir}/libpugixml.so.*.*
105%attr(755,root,root) %ghost %{_libdir}/libpugixml.so.1
1392c26d
JB
106
107%files devel
108%defattr(644,root,root,755)
109%doc docs/*
110%attr(755,root,root) %{_libdir}/libpugixml.so
1392c26d
JB
111%{_includedir}/pugiconfig.hpp
112%{_includedir}/pugixml.hpp
92afb597
JB
113%{_pkgconfigdir}/pugixml.pc
114%{_libdir}/cmake/pugixml
1392c26d 115
92afb597 116%if %{with static_libs}
1392c26d
JB
117%files static
118%defattr(644,root,root,755)
119%{_libdir}/libpugixml.a
92afb597 120%endif
This page took 0.060356 seconds and 4 git commands to generate.