]> git.pld-linux.org Git - packages/pugixml.git/blame - pugixml.spec
- updated download URL
[packages/pugixml.git] / pugixml.spec
CommitLineData
92afb597
JB
1#
2# Conditional build:
3%bcond_without static_libs # static library
4#
1392c26d
JB
5Summary: C++ XML processing library
6Summary(pl.UTF-8): Biblioteka C++ do przetwarzania XML-a
7Name: pugixml
016f4c24 8Version: 1.11.4
b02ef1ae 9Release: 2
1392c26d
JB
10License: MIT
11Group: Libraries
e0c9a6e3
JB
12#Source0Download: https://github.com/zeux/pugixml/releases
13Source0: https://github.com/zeux/pugixml/releases/download/v%{version}/%{name}-%{version}.tar.gz
016f4c24 14# Source0-md5: 2d2730d3412b08d3e70c795bc17003df
151a21f5 15Patch0: longlong.patch
1392c26d 16URL: http://pugixml.org/
5aa586e7 17BuildRequires: cmake >= 3.4
1392c26d 18BuildRequires: libstdc++-devel
1392c26d
JB
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22pugixml is a C++ XML processing library, which consists of a DOM-like
23interface with rich traversal/modification capabilities, an extremely
24fast XML parser which constructs the DOM tree from an XML file/buffer,
25and an XPath 1.0 implementation for complex data-driven tree queries.
26Full Unicode support is also available, with Unicode interface
27variants and conversions between different Unicode encodings (which
28happen automatically during parsing/saving).
29
30%description -l pl.UTF-8
31pugixml to biblioteka C++ do przetwarzania XML-a, składająca się z
32interfejsu w stylu DOM z dużymi możliwościami przeglądania i
33modyfikowania, bardzo szybkim analizatorem XML-a tworzącym drzewo DOM
34z pliku/bufora XML oraz implementacji XPath 1.0 do złożonych zapytań
35drzewiastych zależnych od danych. Dostępna jest też pełna obsługa
36Unikodu, z wariantowym interfejsem i przekształcaniem między różnymi
37kodowaniami Unikodu (co wykonywane jest automatycznie podczas
38analizy/zapisu).
39
40%package devel
41Summary: Header files for pugixml library
42Summary(pl.UTF-8): Pliki nagłówkowe biblioteki pugixml
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: libstdc++-devel
46
47%description devel
48Header files for pugixml library.
49
50%description devel -l pl.UTF-8
51Pliki nagłówkowe biblioteki pugixml.
52
53%package static
54Summary: Static pugixml library
55Summary(pl.UTF-8): Statyczna biblioteka pugixml
56Group: Development/Libraries
57Requires: %{name}-devel = %{version}-%{release}
58
59%description static
60Static pugixml library.
61
62%description static -l pl.UTF-8
63Statyczna biblioteka pugixml.
64
65%prep
46c0eb2c 66%setup -q
151a21f5 67%patch0 -p1
1392c26d
JB
68
69%build
92afb597
JB
70install -d build
71cd build
72%cmake .. \
92afb597
JB
73 -DBUILD_SHARED_LIBS=ON
74cd ..
75
76%if %{with static_libs}
77install -d build-static
78cd build-static
79%cmake .. \
80 -DBUILD_SHARED_LIBS=OFF
81cd ..
82%endif
1392c26d
JB
83
84%install
85rm -rf $RPM_BUILD_ROOT
1392c26d 86
92afb597
JB
87%if %{with static_libs}
88%{__make} -C build-static install \
89 DESTDIR=$RPM_BUILD_ROOT
b02ef1ae
JB
90
91# force packaging cmake configs for shared target
92%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/cmake/pugixml
92afb597
JB
93%endif
94
95%{__make} -C build install \
96 DESTDIR=$RPM_BUILD_ROOT
1392c26d
JB
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%post -p /sbin/ldconfig
102%postun -p /sbin/ldconfig
103
104%files
105%defattr(644,root,root,755)
106%doc readme.txt
92afb597
JB
107%attr(755,root,root) %{_libdir}/libpugixml.so.*.*
108%attr(755,root,root) %ghost %{_libdir}/libpugixml.so.1
1392c26d
JB
109
110%files devel
111%defattr(644,root,root,755)
112%doc docs/*
113%attr(755,root,root) %{_libdir}/libpugixml.so
1392c26d
JB
114%{_includedir}/pugiconfig.hpp
115%{_includedir}/pugixml.hpp
92afb597
JB
116%{_pkgconfigdir}/pugixml.pc
117%{_libdir}/cmake/pugixml
1392c26d 118
92afb597 119%if %{with static_libs}
1392c26d
JB
120%files static
121%defattr(644,root,root,755)
122%{_libdir}/libpugixml.a
92afb597 123%endif
This page took 0.078993 seconds and 4 git commands to generate.