]> git.pld-linux.org Git - packages/ptex.git/blame - ptex.spec
- updated to 2.0.42
[packages/ptex.git] / ptex.spec
CommitLineData
953d1601
JB
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4#
5Summary: Ptex - texture mapping system by Walt Disney Animation Studios
6Summary(pl.UTF-8): Ptex - system odwzorowywania tekstur z Walt Disney Animation Studios
7Name: ptex
ef55886b 8Version: 2.0.42
953d1601
JB
9Release: 1
10License: BSD
11Group: Libraries
12# (not precisely: see github for releases, then fetch appropriate tarball)
13#Source0Download: https://github.com/wdas/ptex
ef55886b
JB
14Source0: https://github.com/wdas/ptex/tarball/v%{version}?/%{name}-%{version}.tar.gz
15# Source0-md5: 80181532ab9ef9dcc729344f45415c8b
953d1601
JB
16URL: http://ptex.us/
17%{?with_apidocs:BuildRequires: doxygen}
18BuildRequires: libstdc++-devel
19BuildRequires: zlib-devel
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Ptex is a texture mapping system developed by Walt Disney Animation
24Studios for production-quality rendering:
25- No UV assignment is required; Ptex applies a separate texture to
26 each face of a subdivision or polygon mesh.
27- The Ptex file format can efficiently store hundreds of thousands of
28 texture images in a single file.
29- The Ptex API provides cached file I/O and high-quality filtering -
30 everything that is needed to easily add Ptex support to a
31 production-quality renderer or texture authoring application.
32
33%description -l pl.UTF-8
34Ptex to system odwzorowywania tekstur stworzony przez Walt Disney
35Animation Studios do renderowania z jakością produkcyjną:
36- Nie wymaga przypisań UV; stosuje osobną teksturę dla każdej ściany
37 podziału lub siatki wielokątnej.
38- Format plików Ptex może wydajnie przechowywać setki tysięcy obrazów
39 tekstur w pojedynczym pliku.
40- API Ptex udostępnia operacje we/wy z buforowaniem oraz wysokiej
41 jakości filtrowanie - to wystarczy, żeby dodać obsługę plików Ptex
42 do renderera o jakości produkcyjnej lub aplikacji do tworzenia
43 tekstur.
44
45%package devel
46Summary: Header files for Ptex library
47Summary(pl.UTF-8): Pliki nagłówkowe biblioteki Ptex
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: libstdc++-devel
51Requires: zlib-devel
52
53%description devel
54Header files for Ptex library.
55
56%description devel -l pl.UTF-8
57Pliki nagłówkowe biblioteki Ptex.
58
59%package static
60Summary: Static Ptex library
61Summary(pl.UTF-8): Statyczna biblioteka Ptex
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64
65%description static
66Static Ptex library.
67
68%description static -l pl.UTF-8
69Statyczna biblioteka Ptex.
70
71%package apidocs
72Summary: Ptex API documentation
73Summary(pl.UTF-8): Dokumentacja API biblioteki Ptex
74Group: Documentation
75
76%description apidocs
77API and internal documentation for Ptex library.
78
79%description apidocs -l pl.UTF-8
80Dokumentacja API biblioteki Ptex.
81
82%prep
ef55886b 83%setup -q -n wdas-ptex-7e2cb22
953d1601
JB
84
85%build
86%{__make} -C src/ptex \
87 CXX="%{__cxx}" \
88 DEBUG="%{rpmcxxflags} %{rpmcppflags} -fPIC -DNDEBUG"
89
90%{__make} -C src/utils \
91 CXX="%{__cxx}" \
92 DEBUG="%{rpmcxxflags} %{rpmcppflags} -DNDEBUG"
93
94%if %{with apidocs}
95# make doc generates source docs, not just API; invoke doxygen manually
96#%{__make} -C src/doc
97cd src/doc
98install -d ../../install/apidocs/ptex
99doxygen Doxyfile_API_only
100%endif
101
102%install
103rm -rf $RPM_BUILD_ROOT
104
105%{__make} -C src/ptex install \
106 INSTALLDIR=$RPM_BUILD_ROOT%{_prefix} \
107 LIBDIR=%{_lib}
108
109%{__make} -C src/utils install \
110 INSTALLDIR=$RPM_BUILD_ROOT%{_prefix}
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post -p /sbin/ldconfig
116%postun -p /sbin/ldconfig
117
118%files
119%defattr(644,root,root,755)
120%doc src/doc/{FilterFootprint.html,License.txt}
121%attr(755,root,root) %{_bindir}/ptxinfo
122%attr(755,root,root) %{_libdir}/libPtex.so
123
124%files devel
125%defattr(644,root,root,755)
126%{_includedir}/Ptex*.h
127
128%files static
129%defattr(644,root,root,755)
130%{_libdir}/libPtex.a
131
132%if %{with apidocs}
133%files apidocs
134%defattr(644,root,root,755)
135%doc apidocs/*.{css,html,js,png}
136%endif
This page took 0.108389 seconds and 4 git commands to generate.