]> git.pld-linux.org Git - packages/pound.git/blame - pound.spec
ensure consistent build by enforcing options, BR tcmalloc
[packages/pound.git] / pound.spec
CommitLineData
73807a5d 1Summary: Pound - reverse-proxy and load-balancer
7fbec31c 2Summary(pl.UTF-8): Pound - reverse-proxy i load-balancer
73807a5d 3Name: pound
99431378 4Version: 2.6
e6ba7a2a 5Release: 7
361f3ee8 6License: GPL v3
73807a5d 7Group: Networking/Daemons
73807a5d 8Source0: http://www.apsis.ch/pound/Pound-%{version}.tgz
99431378 9# Source0-md5: 8c913b527332694943c4c67c8f152071
8a12d360
JR
10Source1: %{name}.cfg
11Source2: %{name}.init
12Source3: %{name}.sysconfig
13Source4: %{name}.logrotate
14Source5: %{name}.tmpfiles
487cceae
ER
15Patch0: %{name}-hash-UL.patch
16Patch1: %{name}-logfile.patch
17Patch2: %{name}-daemonize.patch
18Patch3: %{name}-log-notice.patch
19Patch4: %{name}-man.patch
73807a5d 20URL: http://www.apsis.ch/pound/
f8a55c4f 21BuildRequires: automake
7c4d13be 22BuildRequires: libtcmalloc-devel
18e83af5 23BuildRequires: openssl-devel >= 0.9.7d
335ccc63 24BuildRequires: openssl-tools
f8a55c4f 25BuildRequires: pcre-devel
0453b2b1 26BuildRequires: rpmbuild(macros) >= 1.644
6e57d9ed 27Requires(post,preun): /sbin/chkconfig
5474a5a6
ER
28Requires(postun): /usr/sbin/groupdel
29Requires(postun): /usr/sbin/userdel
30Requires(pre): /bin/id
31Requires(pre): /usr/bin/getgid
32Requires(pre): /usr/sbin/groupadd
33Requires(pre): /usr/sbin/useradd
767184e8 34Requires: pcre >= 7.8
2dbe9c52 35Requires: rc-scripts
5474a5a6
ER
36Provides: group(pound)
37Provides: user(pound)
6b1b2506 38Conflicts: logrotate < 3.7-4
73807a5d 39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
9df600c4
ER
41%define _sysconfdir /etc/pound
42
73807a5d 43%description
44The Pound program is a reverse proxy, load balancer and HTTPS
45front-end for Web server(s). Pound was developped to enable
46distributing the load among several Web-servers and to allow for a
47convenient SSL wrapper for those Web servers that do not offer it
48natively. Pound is distributed under the GPL - no warranty, it's free
49to use, copy and give away.
50
ebd232a4 51%description -l pl.UTF-8
f8243939 52Program Pound jest odwrotnym proxy, load-balancerem i interfejsem
ebd232a4
JR
53HTTPS do serwera(ów) WWW. Pount został stworzony by pozwolić na
54rozdzielenie obciążenia na kilka serwerów WWW i pozwolić na wygodne
55opakowanie SSL-em tych serwerów, które same nie obsługują SSL. Pound
56jest rozpowszechniany na licencji GPL - bez gwarancji, z możliwością
57swobodnego używania, kopiowania i rozdawania.
f8243939 58
73807a5d 59%prep
fd0369ad 60%setup -q -n Pound-%{version}
9df600c4
ER
61%patch0 -p1
62%patch1 -p1
63%patch2 -p1
6b1b2506
ER
64%patch3 -p1
65%patch4 -p1
73807a5d 66
67%build
f8a55c4f 68cp -f /usr/share/automake/config.sub .
9ea1ad0e 69%configure \
7c4d13be
ER
70 --enable-super \
71 --enable-pcreposix \
72 --enable-tcmalloc \
73 --disable-hoard \
e6ba7a2a 74 --with-maxbuf=6144
9df600c4 75%{__make}
73807a5d 76
77%install
78rm -rf $RPM_BUILD_ROOT
6b1b2506 79install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8,%{_sysconfdir},/etc/{sysconfig,logrotate.d,rc.d/init.d}} \
8a12d360 80 $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}} \
0453b2b1 81 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
73807a5d 82
e6ba7a2a 83install -p pound $RPM_BUILD_ROOT%{_sbindir}
b329097e
ER
84install -p poundctl $RPM_BUILD_ROOT%{_sbindir}
85cp -p pound.8 $RPM_BUILD_ROOT%{_mandir}/man8
86cp -p poundctl.8 $RPM_BUILD_ROOT%{_mandir}/man8
87cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
88install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
89cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
90cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
e6ba7a2a 91cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
8a12d360 92
6e57d9ed
JB
93%clean
94rm -rf $RPM_BUILD_ROOT
95
5474a5a6
ER
96%pre
97%groupadd -g 200 %{name}
98%useradd -u 200 -d /var/lib/%{name} -g %{name} -c "Pound Daemon" %{name}
99
73807a5d 100%post
6b1b2506
ER
101for a in access.log pound.log; do
102 if [ ! -f /var/log/%{name}/$a ]; then
103 touch /var/log/%{name}/$a
104 chown pound:pound /var/log/%{name}/$a
105 chmod 644 /var/log/%{name}/$a
106 fi
107done
73807a5d 108/sbin/chkconfig --add %{name}
5474a5a6 109%service %{name} restart "Pound Daemon"
73807a5d 110
111%preun
cfc0cb59
ER
112if [ "$1" = "0" ]; then
113 %service %{name} stop
114 /sbin/chkconfig --del %{name}
73807a5d 115fi
73807a5d 116
5474a5a6
ER
117%postun
118if [ "$1" = "0" ]; then
119 %userremove %{name}
120 %groupremove %{name}
121fi
122
73807a5d 123%files
124%defattr(644,root,root,755)
35c6c398 125%doc README FAQ CHANGELOG z*.py
6b1b2506
ER
126%attr(755,root,root) %{_sbindir}/pound
127%attr(755,root,root) %{_sbindir}/poundctl
9df600c4
ER
128%dir %{_sysconfdir}
129%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pound.cfg
ef2dd428 130%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
6b1b2506 131%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
9a81a858 132%attr(754,root,root) /etc/rc.d/init.d/%{name}
83dd8e4d 133%{_mandir}/man8/*
0453b2b1 134%{systemdtmpfilesdir}/%{name}.conf
5474a5a6 135%dir /var/run/%{name}
9df600c4
ER
136%dir %attr(751,root,root) /var/log/%{name}
137%attr(750,root,root) %dir /var/log/archive/%{name}
This page took 0.04407 seconds and 4 git commands to generate.