]> git.pld-linux.org Git - packages/postgis.git/blame - postgis.spec
- one more fix for json-c 0.12
[packages/postgis.git] / postgis.spec
CommitLineData
32e16a3a 1%define pg_version %(rpm -q --queryformat '%{VERSION}' postgresql-backend-devel)
f2588acb 2%define beta %{nil}
7045685f 3#
fc587bde 4# Conditional build:
7045685f
JB
5%bcond_without raster # disable raster support
6%bcond_without doc # HTML documentation
7%bcond_without gui # data import GUI
8#
32e16a3a 9Summary: Geographic Information Systems Extensions to PostgreSQL
11d12754 10Summary(pl.UTF-8): Rozszerzenie do PostgreSQL wspomagające Geograficzne Systemy Informacyjne
32e16a3a 11Name: postgis
7d744938 12Version: 2.1.3
9d5295c5 13Release: 4
4203f720 14License: GPL v2+
32e16a3a 15Group: Applications/Databases
6157b8c2 16Source0: http://download.osgeo.org/postgis/source/%{name}-%{version}%{beta}.tar.gz
7d744938 17# Source0-md5: 104e4468429ea0882259fc268c62d6c7
83cabce9 18Patch0: json-c-0.12.patch
32e16a3a 19URL: http://postgis.refractions.net/
fc587bde 20%{?with_raster:BuildRequires: gdal-devel >= 1.6.0}
83cabce9 21BuildRequires: gdal-devel
8455414f 22BuildRequires: geos-devel >= 3.3.2
7045685f
JB
23BuildRequires: json-c-devel
24BuildRequires: libstdc++-devel
def64c02 25BuildRequires: libxml2-devel
a6fb65b0 26BuildRequires: perl-base
7045685f
JB
27BuildRequires: postgresql-backend-devel >= 8.3
28BuildRequires: postgresql-devel >= 8.3
29BuildRequires: proj-devel >= 4.5.0
30%if %{with doc}
31BuildRequires: ImageMagick
32BuildRequires: docbook-style-xsl
33BuildRequires: libxml2-progs
34BuildRequires: libxslt-progs
35%endif
36%if %{with gui}
37BuildRequires: gtk+2-devel >= 2:2.8.0
38BuildRequires: pkgconfig
39%endif
92489202 40%{?with_raster:Requires: gdal >= 1.6.0}
7045685f 41Requires: liblwgeom = %{version}-%{release}
32e16a3a
MM
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
def64c02 44%define specflags_x86_64 -fPIC
45
32e16a3a
MM
46# oh well... I also don't understand this... ;)
47
48%description
49This package contains a module which implements GIS simple features,
50ties the features to rtree indexing, and provides some spatial
51functions for accessing and analyzing geographic data.
52
c7a5e637
JR
53%description -l pl.UTF-8
54Pakiet ten zawiera moduł implementujący proste funkcje GIS, wiąże je z
55indeksowaniem rtree oraz dostarcza funkcje dostępu oraz analizy danych
32e16a3a
MM
56geograficznych.
57
7045685f
JB
58%package gui
59Summary: Data import GUI for PostGIS
60Summary(pl.UTF-8): Graficzny interfejs użytkownika importujący dane dla PostGIS-a
61Group: X11/Applications
62Requires: %{name} = %{version}-%{release}
fc59c3d1 63Requires: gtk+2 >= 2:2.8.0
7045685f
JB
64
65%description gui
66Data import GUI for PostGIS.
67
68%description gui -l pl.UTF-8
69Graficzny interfejs użytkownika importujący dane dla PostGIS-a.
70
71%package -n liblwgeom
72Summary: lwgeom library (a part of PostGIS project)
73Summary(pl.UTF-8): Biblioteka lwgeom (część projektu PostGIS)
74Group: Libraries
8455414f 75Requires: geos >= 3.3.2
7045685f
JB
76Requires: proj >= 4.5.0
77Conflicts: postgis < 2.0.0-2
78
79%description -n liblwgeom
80lwgeom library (a part of PostGIS project).
81
82%description -n liblwgeom -l pl.UTF-8
83Biblioteka lwgeom (część projektu PostGIS).
84
85%package -n liblwgeom-devel
86Summary: Header file for lwgeom library
87Summary(pl.UTF-8): Plik nagłówkowy biblioteki lwgeom
88Group: Development/Libraries
8455414f 89Requires: geos-devel >= 3.3.2
7045685f
JB
90Requires: liblwgeom = %{version}-%{release}
91Requires: proj-devel >= 4.5.0
92
93%description -n liblwgeom-devel
94Header file for lwgeom library.
95
96%description -n liblwgeom-devel -l pl.UTF-8
97Plik nagłówkowy biblioteki lwgeom.
98
99%package -n liblwgeom-static
100Summary: Static lwgeom library
101Summary(pl.UTF-8): Statyczna biblioteka lwgeom
102Group: Development/Libraries
103Requires: liblwgeom-devel = %{version}-%{release}
104
105%description -n liblwgeom-static
106Static lwgeom library.
107
108%description -n liblwgeom-static -l pl.UTF-8
109Statyczna biblioteka lwgeom.
110
32e16a3a 111%prep
7045685f 112%setup -q -n %{name}-%{version}%{beta}
83cabce9 113%patch0 -p1
32e16a3a
MM
114
115%build
81e2cdad 116%configure \
117 --with-geos \
9dd90af9 118 --with-geos-libdir=/usr/%{_lib} \
7045685f 119 %{?with_gui:--with-gui} \
81e2cdad 120 --with-pgsql \
42e18f0f 121 --with-proj=%{_prefix} \
fc587bde 122 --with-proj-libdir=/usr/%{_lib} \
123 %{!?with_raster:--without-raster}
9dd90af9 124
da374675 125%{__make}
32e16a3a
MM
126
127%install
128rm -rf $RPM_BUILD_ROOT
1393aae1 129
7045685f
JB
130%{__make} install \
131 DESTDIR=$RPM_BUILD_ROOT
1393aae1 132
32e16a3a
MM
133%clean
134rm -rf $RPM_BUILD_ROOT
135
7045685f
JB
136%post -n liblwgeom -p /sbin/ldconfig
137%postun -n liblwgeom -p /sbin/ldconfig
138
32e16a3a
MM
139%files
140%defattr(644,root,root,755)
92489202 141%doc CREDITS LICENSE.TXT NEWS README.postgis TODO %{?with_doc:doc/html}
7045685f
JB
142%attr(755,root,root) %{_bindir}/pgsql2shp
143%attr(755,root,root) %{_bindir}/shp2pgsql
94b1d95e 144%attr(755,root,root) %{_libdir}/postgresql/postgis-2.1.so
145%{_datadir}/postgresql/contrib/postgis-2.1
7045685f
JB
146%if %{with raster}
147%attr(755,root,root) %{_bindir}/raster2pgsql
94b1d95e 148%attr(755,root,root) %{_libdir}/postgresql/rtpostgis-2.1.so
7045685f
JB
149%{_datadir}/postgresql/extension/postgis*.control
150%{_datadir}/postgresql/extension/postgis*.sql
151%endif
152
153%if %{with gui}
154%files gui
155%defattr(644,root,root,755)
156%attr(755,root,root) %{_bindir}/shp2pgsql-gui
157%endif
158
159%files -n liblwgeom
160%defattr(644,root,root,755)
fdd6c2b3 161%attr(755,root,root) %{_libdir}/liblwgeom-?.?.?.so
7045685f
JB
162
163%files -n liblwgeom-devel
164%defattr(644,root,root,755)
165%attr(755,root,root) %{_libdir}/liblwgeom.so
166%{_libdir}/liblwgeom.la
167%{_includedir}/liblwgeom.h
168
169%files -n liblwgeom-static
170%defattr(644,root,root,755)
171%{_libdir}/liblwgeom.a
This page took 0.132251 seconds and 4 git commands to generate.