]> git.pld-linux.org Git - packages/podman.git/blame - podman.spec
up to 4.7.2
[packages/podman.git] / podman.spec
CommitLineData
18c175b8
JP
1Summary: A tool for managing OCI containers and pods
2Name: podman
dfbc4ec4 3Version: 4.7.2
18c175b8
JP
4Release: 1
5License: Apache v2.0
6Group: Applications/System
7#Source0Download: https://github.com/containers/podman/releases
8Source0: https://github.com/containers/podman/archive/v%{version}/%{name}-%{version}.tar.gz
dfbc4ec4 9# Source0-md5: 4b78f4b222e5d6e9eaaf3c74ef91e973
35a38226 10Source1: policy.json
00346cb1 11Source2: registries.conf
18c175b8 12URL: https://github.com/containers/podman
0f65ad8d 13BuildRequires: btrfs-progs-devel
cbf5965c 14BuildRequires: device-mapper-devel
18c175b8 15BuildRequires: go-md2man
b39c9586 16BuildRequires: golang >= 1.18
18c175b8 17BuildRequires: golang-varlink
cbf5965c
JP
18BuildRequires: gpgme-devel
19BuildRequires: libseccomp-devel
20BuildRequires: pkgconfig
5b992af5 21BuildRequires: python3-modules
93c72252 22BuildRequires: rpm-build >= 4.6
48a1ddc7 23BuildRequires: rpmbuild(macros) >= 2.009
cbf5965c 24BuildRequires: systemd-devel
18c175b8
JP
25Requires: conmon
26Requires: crun
07e93123 27Requires: netavark
2d104b8a
JP
28Suggests: slirp4netns
29Suggests: uidmap
d113c837 30ExclusiveArch: %go_arches
18c175b8
JP
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
8a009d33
JP
33%define _enable_debug_packages 0
34
18c175b8
JP
35%description
36Podman (the POD MANager) is a tool for managing containers and images,
37volumes mounted into those containers, and pods made from groups of
38containers. Podman is based on libpod, a library for container
39lifecycle management that is also contained in this repository. The
40libpod library provides APIs for managing containers, pods, container
41images, and volumes.
42
93c72252
JP
43%package -n bash-completion-podman
44Summary: bash-completion for podman
45Group: Applications/Shells
46Requires: %{name} = %{version}-%{release}
0c669cb0 47Requires: bash-completion >= 1:2.0
93c72252
JP
48BuildArch: noarch
49
50%description -n bash-completion-podman
51This package provides bash-completion for podman.
52
53%package -n fish-completion-podman
54Summary: Fish completion for podman command
55Group: Applications/Shells
56Requires: %{name} = %{version}-%{release}
57Requires: fish
58BuildArch: noarch
59
60%description -n fish-completion-podman
61Fish completion for podman command.
62
63%package -n zsh-completion-podman
64Summary: Zsh completion for podman command
65Group: Applications/Shells
66Requires: %{name} = %{version}-%{release}
67Requires: zsh
68BuildArch: noarch
69
70%description -n zsh-completion-podman
71Zsh completion for podman command.
72
18c175b8
JP
73%prep
74%setup -q
75
76%build
b89df2eb 77%{__make} -j1 \
a6a3c572 78 GO=/usr/bin/go \
48a1ddc7 79 GOCMD="CGO_ENABLED=1 %__go" \
e908b902 80 GOPATH=$(pwd)/.gopath \
e7ee545a
JP
81 PREFIX="%{_prefix}" \
82 BINDIR="%{_bindir}" \
83 LIBEXECDIR="%{_libexecdir}" \
84 MANDIR="%{_mandir}" \
85 SHAREDIR_CONTAINERS="%{_datadir}/containers" \
86 ETCDIR="%{_sysconfdir}" \
87 TMPFILESDIR="%{systemdtmpfilesdir}" \
88 SYSTEMDDIR="%{systemdunitdir}" \
89 USERSYSTEMDDIR="%{systemduserunitdir}" \
90 PYTHON="%{__python3}"
18c175b8
JP
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
ad6ad319 95install -d $RPM_BUILD_ROOT{%{_sysconfdir}/containers,%{bash_compdir},%{fish_compdir},%{zsh_compdir},%{_sharedstatedir}/containers}
35a38226 96
18c175b8
JP
97%{__make} install \
98 DESTDIR=$RPM_BUILD_ROOT \
e7ee545a
JP
99 PREFIX="%{_prefix}" \
100 BINDIR="%{_bindir}" \
101 LIBEXECDIR="%{_libexecdir}" \
102 MANDIR="%{_mandir}" \
103 SHAREDIR_CONTAINERS="%{_datadir}/containers" \
104 ETCDIR="%{_sysconfdir}" \
105 TMPFILESDIR="%{systemdtmpfilesdir}" \
106 SYSTEMDDIR="%{systemdunitdir}" \
b39c9586
JP
107 SYSTEMDGENERATORSDIR="%{_systemdgeneratordir}" \
108 USERSYSTEMDGENERATORSDIR="%{_systemdusergeneratordir}" \
e7ee545a
JP
109 USERSYSTEMDDIR="%{systemduserunitdir}" \
110 PYTHON="%{__python3}"
18c175b8 111
ad6ad319
JP
112cp -p %{SOURCE1} %{SOURCE2} \
113 vendor/github.com/containers/common/pkg/config/containers.conf \
114 $RPM_BUILD_ROOT%{_sysconfdir}/containers
115
116%{__sed} -e 's|/var/lib/containers|%{_sharedstatedir}/containers|g' \
117 vendor/github.com/containers/storage/storage.conf \
8e304485 118 > $RPM_BUILD_ROOT%{_sysconfdir}/containers/storage.conf
35a38226 119
93c72252
JP
120$RPM_BUILD_ROOT%{_bindir}/podman completion -f $RPM_BUILD_ROOT%{bash_compdir}/podman bash
121$RPM_BUILD_ROOT%{_bindir}/podman completion -f $RPM_BUILD_ROOT%{fish_compdir}/podman.fish fish
122$RPM_BUILD_ROOT%{_bindir}/podman completion -f $RPM_BUILD_ROOT%{zsh_compdir}/_podman zsh
123
18c175b8
JP
124%clean
125rm -rf $RPM_BUILD_ROOT
126
b74ba7ea
JP
127%post
128%systemd_post podman.service podman.socket
129
130%preun
131%systemd_preun podman.service podman.socket
132
133%postun
134%systemd_reload
135
18c175b8
JP
136%files
137%defattr(644,root,root,755)
c22a6efc 138%doc README.md
35a38226 139%dir %{_sysconfdir}/containers
ad6ad319 140%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/containers/containers.conf
35a38226 141%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/containers/policy.json
00346cb1 142%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/containers/registries.conf
ad6ad319 143%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/containers/storage.conf
18c175b8
JP
144%attr(755,root,root) %{_bindir}/podman
145%attr(755,root,root) %{_bindir}/podman-remote
33556b7f 146%attr(755,root,root) %{_bindir}/podmansh
5cd7f4f0 147%dir %{_libexecdir}/podman
b39c9586 148%attr(755,root,root) %{_libexecdir}/podman/quadlet
5cd7f4f0 149%attr(755,root,root) %{_libexecdir}/podman/rootlessport
18c175b8
JP
150%{systemdunitdir}/podman.service
151%{systemdunitdir}/podman.socket
a6a3c572
JP
152%{systemdunitdir}/podman-auto-update.service
153%{systemdunitdir}/podman-auto-update.timer
b39c9586 154%{systemdunitdir}/podman-clean-transient.service
b1d9f423 155%{systemdunitdir}/podman-kube@.service
41286851 156%{systemdunitdir}/podman-restart.service
b39c9586 157%{_systemdgeneratordir}/podman-system-generator
18c175b8
JP
158%{systemduserunitdir}/podman.service
159%{systemduserunitdir}/podman.socket
a6a3c572
JP
160%{systemduserunitdir}/podman-auto-update.service
161%{systemduserunitdir}/podman-auto-update.timer
b1d9f423 162%{systemduserunitdir}/podman-kube@.service
41286851 163%{systemduserunitdir}/podman-restart.service
b39c9586 164%{_systemdusergeneratordir}/podman-user-generator
18c175b8 165%{_mandir}/man1/podman*.1*
708445ad
JP
166%{_mandir}/man5/podman-systemd.unit.5*
167%{_mandir}/man5/quadlet.5*
e7ee545a 168/usr/lib/tmpfiles.d/podman.conf
ad6ad319 169%dir %{_sharedstatedir}/containers
93c72252
JP
170
171%files -n bash-completion-podman
172%defattr(644,root,root,755)
173%{bash_compdir}/podman
174
175%files -n fish-completion-%{name}
176%defattr(644,root,root,755)
177%{fish_compdir}/podman.fish
178
179%files -n zsh-completion-%{name}
180%defattr(644,root,root,755)
181%{zsh_compdir}/_podman
This page took 0.759026 seconds and 4 git commands to generate.