]> git.pld-linux.org Git - packages/physfs.git/blame - physfs.spec
- initial
[packages/physfs.git] / physfs.spec
CommitLineData
c617ed92 1Summary: PhysicsFS file abstraction layer for games
2Name: physfs
3Version: 0.1.8
4Release: 1
5License: LGPL
6Group: Libraries
7Source0: http://www.icculus.org/physfs/downloads/%{name}-%{version}.tar.gz
8URL: http://www.icculus.org/physfs/
9BuildRequires: doxygen
10BuildRequires: ncurses-devel
11BuildRequires: readline-devel
12BuildRequires: zlib-devel
13BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15%description
16PhysicsFS is a library to provide abstract access to various archives.
17It is intended for use in video games, and the design was somewhat inspired
18by Quake 3's file subsystem. The programmer defines a "write directory" on
19the physical filesystem. No file writing done through the PhysicsFS API can
20leave that write directory, for security. For example, an embedded scripting
21language cannot write outside of this path if it uses PhysFS for all of its
22I/O, which means that untrusted scripts can run more safely. Symbolic links
23can be disabled as well, for added safety. For file reading, the programmer
24lists directories and archives that form a "search path". Once the search
25path is defined, it becomes a single, transparent hierarchical filesystem.
26This makes for easy access to ZIP files in the same way as you access a file
27directly on the disk, and it makes it easy to ship a new archive that will
28override a previous archive on a per-file basis. Finally, PhysicsFS gives
29you platform-abstracted means to determine if CD-ROMs are available, the
30user's home directory, where in the real filesystem your program is running,
31etc.
32
33%package devel
34Summary: Header files for PhysicsFS development
35Group: Development/Libraries
36Requires: %{name} = %{version}
37
38%description devel
39PhysicsFS is a library to provide abstract access to various archives.
40This package contains the development headers, libraries, and documentaion to
41build programs using PhysicsFS.
42
43%package static
44Summary: Static libraries for PhysicsFS development
45Group: Development/Libraries
46Requires: %{name}-devel = %{version}
47
48%description static
49PhysicsFS is a library to provide abstract access to various archives.
50This package contains the static libraries to build programs using PhysicsFS.
51
52%package programs
53Summary: Program for testing PhysicsFS archives
54Group: Development/Libraries
55
56%description programs
57PhysicsFS is a library to provide abstract access to various archives.
58This package contains the programs using for PhysicsFS archives testing.
59
60%prep
61%setup
62
63%build
64%configure
65%{__make}
66
67doxygen
68
69%install
70rm -rf $RPM_BUILD_ROOT
71install -d $RPM_BUILD_ROOT%{_mandir}/man3
72
73make install DESTDIR=${RPM_BUILD_ROOT}
74
75install docs/man/man3/{PHYS*,phys*} $RPM_BUILD_ROOT%{_mandir}/man3
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post -p /sbin/ldconfig
81%postun -p /sbin/ldconfig
82
83%files
84%defattr(644,root,root,755)
85%doc CHANGELOG CREDITS
86%attr(755,root,root) %{_libdir}/lib*.so.*.*
87
88%files devel
89%defattr(644,root,root,755)
90%doc docs/html
91%{_libdir}/lib*.la
92%{_libdir}/lib*.so
93%{_includedir}/physfs.h
94%{_mandir}/man3/*
95
96%files static
97%defattr(644,root,root,755)
98%{_libdir}/lib*.a
99
100%files programs
101%defattr(644,root,root,755)
102%{_bindir}/test_physfs
This page took 0.076885 seconds and 4 git commands to generate.