]> git.pld-linux.org Git - packages/phpstorm.git/blame - phpstorm.spec
up to 2016.1.1
[packages/phpstorm.git] / phpstorm.spec
CommitLineData
24daebe3 1%include /usr/lib/rpm/macros.java
265003bd
ER
2Summary: Lightweight and Smart PHP IDE
3Name: phpstorm
fb9f138c 4Version: 2016.1.1
7246d0bc 5Release: 1
01772af1 6# TODO: figure out what's the licensing and redistribution
265003bd
ER
7License: ?
8Group: Development/Tools
0304cfdc 9Source0: https://download.jetbrains.com/webide/PhpStorm-%{version}.tar.gz
fb9f138c 10# NoSource0-md5: 2867f819039d5cd4844897c80c857b9a
265003bd 11NoSource: 0
1720293b 12Source1: %{name}.desktop
486dfff4 13Source2: %{name}.py
8c2db59b 14Patch0: pld.patch
265003bd 15URL: http://www.jetbrains.com/phpstorm/
24daebe3
ER
16BuildRequires: jpackage-utils
17BuildRequires: rpm-javaprov
18BuildRequires: rpmbuild(macros) >= 1.300
265003bd 19BuildRequires: unzip
cc0a19f5 20Requires: jre-X11 >= 1.7
8c2db59b 21Requires: which
71ebdb62
ER
22Suggests: cvs
23Suggests: git-core
88bc6db6 24Suggests: java-jdbc-mysql
71ebdb62 25Suggests: subversion
88bc6db6 26Conflicts: java-jdbc-mysql < 5.1.22
265003bd
ER
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
1f07e370
ER
29# don't strip fsnotifier, it's size is checked for "outdated binary"
30# https://bugs.archlinux.org/task/34703
31# http://git.jetbrains.org/?p=idea/community.git;a=blob;f=platform/platform-impl/src/com/intellij/openapi/vfs/impl/local/FileWatcher.java;h=004311b96a35df1ffc2c87baba78a8b2a8809f7d;hb=376b939fd6d6ec4c12191a5f90503d9d62c501da#l173
32%define _noautostrip .*/fsnotifier.*
33
01772af1 34# use /usr/lib, 64bit files do not conflict with 32bit files (64 suffix)
9c78341a
ER
35# this allows to install both arch files and to use 32bit jdk on 64bit os
36%define _appdir %{_prefix}/lib/%{name}
265003bd
ER
37
38%description
39PhpStorm is a lightweight and smart PHP IDE focused on developer
40productivity that deeply understands your code, provides smart code
41completion, quick navigation and on-the-fly error checking. It is
42always ready to help you shape your code, run unit-tests or provide
43visual debugging.
44
45Note: PhpStorm includes all the functionality of WebStorm (HTML/CSS
46Editor, JavaScript Editor) and adds full-fledged support for PHP.
47
48%prep
fb9f138c 49%setup -qn PhpStorm-145.970.40
ae6c8231
ER
50
51# keep only single arch files (don't want to pull 32bit deps by default),
52# if you want to mix, install rpm from both arch
265003bd
ER
53%ifarch %{ix86}
54rm bin/fsnotifier64
ae6c8231
ER
55rm bin/libyjpagent-linux64.so
56rm bin/phpstorm64.vmoptions
1444622e 57rm -r lib/libpty/linux/x86_64
265003bd
ER
58%endif
59%ifarch %{x8664}
9c78341a 60rm bin/fsnotifier
ae6c8231
ER
61rm bin/libyjpagent-linux.so
62rm bin/phpstorm.vmoptions
1444622e 63rm -r lib/libpty/linux/x86
265003bd 64%endif
1444622e 65rm -r lib/libpty/{macosx,win}
794e16f3 66rm bin/fsnotifier-arm
8c2db59b 67%patch0 -p1
794e16f3 68chmod a+rx bin/*.so bin/fsnotifier* lib/libpty/linux/*/libpty.so
265003bd
ER
69mv bin/webide.png .
70
d2ed7e5a
ER
71# cleanup backups after patching
72find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
73
265003bd
ER
74%install
75rm -rf $RPM_BUILD_ROOT
76install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_pixmapsdir},%{_desktopdir}}
1720293b 77cp -l build.txt $RPM_BUILD_ROOT/cp-test && l=l && rm -f $RPM_BUILD_ROOT/cp-test
794e16f3 78cp -a$l bin help lib plugins $RPM_BUILD_ROOT%{_appdir}
f3107250
ER
79ln -s %{_pixmapsdir}/%{name}.png $RPM_BUILD_ROOT%{_appdir}/bin
80cp -p webide.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
1720293b 81cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
486dfff4 82install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}
17c1946d 83ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/pstorm
265003bd
ER
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(644,root,root,755)
425880c4 90%attr(755,root,root) %{_bindir}/%{name}
17c1946d 91%attr(755,root,root) %{_bindir}/pstorm
265003bd
ER
92%dir %{_appdir}
93%{_appdir}/help
265003bd
ER
94%{_appdir}/plugins
95%dir %{_appdir}/bin
1444622e 96%{_appdir}/bin/%{name}*.vmoptions
486dfff4 97%{_appdir}/bin/%{name}.png
265003bd
ER
98%{_appdir}/bin/idea.properties
99%{_appdir}/bin/log.xml
1444622e 100%attr(755,root,root) %{_appdir}/bin/%{name}.sh
ae6c8231 101%attr(755,root,root) %{_appdir}/bin/inspect.sh
9c78341a 102%attr(755,root,root) %{_appdir}/bin/fsnotifier*
ae6c8231 103%attr(755,root,root) %{_appdir}/bin/libyjpagent-linux*.so
1444622e
ER
104%dir %{_appdir}/lib
105%{_appdir}/lib/*.jar
106%dir %{_appdir}/lib/ext
107%{_appdir}/lib/ext/*.jar
108%dir %{_appdir}/lib/libpty
109%dir %{_appdir}/lib/libpty/linux
110%dir %{_appdir}/lib/libpty/linux/x86*
111%attr(755,root,root) %{_appdir}/lib/libpty/linux/x86*/libpty.so
1720293b 112%{_desktopdir}/%{name}.desktop
265003bd 113%{_pixmapsdir}/%{name}.png
This page took 0.087193 seconds and 4 git commands to generate.