]> git.pld-linux.org Git - packages/phpstorm.git/blame - phpstorm.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/phpstorm.git] / phpstorm.spec
CommitLineData
265003bd
ER
1Summary: Lightweight and Smart PHP IDE
2Name: phpstorm
71296179 3Version: 2017.1.4
7246d0bc 4Release: 1
01772af1 5# TODO: figure out what's the licensing and redistribution
265003bd
ER
6License: ?
7Group: Development/Tools
0304cfdc 8Source0: https://download.jetbrains.com/webide/PhpStorm-%{version}.tar.gz
71296179 9# NoSource0-md5: 1aa6f479b6edb92586388acb0b8e73a2
265003bd 10NoSource: 0
1720293b 11Source1: %{name}.desktop
486dfff4 12Source2: %{name}.py
8c2db59b 13Patch0: pld.patch
265003bd 14URL: http://www.jetbrains.com/phpstorm/
24daebe3
ER
15BuildRequires: jpackage-utils
16BuildRequires: rpm-javaprov
17BuildRequires: rpmbuild(macros) >= 1.300
265003bd 18BuildRequires: unzip
cc0a19f5 19Requires: jre-X11 >= 1.7
8c2db59b 20Requires: which
71ebdb62
ER
21Suggests: cvs
22Suggests: git-core
88bc6db6 23Suggests: java-jdbc-mysql
71ebdb62 24Suggests: subversion
88bc6db6 25Conflicts: java-jdbc-mysql < 5.1.22
265003bd
ER
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
1f07e370
ER
28# don't strip fsnotifier, it's size is checked for "outdated binary"
29# https://bugs.archlinux.org/task/34703
30# http://git.jetbrains.org/?p=idea/community.git;a=blob;f=platform/platform-impl/src/com/intellij/openapi/vfs/impl/local/FileWatcher.java;h=004311b96a35df1ffc2c87baba78a8b2a8809f7d;hb=376b939fd6d6ec4c12191a5f90503d9d62c501da#l173
31%define _noautostrip .*/fsnotifier.*
32
01772af1 33# use /usr/lib, 64bit files do not conflict with 32bit files (64 suffix)
9c78341a
ER
34# this allows to install both arch files and to use 32bit jdk on 64bit os
35%define _appdir %{_prefix}/lib/%{name}
265003bd
ER
36
37%description
38PhpStorm is a lightweight and smart PHP IDE focused on developer
39productivity that deeply understands your code, provides smart code
40completion, quick navigation and on-the-fly error checking. It is
41always ready to help you shape your code, run unit-tests or provide
42visual debugging.
43
44Note: PhpStorm includes all the functionality of WebStorm (HTML/CSS
45Editor, JavaScript Editor) and adds full-fledged support for PHP.
46
47%prep
71296179 48%setup -qn PhpStorm-171.4694.2
ae6c8231
ER
49
50# keep only single arch files (don't want to pull 32bit deps by default),
51# if you want to mix, install rpm from both arch
265003bd
ER
52%ifarch %{ix86}
53rm bin/fsnotifier64
ae6c8231
ER
54rm bin/libyjpagent-linux64.so
55rm bin/phpstorm64.vmoptions
1444622e 56rm -r lib/libpty/linux/x86_64
265003bd
ER
57%endif
58%ifarch %{x8664}
9c78341a 59rm bin/fsnotifier
ae6c8231
ER
60rm bin/libyjpagent-linux.so
61rm bin/phpstorm.vmoptions
1444622e 62rm -r lib/libpty/linux/x86
265003bd 63%endif
794e16f3 64rm bin/fsnotifier-arm
8c2db59b 65%patch0 -p1
794e16f3 66chmod a+rx bin/*.so bin/fsnotifier* lib/libpty/linux/*/libpty.so
da262f07 67mv bin/phpstorm.png .
265003bd 68
d2ed7e5a
ER
69# cleanup backups after patching
70find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
71
265003bd
ER
72%install
73rm -rf $RPM_BUILD_ROOT
74install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_pixmapsdir},%{_desktopdir}}
1720293b 75cp -l build.txt $RPM_BUILD_ROOT/cp-test && l=l && rm -f $RPM_BUILD_ROOT/cp-test
794e16f3 76cp -a$l bin help lib plugins $RPM_BUILD_ROOT%{_appdir}
f3107250 77ln -s %{_pixmapsdir}/%{name}.png $RPM_BUILD_ROOT%{_appdir}/bin
da262f07 78cp -p phpstorm.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
1720293b 79cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
457ca289
ER
80install -p %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/pstorm
81ln -s pstorm $RPM_BUILD_ROOT%{_bindir}/%{name}
265003bd
ER
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%files
87%defattr(644,root,root,755)
425880c4 88%attr(755,root,root) %{_bindir}/%{name}
17c1946d 89%attr(755,root,root) %{_bindir}/pstorm
265003bd
ER
90%dir %{_appdir}
91%{_appdir}/help
265003bd
ER
92%{_appdir}/plugins
93%dir %{_appdir}/bin
1444622e 94%{_appdir}/bin/%{name}*.vmoptions
486dfff4 95%{_appdir}/bin/%{name}.png
265003bd
ER
96%{_appdir}/bin/idea.properties
97%{_appdir}/bin/log.xml
1444622e 98%attr(755,root,root) %{_appdir}/bin/%{name}.sh
da262f07
ER
99%attr(755,root,root) %{_appdir}/bin/*.py
100%attr(755,root,root) %{_appdir}/bin/format.sh
9c78341a 101%attr(755,root,root) %{_appdir}/bin/fsnotifier*
da262f07 102%attr(755,root,root) %{_appdir}/bin/inspect.sh
ae6c8231 103%attr(755,root,root) %{_appdir}/bin/libyjpagent-linux*.so
1444622e
ER
104%dir %{_appdir}/lib
105%{_appdir}/lib/*.jar
1444622e
ER
106%dir %{_appdir}/lib/libpty
107%dir %{_appdir}/lib/libpty/linux
108%dir %{_appdir}/lib/libpty/linux/x86*
109%attr(755,root,root) %{_appdir}/lib/libpty/linux/x86*/libpty.so
1720293b 110%{_desktopdir}/%{name}.desktop
265003bd 111%{_pixmapsdir}/%{name}.png
This page took 1.187517 seconds and 4 git commands to generate.