]> git.pld-linux.org Git - packages/php-symfony2-Intl.git/blame - php-symfony2-Intl.spec
use autoloader.php as autoload bootstrap
[packages/php-symfony2-Intl.git] / php-symfony2-Intl.spec
CommitLineData
4573fc82
ER
1%define pearname Intl
2%define php_min_version 5.3.3
3%include /usr/lib/rpm/macros.php
4Summary: Symfony2 Intl Component
5Name: php-symfony2-Intl
d896cacc 6Version: 2.4.8
4573fc82
ER
7Release: 1
8License: MIT
9Group: Development/Languages/PHP
d896cacc
ER
10Source0: https://github.com/symfony/%{pearname}/archive/v%{version}/%{pearname}-%{version}.tar.gz
11# Source0-md5: cee0e1e9ace6b9651c6d940ab6988a03
eab577f6 12URL: http://symfony.com/doc/2.4/components/intl.html
d896cacc 13BuildRequires: phpab
4573fc82
ER
14BuildRequires: rpm-php-pearprov >= 4.4.2-11
15BuildRequires: rpmbuild(macros) >= 1.674
16Requires: php(core) >= %{php_min_version}
eab577f6
ER
17Requires: php(date)
18Requires: php(pcre)
19Requires: php(simplexml)
20Requires: php(spl)
4573fc82 21Requires: php-pear >= 4:1.3.10
d1f7fd63 22Requires: php-symfony2-Icu >= 1.0
4573fc82
ER
23Suggests: php(intl)
24BuildArch: noarch
25BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27%description
28A PHP replacement layer for the C intl extension that also provides
29access to the localization data of the ICU library.
30
31The replacement layer is limited to the locale "en". If you want to
32use other locales, you should install the intl extension instead.
33
34%prep
d896cacc 35%setup -q -n %{pearname}-%{version}
4573fc82 36
d896cacc 37%build
9b51ab84 38phpab -n -e '*/Tests/*' -o autoloader.php .
4573fc82
ER
39
40%install
41rm -rf $RPM_BUILD_ROOT
d896cacc
ER
42install -d $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{pearname}
43cp -a *.php */ $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{pearname}
44rm -r $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{pearname}/Tests
45# dev tools for Intl package maintainer
46rm -r $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{pearname}/Resources/bin
4573fc82
ER
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%files
52%defattr(644,root,root,755)
d896cacc 53%doc LICENSE README.md CONTRIBUTING.md
4573fc82
ER
54%dir %{php_pear_dir}/Symfony/Component/Intl
55%{php_pear_dir}/Symfony/Component/Intl/*.php
56%{php_pear_dir}/Symfony/Component/Intl/Collator
57%{php_pear_dir}/Symfony/Component/Intl/DateFormatter
58%{php_pear_dir}/Symfony/Component/Intl/Exception
59%{php_pear_dir}/Symfony/Component/Intl/Globals
60%{php_pear_dir}/Symfony/Component/Intl/Locale
61%{php_pear_dir}/Symfony/Component/Intl/NumberFormatter
62%{php_pear_dir}/Symfony/Component/Intl/ResourceBundle
63%{php_pear_dir}/Symfony/Component/Intl/Util
64
65%dir %{php_pear_dir}/Symfony/Component/Intl/Resources
66%{php_pear_dir}/Symfony/Component/Intl/Resources/stubs
This page took 0.065546 seconds and 4 git commands to generate.