]> git.pld-linux.org Git - packages/php-symfony2-Icu.git/blame - php-symfony2-Icu.spec
use autoloader.php as autoload bootstrap
[packages/php-symfony2-Icu.git] / php-symfony2-Icu.spec
CommitLineData
9c67ce6c
ER
1%define pearname Icu
2%define php_min_version 5.3.3
3%include /usr/lib/rpm/macros.php
4Summary: Symfony2 Icu Component
5Name: php-symfony2-Icu
8e17266a 6Version: 1.2.2
9c67ce6c
ER
7Release: 1
8License: MIT
9Group: Development/Languages/PHP
8e17266a
ER
10Source0: https://github.com/symfony/%{pearname}/archive/v%{version}/%{pearname}-%{version}.tar.gz
11# Source0-md5: 66893e27c0d49f8d829c7791b0a947e6
9c67ce6c 12URL: https://github.com/symfony/Icu
8e17266a 13BuildRequires: phpab
9c67ce6c
ER
14BuildRequires: rpm-php-pearprov >= 4.4.2-11
15BuildRequires: rpmbuild(macros) >= 1.610
16Requires: libicu >= 4.4
17Requires: php(core) >= %{php_min_version}
86af750c 18Requires: php(ctype)
9c67ce6c
ER
19Requires: php-pear >= 4:1.3.10
20Requires: php-symfony2-Intl >= 2.3
21BuildArch: noarch
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Contains the data of the ICU library in a specific version. Use it
26through the API of the Intl component.
27
28%prep
29%setup -q -n %{pearname}-%{version}
30
31mv Resources/data/*.txt .
32
8e17266a 33%build
9746439b 34phpab -n -e '*/Tests/*' -o autoloader.php .
8e17266a 35
9c67ce6c
ER
36%install
37rm -rf $RPM_BUILD_ROOT
8e17266a
ER
38install -d $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{pearname}
39cp -a Icu*.php Resources $RPM_BUILD_ROOT%{php_pear_dir}/Symfony/Component/%{pearname}
9c67ce6c
ER
40
41%clean
42rm -rf $RPM_BUILD_ROOT
43
44%files
45%defattr(644,root,root,755)
46%doc LICENSE README.md *.txt
47%dir %{php_pear_dir}/Symfony/Component/Icu
48%{php_pear_dir}/Symfony/Component/Icu/IcuCurrencyBundle.php
49%{php_pear_dir}/Symfony/Component/Icu/IcuData.php
50%{php_pear_dir}/Symfony/Component/Icu/IcuLanguageBundle.php
51%{php_pear_dir}/Symfony/Component/Icu/IcuLocaleBundle.php
52%{php_pear_dir}/Symfony/Component/Icu/IcuRegionBundle.php
53
54%dir %{php_pear_dir}/Symfony/Component/Icu/Resources
55%dir %{php_pear_dir}/Symfony/Component/Icu/Resources/data
56%dir %{php_pear_dir}/Symfony/Component/Icu/Resources/data/curr
57%dir %{php_pear_dir}/Symfony/Component/Icu/Resources/data/lang
58%dir %{php_pear_dir}/Symfony/Component/Icu/Resources/data/locales
59%dir %{php_pear_dir}/Symfony/Component/Icu/Resources/data/region
60
61# TODO: lang tags
62%{php_pear_dir}/Symfony/Component/Icu/Resources/data/curr/*.res
63%{php_pear_dir}/Symfony/Component/Icu/Resources/data/lang/*.res
64%{php_pear_dir}/Symfony/Component/Icu/Resources/data/locales/*.res
65%{php_pear_dir}/Symfony/Component/Icu/Resources/data/region/*.res
This page took 0.065472 seconds and 4 git commands to generate.