]> git.pld-linux.org Git - packages/php-redis.git/blame - php-redis.spec
Requires json extension now
[packages/php-redis.git] / php-redis.spec
CommitLineData
2b82b6de
ER
1# TODO
2# - use external igbinary and make it's dependency optional
b91beefc
ER
3#
4# Conditional build:
303e815d 5%bcond_without phpdoc # build phpdoc package
24c6c494 6%bcond_with tests # build without tests
b91beefc 7
303e815d
ER
8# build "phpdoc" only for 7.3 version on pld builders
9%if 0%{?_pld_builder:1} && "%{?php_suffix}" != "73"
10%undefine with_phpdoc
11%endif
12
67fa4b41 13%define php_name php%{?php_suffix}
48db7d63
ER
14%define modname redis
15Summary: %{modname} A PHP extension for Redis
67fa4b41 16Name: %{php_name}-%{modname}
07584202 17Version: 5.1.0
f2c23d87 18Release: 1
48db7d63
ER
19License: PHP 3.01
20Group: Development/Languages/PHP
7345c0d0 21Source0: https://github.com/phpredis/phpredis/tarball/%{version}/%{modname}-%{version}.tar.gz
07584202 22# Source0-md5: 1a175f0351a2fab4f495a935c20fb239
7345c0d0
ER
23Source1: https://github.com/ukko/phpredis-phpdoc/archive/9ec1795bcd45ec83a19b46cf9a8b78b4e4d7ac80/%{modname}-phpdoc.tar.gz
24# Source1-md5: eaba2e5fad040e2f4526374c073ae5f7
25URL: https://github.com/phpredis/phpredis
7345c0d0 26BuildRequires: %{php_name}-cli
07584202 27BuildRequires: %{php_name}-devel >= 4:7.0
f695dc29 28BuildRequires: %{php_name}-json
c61b27e4
AM
29BuildRequires: %{php_name}-pcre
30BuildRequires: %{php_name}-session
31BuildRequires: %{php_name}-simplexml
07584202 32BuildRequires: zstd-devel >= 1.3.0
a56ffbc5 33%if %{with tests}
24c6c494
ER
34BuildRequires: %{php_name}-pecl-igbinary
35BuildRequires: %{php_name}-zlib
c61b27e4 36%endif
48db7d63
ER
37BuildRequires: rpmbuild(macros) >= 1.519
38%{?requires_php_extension}
f695dc29 39Requires: %{php_name}-json
67fa4b41 40Requires: %{php_name}-session
54d79b38 41Provides: php(%{modname}) = %{version}
e15e2353 42Obsoletes: php-redis < 2.2.5-1
48db7d63
ER
43BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45%description
46The phpredis extension provides an API for communicating with the
47Redis key-value store.
48
49This extension also provides session support.
50
303e815d
ER
51%package -n php-redis-phpdoc
52Summary: @phpdoc extension PHP for IDE autocomplete
53Group: Documentation
54URL: https://github.com/ukko/phpredis-phpdoc
55Requires: php-dirs
56BuildArch: noarch
57
58%description -n php-redis-phpdoc
59@phpdoc extension PHP for IDE autocomplete.
60
48db7d63 61%prep
2b82b6de 62%setup -qc -a1
bc808e49 63mv phpredis-phpredis-*/* .
7345c0d0 64mv phpredis-phpdoc-* phpdoc
48db7d63
ER
65
66%build
67phpize
07584202
ER
68%configure \
69 --enable-redis-zstd
48db7d63
ER
70%{__make}
71
24c6c494
ER
72export TEST_PHP_EXECUTABLE="%{__php}"
73export TEST_PHP_ARGS=" -n \
b91beefc 74 -dextension_dir=modules \
f695dc29 75%if "%php_major_version.%php_minor_version" < "7.4"
fd0294ec 76 -dextension=%{php_extensiondir}/pcre.so \
b91beefc 77 -dextension=%{php_extensiondir}/spl.so \
f695dc29 78%endif
fd0294ec 79 -dextension=%{php_extensiondir}/simplexml.so \
b91beefc 80 -dextension=%{php_extensiondir}/session.so \
f695dc29 81 -dextension=%{php_extensiondir}/json.so \
b91beefc 82 -dextension=%{modname}.so \
24c6c494
ER
83"
84
85# simple module load test
86$TEST_PHP_EXECUTABLE $TEST_PHP_ARGS -m > modules.log
b91beefc 87grep %{modname} modules.log
b91beefc 88
24c6c494
ER
89%if %{with tests}
90TEST_PHP_ARGS="
91 $TEST_PHP_ARGS
92 -dextension=%{php_extensiondir}/zlib.so \
93"
94
95# Run tests for Redis class (note this is the default)
96$TEST_PHP_EXECUTABLE $TEST_PHP_ARGS tests/TestRedis.php --class Redis
97
98# Run tests for RedisArray class
99tests/mkring.sh start
100$TEST_PHP_EXECUTABLE $TEST_PHP_ARGS tests/TestRedis.php --class RedisArray
101tests/mkring.sh stop
102
103# Run tests for the RedisCluster class
104tests/make-cluster.sh start
105$TEST_PHP_EXECUTABLE $TEST_PHP_ARGS tests/TestRedis.php --class RedisCluster
106tests/make-cluster.sh stop
107%endif
108
48db7d63
ER
109%install
110rm -rf $RPM_BUILD_ROOT
48db7d63
ER
111%{__make} install \
112 EXTENSION_DIR=%{php_extensiondir} \
113 INSTALL_ROOT=$RPM_BUILD_ROOT
114
115install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
116cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
117; Enable %{modname} extension module
118extension=%{modname}.so
119EOF
120
303e815d
ER
121install -d $RPM_BUILD_ROOT%{_examplesdir}/php-%{modname}-%{version}
122cp -a phpdoc/src/*.php $RPM_BUILD_ROOT%{_examplesdir}/php-%{modname}-%{version}
7345c0d0 123
48db7d63
ER
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post
128%php_webserver_restart
129
130%postun
131if [ "$1" = 0 ]; then
132 %php_webserver_restart
133fi
134
135%files
136%defattr(644,root,root,755)
7345c0d0 137%doc CREDITS README.markdown
48db7d63
ER
138%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
139%attr(755,root,root) %{php_extensiondir}/%{modname}.so
303e815d
ER
140
141%if %{with phpdoc}
142%files -n php-redis-phpdoc
143%defattr(644,root,root,755)
144%{_examplesdir}/php-%{modname}-%{version}
145%endif
This page took 0.078125 seconds and 5 git commands to generate.