]> git.pld-linux.org Git - packages/php-phpoffice-PHPExcel.git/blame - php-phpoffice-PHPExcel.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/php-phpoffice-PHPExcel.git] / php-phpoffice-PHPExcel.spec
CommitLineData
e3b63971
ER
1# TODO
2# - drop PHPExcel/Calculation/Functions.php - php compat functions (find minimum required and use that in .spec)
3# - mbstring used unconditionally in some places: ./PHPExcel/Writer/CSV.php, ./PHPExcel/Calculation.php
09bf018d 4%define pkgname PHPExcel
e3b63971 5%define php_min_version 5.2.1
e3b63971
ER
6Summary: PHPExcel - OpenXML - Create Excel2007 documents in PHP - Spreadsheet engine
7Name: php-phpoffice-%{pkgname}
0dbf0c8c
AM
8Version: 1.8.1
9Release: 1
e3b63971
ER
10License: LGPL v2.1
11Group: Development/Languages/PHP
12Source0: https://github.com/PHPOffice/PHPExcel/archive/%{version}/%{pkgname}-%{version}.tar.gz
0dbf0c8c 13# Source0-md5: c72783d9704e90120b480001335e7518
e3b63971
ER
14URL: http://phpexcel.codeplex.com/
15BuildRequires: rpm-php-pearprov >= 4.4.2-11
16BuildRequires: rpmbuild(macros) >= 1.654
17Requires: php(core) >= %{php_min_version}
18Requires: php(ctype)
19Requires: php(date)
20Requires: php(mbstring)
21Requires: php(pcre)
22Requires: php(spl)
23Requires: php(xml)
e3b63971
ER
24Suggests: php(gd)
25Suggests: php(iconv)
26Suggests: php(simplexml)
27Suggests: php(sqlite)
28Suggests: php(xmlreader)
cc20216e 29Suggests: php(xmlwriter)
e3b63971 30Suggests: php(zip)
38532d2d 31Suggests: php-jpgraph
e3b63971
ER
32BuildArch: noarch
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
25a6e356 35%define _noautoreq_pear jpgraph_.*.php
e3b63971
ER
36
37# exclude optional php dependencies
38%define _noautophp php-gd php-iconv php-mbstring php-simplexml php-sqlite php-xmlreader
39
40# put it together for rpmbuild
41%define _noautoreq %{?_noautophp}
42
43%description
44PHPExcel - OpenXML - Read, Write and Create Excel documents in PHP -
45Spreadsheet engine
46
47Project providing a set of classes for the PHP programming language,
48which allow you to write to and read from different spreadsheet file
49formats, like Excel (BIFF) .xls, Excel 2007 (OfficeOpenXML) .xlsx,
50CSV, Libre/OpenOffice Calc .ods, Gnumeric, PDF, HTML, ... This project
51is built around Microsoft's OpenXML standard and PHP. Checkout the
52Features this class set provides, such as setting spreadsheet meta
53data (author, title, description, ...), multiple worksheets, different
54fonts and font styles, cell borders, fills, gradients, adding images
55to your spreadsheet, calculating formulas, converting between file
56types and much, much more!
57
58%package examples
59Summary: Examples for %{pkgname}
60Group: Documentation
61
62%description examples
63Documentation for %{name}.
64
65%description examples -l pl.UTF-8
66Dokumentacja do %{name}.
67
68%prep
69%setup -q -n %{pkgname}-%{version}
70%undos -f php
71
72%install
73rm -rf $RPM_BUILD_ROOT
74install -d $RPM_BUILD_ROOT{%{php_data_dir},%{_examplesdir}/%{name}-%{version}}
75cp -a Classes/* $RPM_BUILD_ROOT%{php_data_dir}
76cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77
78%clean
79rm -rf $RPM_BUILD_ROOT
80
81%files
82%defattr(644,root,root,755)
83%doc install.txt changelog.txt
84%{php_data_dir}/PHPExcel.php
1bb3ac9a
ER
85%dir %{php_data_dir}/PHPExcel
86%{php_data_dir}/PHPExcel/*.php
87%{php_data_dir}/PHPExcel/CachedObjectStorage
88%{php_data_dir}/PHPExcel/CalcEngine
89%{php_data_dir}/PHPExcel/Calculation
90%{php_data_dir}/PHPExcel/Cell
91%{php_data_dir}/PHPExcel/Chart
0dbf0c8c 92%{php_data_dir}/PHPExcel/Helper
1bb3ac9a
ER
93%{php_data_dir}/PHPExcel/Reader
94%{php_data_dir}/PHPExcel/RichText
95%{php_data_dir}/PHPExcel/Shared
96%{php_data_dir}/PHPExcel/Style
97%{php_data_dir}/PHPExcel/Worksheet
98%{php_data_dir}/PHPExcel/Writer
99
100%dir %{php_data_dir}/PHPExcel/locale
0dbf0c8c 101%lang(bg) %{php_data_dir}/PHPExcel/locale/bg
1bb3ac9a
ER
102%lang(cs) %{php_data_dir}/PHPExcel/locale/cs
103%lang(da) %{php_data_dir}/PHPExcel/locale/da
104%lang(de) %{php_data_dir}/PHPExcel/locale/de
105%lang(en_GB) %dir %{php_data_dir}/PHPExcel/locale/en
106%lang(en_GB) %{php_data_dir}/PHPExcel/locale/en/uk
107%lang(es) %{php_data_dir}/PHPExcel/locale/es
108%lang(fi) %{php_data_dir}/PHPExcel/locale/fi
109%lang(fr) %{php_data_dir}/PHPExcel/locale/fr
110%lang(hu) %{php_data_dir}/PHPExcel/locale/hu
111%lang(it) %{php_data_dir}/PHPExcel/locale/it
112%lang(nb) %{php_data_dir}/PHPExcel/locale/no
113%lang(nl) %{php_data_dir}/PHPExcel/locale/nl
114%lang(pl) %{php_data_dir}/PHPExcel/locale/pl
115%lang(pt_BR) %dir %{php_data_dir}/PHPExcel/locale/pt
116%lang(pt_BR) %{php_data_dir}/PHPExcel/locale/pt/br
93e7b436
ER
117%lang(pt) %{php_data_dir}/PHPExcel/locale/pt/config
118%lang(pt) %{php_data_dir}/PHPExcel/locale/pt/functions
1bb3ac9a
ER
119%lang(ru) %{php_data_dir}/PHPExcel/locale/ru
120%lang(sv) %{php_data_dir}/PHPExcel/locale/sv
121%lang(tr) %{php_data_dir}/PHPExcel/locale/tr
e3b63971
ER
122
123%files examples
124%defattr(644,root,root,755)
125%{_examplesdir}/%{name}-%{version}
This page took 0.090439 seconds and 5 git commands to generate.