]> git.pld-linux.org Git - packages/php-pecl-zlib_filter.git/blame - php-pecl-zlib_filter.spec
support building for multiple php versions
[packages/php-pecl-zlib_filter.git] / php-pecl-zlib_filter.spec
CommitLineData
541fdff9
ER
1%define php_name php%{?php_suffix}
2%define modname zlib_filter
3%define status stable
4Summary: %{modname} - zlib filter implementation backport for PHP 5.0
5Summary(pl.UTF-8): %{modname} - backport implementacji filtra zlib dla PHP 5.0
6Name: %{php_name}-pecl-%{modname}
8c7c9fca 7Version: 1.1
b676e3c0 8Release: 7
8c7c9fca
AG
9License: PHP
10Group: Development/Languages/PHP
541fdff9 11Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
8c7c9fca
AG
12# Source0-md5: 1ebb48e3fd1be4593a4eb217fbc1ab53
13URL: http://pecl.php.net/package/zlib_filter/
541fdff9
ER
14BuildRequires: %{php_name}-devel >= 3:5.0.0
15BuildRequires: rpmbuild(macros) >= 1.650
7d0af381 16%{?requires_php_extension}
f4e335ba 17Requires: php-common >= 4:5.0.4
541fdff9 18Obsoletes: php-pear-%{modname}
8c7c9fca
AG
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
8c7c9fca
AG
21%description
22RFC 1951 inflate/deflate stream filter implementation. Performs inline
23compression/decompression using the deflate method on any PHP I/O
24stream. The data produced by this filter, while compatable with the
25payload portion of an RFC 1952 gzip file, does not include headers or
26tailers for full RFC 1952 gzip compatability. To achieve this format,
27use the compress.zlib:// fopen wrapper built directly into PHP.
28
541fdff9 29In PECL status of this extension is: %{status}.
8c7c9fca 30
7dc667fe 31%description -l pl.UTF-8
27a68bca 32Implementacja filtra strumienia inflate/deflate zgodna z RFC 1951.
7dc667fe
JR
33Wykonuje kompresję/dekompresję metodą deflate na dowolnym strumieniu
34I/O PHP. Dane stworzone przez ten filtr, będąc kompatybilnymi z
35częścią RFC 1952 dotyczącą payloadu pliku gzip, nie zawierają
36nagłówków ani końcówek dla pełnej zgodności z gzipem według RFC 1952.
37Aby uzyskać ten format, trzeba użyć wrappera fopen compress.zlib://
38wbudowanego bezpośrednio w PHP.
27a68bca 39
541fdff9 40To rozszerzenie ma w PECL status: %{status}.
8c7c9fca
AG
41
42%prep
541fdff9
ER
43%setup -qc
44mv %{modname}-%{version}/* .
8c7c9fca
AG
45
46%build
8c7c9fca
AG
47phpize
48%configure \
49 --with-zlib-filter=/usr
50%{__make}
51
52%install
53rm -rf $RPM_BUILD_ROOT
f4e335ba 54install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
8c7c9fca 55
541fdff9
ER
56install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
57cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
58; Enable %{modname} extension module
59extension=%{modname}.so
7d0af381 60EOF
8c7c9fca
AG
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post
f4e335ba 66%php_webserver_restart
8c7c9fca 67
7d0af381
ER
68%postun
69if [ "$1" = 0 ]; then
f4e335ba 70 %php_webserver_restart
8c7c9fca
AG
71fi
72
73%files
74%defattr(644,root,root,755)
541fdff9
ER
75%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
76%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.092087 seconds and 4 git commands to generate.