]> git.pld-linux.org Git - packages/php-pecl-zendopcache.git/blame - php-pecl-zendopcache.spec
add php suffix support
[packages/php-pecl-zendopcache.git] / php-pecl-zendopcache.spec
CommitLineData
43eeafa3
ER
1# NOTE:
2# This version of Zend OPcache is compatible with PHP 5.2.*, 5.3.*, 5.4.*
3# and PHP-5.5 development branch. PHP 5.2 support may be removed in the future.
82862555 4%define php_name php%{?php_suffix}
43eeafa3
ER
5%define modname zendopcache
6Summary: Zend Optimizer+ - PHP code optimizer
7Summary(pl.UTF-8): Zend Optimizer+ - optymalizator kodu PHP
82862555 8Name: %{php_name}-pecl-%{modname}
43eeafa3 9Version: 7.0.1
82862555 10Release: 2
43eeafa3 11License: PHP 3.01
82862555 12Group: Development/Languages/PHP
43eeafa3
ER
13Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
14# Source0-md5: 3a0a43a4819c72763bc35ecf5689221e
223ba653 15Source1: %{modname}.ini
43eeafa3 16URL: http://pecl.php.net/package/zendopcache
82862555 17BuildRequires: %{php_name}-devel >= 4:5.0.4
43eeafa3
ER
18BuildRequires: rpmbuild(macros) >= 1.519
19%{?requires_php_extension}
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23The Zend OPcache provides faster PHP execution through opcode caching
24and optimization. It improves PHP performance by storing precompiled
25script bytecode in the shared memory. This eliminates the stages of
26reading code from the disk and compiling it on future access. In
27addition, it applies a few bytecode optimization patterns that make
28code execution faster.
29
30%prep
31%setup -qc
32mv %{modname}-%{version}/* .
33
34%build
35phpize
36%configure
37%{__make}
38
39%install
40rm -rf $RPM_BUILD_ROOT
41%{__make} install \
42 EXTENSION_DIR=%{php_extensiondir} \
43 INSTALL_ROOT=$RPM_BUILD_ROOT
44
43eeafa3
ER
45# NOTE: In case you are going to use Zend OPcache together with Xdebug,
46# be sure that Xdebug is loaded after OPcache. "php -v" must show Xdebug
47# after OPcache.
48install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
223ba653 49sed -e 's,@extensiondir@,%{php_extensiondir},' %{SOURCE1} > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
43eeafa3
ER
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%post
55%php_webserver_restart
56
57%postun
58if [ "$1" = 0 ]; then
59 %php_webserver_restart
60fi
61
62%files
63%defattr(644,root,root,755)
64%doc README LICENSE
82862555 65%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
43eeafa3 66%attr(755,root,root) %{php_extensiondir}/opcache.so
This page took 0.101352 seconds and 4 git commands to generate.