]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blame - php-pecl-xdebug.spec
up to 2.6.1 [2018-08-01]
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
CommitLineData
3dda0a07
ER
1#
2# Conditional build:
3%bcond_without vim # make vim syntax package
4
16fe691e
ER
5# build noarch packages only for 7.0 version
6%if 0%{?_pld_builder:1} && "%{?php_suffix}" != "70"
bcd8bd1a 7%undefine with_vim
3dda0a07
ER
8%endif
9
d412cdf0 10%define php_name php%{?php_suffix}
266b1c9d 11%define modname xdebug
266b1c9d
ER
12Summary: %{modname} - provides functions for functions traces and profiling
13Summary(pl.UTF-8): %{modname} - funkcje do śledzenia i profilowania funkcji
05ed2ac4 14Name: %{php_name}-pecl-%{modname}
3ea10353 15Version: 2.6.1
28265977 16Release: 1
fe451dff
ER
17# The Xdebug License, version 1.01
18# (Based on "The PHP License", version 3.0)
19License: PHP
d6c5cc9f 20Group: Development/Languages/PHP
3ea10353
ER
21Source0: https://xdebug.org/files/xdebug-%{version}.tgz
22# Source0-md5: 35cc0f2e8b7d40556a9ad9afd9c49aee
05ed2ac4 23Source1: %{modname}.ini
3dda0a07 24Source2: vim-xt-filetype.vim
3ea10353 25URL: https://xdebug.org/
16fe691e 26BuildRequires: %{php_name}-devel >= 4:7.0
e8a9b5ad 27BuildRequires: libedit-devel
aba255b5 28BuildRequires: libtool
8096f627 29BuildRequires: rpmbuild(macros) >= 1.650
3464b421 30%{?requires_zend_extension}
5423a009 31Provides: php(%{modname}) = %{version}
b8ab7bee 32Obsoletes: php-pecl-xdebug < 2.2.4-1
022c051a 33Conflicts: ZendOptimizer
d6c5cc9f
AG
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
3dda0a07
ER
36%define _vimdatadir %{_datadir}/vim
37
d6c5cc9f 38%description
cc7edbad
JB
39The Xdebug extension helps you debugging your script by providing a
40lot of valuable debug information. The debug information that Xdebug
41can provide includes the following:
82a74d97
AG
42
43- stack and function traces in error messages with:
20519407
ER
44 - full parameter display for user defined functions
45 - function name, file name and line indications
fe451dff
ER
46 - support for member functions
47- memory allocation
82a74d97
AG
48- protection for infinite recursions
49
50Xdebug also provides:
d6c5cc9f 51
82a74d97 52- profiling information for PHP scripts
fe451dff 53- code coverage analysis
82a74d97 54- capabilities to debug your scripts interactively with a debug client
98b3abb8 55
2c8c4667
JR
56%description -l pl.UTF-8
57Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
58dużo wartościowych informacji. Informacje przydatne do śledzenia,
59które może zapewnić Xdebug, obejmują:
cc7edbad 60
2c8c4667
JR
61- śledzenie stosu i funkcji w komunikatach błędów wraz z:
62 - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
63 użytkownika
64 - nazwami funkcji, nazwami plików i numerami linii
65 - obsługą metod klas
66- przydzielanie pamięci
67- zabezpieczenie przed nieskończoną rekurencją
cc7edbad 68
2c8c4667 69Xdebug dostarcza także:
cc7edbad 70
2c8c4667
JR
71- informacje do profilowania skryptów PHP
72- analizę wywołań skryptu
73- możliwość śledzenia skryptów interaktywnie przy pomocy klienta
cc7edbad
JB
74 odpluskwiacza
75
3dda0a07
ER
76%package -n vim-syntax-xdebug
77Summary: Vim syntax: Xdebug trace files
78Group: Applications/Editors/Vim
79Requires: php(%{modname}) = %{version}
80Requires: vim-rt >= 4:7.2.170
3dda0a07 81BuildArch: noarch
3dda0a07
ER
82
83%description -n vim-syntax-xdebug
84This plugin provides syntax highlighting Xdebug trace files (context
85or unified).
86
d6c5cc9f 87%prep
266b1c9d
ER
88%setup -qc
89mv %{modname}-%{version}*/* .
aba255b5 90chmod +x debugclient/configure
d6c5cc9f 91
7c227a4b 92%{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
50d01b8c 93
3dda0a07
ER
94install -d vim/{syntax,ftdetect}
95mv contrib/xt.vim vim/syntax
96cp -p %{SOURCE2} vim/ftdetect/xt.vim
97
aba255b5 98%build
dcaafe35 99# libtool 2.2 build fix
266b1c9d
ER
100if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
101 cat %{_aclocaldir}/ltsugar.m4 >> config.m4
102 cat %{_aclocaldir}/ltsugar.m4 >> debugclient/aclocal.m4
103
104 cat %{_aclocaldir}/ltversion.m4 >> config.m4
105 cat %{_aclocaldir}/ltversion.m4 >> debugclient/aclocal.m4
106
107 cat %{_aclocaldir}/lt~obsolete.m4 >> config.m4
108 cat %{_aclocaldir}/lt~obsolete.m4 >> debugclient/aclocal.m4
109
110 cat %{_aclocaldir}/ltoptions.m4 >> config.m4
111 cat %{_aclocaldir}/ltoptions.m4 >> debugclient/aclocal.m4
112
113 cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
dcaafe35 114fi
d6c5cc9f
AG
115phpize
116%configure
117%{__make}
e8a9b5ad 118cd debugclient
e8a9b5ad
AM
119%configure \
120 --with-libedit
121%{__make}
d6c5cc9f
AG
122
123%install
124rm -rf $RPM_BUILD_ROOT
266b1c9d 125install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
d6c5cc9f 126
2ba22e49 127install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}%{?php_suffix}-debugclient
266b1c9d
ER
128install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
129cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
d6c5cc9f 130
3dda0a07
ER
131%if %{with vim}
132# vim syntax
133install -d $RPM_BUILD_ROOT%{_vimdatadir}
134cp -a vim/* $RPM_BUILD_ROOT%{_vimdatadir}
135%endif
136
d6c5cc9f
AG
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%post
bc9b2fd3 141%php_webserver_restart
d6c5cc9f 142
eb5447da
AG
143%postun
144if [ "$1" = 0 ]; then
bc9b2fd3 145 %php_webserver_restart
d6c5cc9f
AG
146fi
147
148%files
149%defattr(644,root,root,755)
18fda282 150%doc README.rst CREDITS contrib
266b1c9d
ER
151%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
152%attr(755,root,root) %{php_extensiondir}/%{modname}.so
2ba22e49 153%attr(755,root,root) %{_bindir}/xdebug*-debugclient
3dda0a07
ER
154
155%if %{with vim}
156%files -n vim-syntax-xdebug
157%defattr(644,root,root,755)
158%{_vimdatadir}/ftdetect/xt.vim
159%{_vimdatadir}/syntax/xt.vim
160%endif
This page took 0.213522 seconds and 4 git commands to generate.