]> git.pld-linux.org Git - packages/php-pecl-xdebug.git/blame - php-pecl-xdebug.spec
- php54 fixes
[packages/php-pecl-xdebug.git] / php-pecl-xdebug.spec
CommitLineData
d412cdf0 1%define php_name php%{?php_suffix}
266b1c9d
ER
2%define modname xdebug
3%define status stable
266b1c9d
ER
4Summary: %{modname} - provides functions for functions traces and profiling
5Summary(pl.UTF-8): %{modname} - funkcje do śledzenia i profilowania funkcji
05ed2ac4 6Name: %{php_name}-pecl-%{modname}
6b8a44ef 7Version: 2.2.0
aea22071 8Release: 2
82a74d97 9License: BSD style
d6c5cc9f 10Group: Development/Languages/PHP
472e26b5 11Source0: http://www.xdebug.org/files/xdebug-%{version}.tgz
6b8a44ef 12# Source0-md5: 27d8ad8224ffab04d12eecb5997a4f5d
05ed2ac4 13Source1: %{modname}.ini
6d9ef3e4 14URL: http://www.xdebug.org/
d412cdf0 15BuildRequires: %{php_name}-devel >= 4:5.2.17-8
e8a9b5ad 16BuildRequires: libedit-devel
aba255b5 17BuildRequires: libtool
7c227a4b 18BuildRequires: rpmbuild(macros) >= 1.579
3464b421 19%{?requires_zend_extension}
022c051a 20Conflicts: ZendOptimizer
d6c5cc9f
AG
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
d6c5cc9f 23%description
cc7edbad
JB
24The Xdebug extension helps you debugging your script by providing a
25lot of valuable debug information. The debug information that Xdebug
26can provide includes the following:
82a74d97
AG
27
28- stack and function traces in error messages with:
20519407
ER
29 - full parameter display for user defined functions
30 - function name, file name and line indications
31 - support for member functions memory allocation
82a74d97
AG
32- protection for infinite recursions
33
34Xdebug also provides:
d6c5cc9f 35
82a74d97
AG
36- profiling information for PHP scripts
37- script execution analysis
38- capabilities to debug your scripts interactively with a debug client
98b3abb8 39
266b1c9d 40In PECL status of this package is: %{status}.
98b3abb8 41
2c8c4667
JR
42%description -l pl.UTF-8
43Rozszerzenie Xdebug pomaga przy odpluskwianiu skryptu dostarczając
44dużo wartościowych informacji. Informacje przydatne do śledzenia,
45które może zapewnić Xdebug, obejmują:
cc7edbad 46
2c8c4667
JR
47- śledzenie stosu i funkcji w komunikatach błędów wraz z:
48 - pełnym wyświetlaniem parametrów dla funkcji zdefiniowanych przez
49 użytkownika
50 - nazwami funkcji, nazwami plików i numerami linii
51 - obsługą metod klas
52- przydzielanie pamięci
53- zabezpieczenie przed nieskończoną rekurencją
cc7edbad 54
2c8c4667 55Xdebug dostarcza także:
cc7edbad 56
2c8c4667
JR
57- informacje do profilowania skryptów PHP
58- analizę wywołań skryptu
59- możliwość śledzenia skryptów interaktywnie przy pomocy klienta
cc7edbad
JB
60 odpluskwiacza
61
266b1c9d 62To rozszerzenie ma w PECL status: %{status}.
d6c5cc9f
AG
63
64%prep
266b1c9d
ER
65%setup -qc
66mv %{modname}-%{version}*/* .
aba255b5 67chmod +x debugclient/configure
d6c5cc9f 68
7c227a4b 69%{__sed} -e 's#^;zend_extension.*#zend_extension=%{php_extensiondir}/%{modname}.so#' %{SOURCE1} > %{modname}.ini
50d01b8c 70
aba255b5 71%build
dcaafe35 72# libtool 2.2 build fix
266b1c9d
ER
73if [ -f %{_aclocaldir}/ltsugar.m4 ]; then
74 cat %{_aclocaldir}/ltsugar.m4 >> config.m4
75 cat %{_aclocaldir}/ltsugar.m4 >> debugclient/aclocal.m4
76
77 cat %{_aclocaldir}/ltversion.m4 >> config.m4
78 cat %{_aclocaldir}/ltversion.m4 >> debugclient/aclocal.m4
79
80 cat %{_aclocaldir}/lt~obsolete.m4 >> config.m4
81 cat %{_aclocaldir}/lt~obsolete.m4 >> debugclient/aclocal.m4
82
83 cat %{_aclocaldir}/ltoptions.m4 >> config.m4
84 cat %{_aclocaldir}/ltoptions.m4 >> debugclient/aclocal.m4
85
86 cat %{_aclocaldir}/libtool.m4 >> debugclient/aclocal.m4
dcaafe35 87fi
50d01b8c 88
d6c5cc9f
AG
89phpize
90%configure
91%{__make}
e8a9b5ad 92cd debugclient
b79d4446 93install /usr/share/automake/{config.*,depcomp} .
aba255b5 94%{__libtoolize}
e8a9b5ad
AM
95%{__aclocal}
96%{__autoconf}
97%configure \
98 --with-libedit
99%{__make}
d6c5cc9f
AG
100
101%install
102rm -rf $RPM_BUILD_ROOT
266b1c9d 103install -d $RPM_BUILD_ROOT{%{_bindir},%{php_sysconfdir}/conf.d,%{php_extensiondir}}
d6c5cc9f 104
266b1c9d
ER
105install -p debugclient/debugclient $RPM_BUILD_ROOT%{_bindir}/%{modname}-debugclient
106install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
107cp -a %{modname}.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
d6c5cc9f
AG
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%post
bc9b2fd3 113%php_webserver_restart
d6c5cc9f 114
eb5447da
AG
115%postun
116if [ "$1" = 0 ]; then
bc9b2fd3 117 %php_webserver_restart
d6c5cc9f
AG
118fi
119
120%files
121%defattr(644,root,root,755)
6b8a44ef 122%doc README NEWS CREDITS contrib/xt.vim
266b1c9d
ER
123%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
124%attr(755,root,root) %{php_extensiondir}/%{modname}.so
125%attr(755,root,root) %{_bindir}/xdebug-debugclient
This page took 0.134465 seconds and 4 git commands to generate.