]> git.pld-linux.org Git - packages/php-pecl-event.git/blame - php-pecl-event.spec
provide php(extname) to really be supporting multiple php versions
[packages/php-pecl-event.git] / php-pecl-event.spec
CommitLineData
2b93d9bf
ER
1%define php_name php%{?php_suffix}
2%define modname event
3%define status beta
4Summary: %{modname} - event scheduling engine
5Summary(pl.UTF-8): %{modname} - silnik do planowania zdarzeń
6Name: %{php_name}-pecl-%{modname}
48a773b2 7Version: 0.9.1
3598172b 8Release: 9
404259fd
AG
9License: PHP
10Group: Development/Languages/PHP
2b93d9bf 11Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
48a773b2 12# Source0-md5: f009fd3519c14a027a8c85414208b61c
404259fd 13URL: http://pecl.php.net/package/event/
2b93d9bf
ER
14BuildRequires: %{php_name}-devel >= 3:5.0.0
15BuildRequires: rpmbuild(macros) >= 1.650
77d454d9 16%{?requires_php_extension}
2b93d9bf
ER
17Requires: php(core) >= 5.0.4
18Obsoletes: php-pear-%{modname}
3598172b 19Provides: php(%{modname}) = %{version}
404259fd
AG
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
404259fd
AG
22%description
23This is an extension to efficiently schedule IO, time and signal based
24events using the best available IO notification mechanism for your
25system.
26
27This is a port of libevent to the PHP infrastructure; the API is
28similar but not identical.
29
2b93d9bf 30In PECL status of this extension is: %{status}.
404259fd 31
5e47829f 32%description -l pl.UTF-8
135d506e 33To rozszerzenie pozwala na efektywne planowanie We/Wy, czasu oraz
5e47829f 34opartych na sygnałach zdarzeń za pomocą najlepszego dostępnego dla
135d506e 35systemu mechanizmu powiadamiania.
404259fd
AG
36
37Jest to port biblioteki libevent do infrastruktury PHP; API jest
38podobne, jednak nie identyczne.
39
2b93d9bf 40To rozszerzenie ma w PECL status: %{status}.
404259fd
AG
41
42%prep
2b93d9bf
ER
43%setup -qc
44mv %{modname}-%{version}/* .
404259fd
AG
45
46%build
404259fd
AG
47phpize
48%configure
49%{__make}
50
51%install
52rm -rf $RPM_BUILD_ROOT
549dec3e 53install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
404259fd 54
2b93d9bf
ER
55install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
56cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
57; Enable %{modname} extension module
58extension=%{modname}.so
77d454d9 59EOF
404259fd
AG
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%post
549dec3e 65%php_webserver_restart
404259fd 66
77d454d9
ER
67%postun
68if [ "$1" = 0 ]; then
549dec3e 69 %php_webserver_restart
404259fd
AG
70fi
71
72%files
73%defattr(644,root,root,755)
2b93d9bf
ER
74%doc CREDITS EXPERIMENTAL
75%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
76%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.07065 seconds and 4 git commands to generate.