]> git.pld-linux.org Git - packages/php-pear.git/blame - php-pear.spec
use __php macro for php cli
[packages/php-pear.git] / php-pear.spec
CommitLineData
25de18da 1Summary: PEAR - PHP Extension and Application Repository
76e800da 2Summary(pl.UTF-8): PEAR - rozszerzenie PHP i repozytorium aplikacji
25de18da 3Name: php-pear
902a69a3 4Version: 1.3.17
7e5dea50 5Release: 1
25de18da
ER
6Epoch: 4
7License: Public Domain
8Group: Development/Languages/PHP
3e35a10f 9Source0: php-channel-prov.php
6d85ce34 10Source100: update-channels.sh
799471e8
ER
11Source1: channel-phing.xml
12Source2: channel-phpdb.xml
fcc14391 13Source3: channel-firephp.xml
cdfa5e00 14Source4: channel-symfony.xml
3e35a10f
ER
15Source5: channel-phpunit.xml
16Source6: channel-phpseclib.xml
1275fa38 17Source7: channel-horde.xml
cdfa5e00 18Source8: channel-rc.xml
d9ff93b5 19Source9: channel-ezc.xml
4c5242d9 20Source10: channel-propel.xml
a9af1509 21Source11: channel-docblox.xml
d92a3b44 22Source12: channel-michelf.xml
f84845e8
ER
23Source13: channel-phpmd.xml
24Source14: channel-pdepend.xml
5f88c87c 25Source15: channel-symfony2.xml
d1682f5e 26Source16: channel-saucelabs.xml
73b1fcbc 27Source17: channel-twig.xml
3ba22036 28Source18: channel-zz.xml
7a1a8238 29Source19: channel-theseer.xml
7e5dea50 30Source20: channel-indeyets.xml
237c2312 31Source21: channel-phpdoc.xml
902a69a3 32Source22: channel-bartlett.xml
924f9510 33BuildRequires: /usr/bin/php
3d75bfd5 34BuildRequires: php-pear-PEAR >= 1:1.9.0
c827a14e 35BuildRequires: rpmbuild(macros) >= 1.570
25de18da 36Obsoletes: php-pear-additional_classes
109b2b0a 37Obsoletes: php4-pear
448d9ae1 38Conflicts: php-pear-PEAR < 1:1.7.2-10
25de18da
ER
39BuildArch: noarch
40BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
c6fd9bb8 42%define __reg_provides %{__php} %{SOURCE0}
924f9510 43
57d254d6 44# find channel provides
924f9510
ER
45%define _use_internal_dependency_generator 0
46%define __find_provides %{__reg_provides}
47%define __find_requires %{nil}
48
57d254d6
ER
49# avoid rpm 4.4.9 adding rm -rf buildroot, we need the dirs to check consistency
50%define __spec_clean_body %{nil}
51
25de18da
ER
52%description
53PEAR - PHP Extension and Application Repository.
54
55Please note that this package provides only basic directory structure.
56If you want to use base PEAR classes (PEAR.php, PEAR/*.php), that come
57with PHP, please install appropriate php-pear-* (php-pear-PEAR,
58php-PEAR-Archive_Tar, etc) packages.
59
84a3ead2 60%description -l pl.UTF-8
25de18da
ER
61PEAR (PHP Extension and Application Repository) - rozszerzenie PHP i
62repozytorium aplikacji.
63
84a3ead2
JR
64Należy pamiętać, że ten pakiet dostarcza tylko podstawową strukturę
65katalogów. Aby użyć podstawowych klas PEAR (PEAR.php PEAR/*.php),
66dostarczanych z PHP, należy zainstalować odpowiednie pakiety
25de18da
ER
67php-pear-* (php-pear-PEAR, php-pear-Archive_Tar, itp).
68
69%prep
367add8f 70%setup -qcT
25de18da 71
1d546840
ER
72%build
73rm -rf pear
74install -d pear
e47124f8 75
367add8f 76# add extra channels
1d546840 77%{__pear} -c pearrc config-set php_dir pear
8bbf817c
ER
78for xml in $(awk '/^Source[0-9]+:.+channel-.+.xml$/ {print $NF}' %{_specdir}/%{name}.spec); do
79 %{__pear} -c pearrc channel-add %{_sourcedir}/$xml
80done
367add8f 81
1d546840
ER
82%install
83install -d $RPM_BUILD_ROOT%{php_pear_dir}/{.registry,bin,data,tests}
84cp -a pear/.??* $RPM_BUILD_ROOT%{php_pear_dir}
85
e47124f8
ER
86while read dir; do
87 install -d $RPM_BUILD_ROOT$dir
88done <<EOF
e47124f8 89%{php_pear_dir}/Archive
8b36818a 90%{php_pear_dir}/Auth
7051e1d1 91%{php_pear_dir}/Cache
e47124f8 92%{php_pear_dir}/Console
d135aaea 93%{php_pear_dir}/Contact
7051e1d1 94%{php_pear_dir}/Crypt
b67f38ff 95%{php_pear_dir}/Event
6a776838 96%{php_pear_dir}/File
7fe1ecf4 97%{php_pear_dir}/Genealogy
8b36818a 98%{php_pear_dir}/Gtk
baff6ba1 99%{php_pear_dir}/Gtk2
e47124f8 100%{php_pear_dir}/HTML
a64748d8 101%{php_pear_dir}/HTML/QuickForm
3314c2d4
ER
102%{php_pear_dir}/HTML/Table
103%{php_pear_dir}/HTML/Template
e47124f8 104%{php_pear_dir}/HTTP
21dc0ab4
ER
105%{php_pear_dir}/HTTP/WebDAV
106%{php_pear_dir}/HTTP/WebDAV/Tools
39946e2d 107%{php_pear_dir}/Horde
66057c98 108%{php_pear_dir}/Horde/Stream
39946e2d
ER
109%{php_pear_dir}/Horde/Text
110%{php_pear_dir}/Horde/Xml
f7198b38 111%{php_pear_dir}/I18N
e47124f8 112%{php_pear_dir}/Image
6c23b1d5 113%{php_pear_dir}/MP3
f15f8dfb 114%{php_pear_dir}/Mail
3314c2d4 115%{php_pear_dir}/Math
e47124f8 116%{php_pear_dir}/Net
c827a14e 117%{php_pear_dir}/Net/UserAgent
e47124f8 118%{php_pear_dir}/Numbers
d135aaea 119%{php_pear_dir}/PHP
3314c2d4 120%{php_pear_dir}/Payment
698a23ed 121%{php_pear_dir}/QA
e47124f8 122%{php_pear_dir}/Science
0ac4465c 123%{php_pear_dir}/SebastianBergmann
e47124f8 124%{php_pear_dir}/Services
d7c960b2 125%{php_pear_dir}/Structures
ee179261 126%{php_pear_dir}/Symfony
1f9bdd5d 127%{php_pear_dir}/Symfony/Bridge
ee179261 128%{php_pear_dir}/Symfony/Component
dff95dc3 129%{php_pear_dir}/Testing
e47124f8 130%{php_pear_dir}/Text
f0386318 131%{php_pear_dir}/Text/CAPTCHA
fb984fdb 132%{php_pear_dir}/Text/Spell
3438e6b2 133%{php_pear_dir}/URI
c8e9976e
AG
134%{php_pear_dir}/Validate
135%{php_pear_dir}/Validate/Finance
698a23ed
AG
136%{php_pear_dir}/VersionControl
137%{php_pear_dir}/XML
e47124f8 138EOF
54b72825 139
08a1e49d 140%clean
57d254d6 141check_channel_dirs() {
1d546840
ER
142 local RPMFILE=%{name}-%{version}-%{release}.%{_target_cpu}.rpm
143 local installed=$(mktemp -t instXXXXXX.tmp)
144 local rpmfiles=$(mktemp -t rpmXXXXXX.tmp)
145 local rc diff=$(mktemp -t diffXXXXXX.tmp)
146
147 find $RPM_BUILD_ROOT%{php_pear_dir} | LC_ALL=C sort > $installed
148 sed -i -re "s#^$RPM_BUILD_ROOT%{php_pear_dir}/?##" $installed
149
150 rpm -qpl %{_rpmdir}/$RPMFILE | LC_ALL=C sort > $rpmfiles
151 sed -i -re "s#^%{php_pear_dir}/?##" $rpmfiles
57d254d6
ER
152
153 # find finds also '.', so use option -B for diff
1d546840
ER
154 if ! diff -uB $installed $rpmfiles > $diff; then
155 cat <<-EOF
156
157 ERROR: some files/directories are not included in package:
158
159 $(%{__sed} -ne '/^-[^-]/ s#^-#%%{php_pear_dir}/#p' $diff)
160
161 EOF
162
57d254d6
ER
163 exit 1
164 fi
1d546840
ER
165 rm -rf $RPM_BUILD_ROOT
166 rm -f $installed $rpmfiles $diff
57d254d6 167}
1d546840 168
57d254d6 169check_channel_dirs
08a1e49d 170
25de18da
ER
171%files
172%defattr(644,root,root,755)
367add8f
ER
173%dir %{php_pear_dir}
174%{php_pear_dir}/*
175
448d9ae1
ER
176%ghost %{php_pear_dir}/.depdblock
177%ghost %{php_pear_dir}/.depdb
178%ghost %{php_pear_dir}/.filemap
179%ghost %{php_pear_dir}/.lock
180
367add8f
ER
181%dir %{php_pear_dir}/.registry
182%dir %{php_pear_dir}/.channels
183%dir %{php_pear_dir}/.channels/.alias
184
16d1038b 185# core channels
448d9ae1
ER
186%{php_pear_dir}/.channels/__uri.reg
187%{php_pear_dir}/.registry/.channel.__uri
188
189%{php_pear_dir}/.channels/.alias/pear.txt
190%{php_pear_dir}/.channels/pear.php.net.reg
191
192%{php_pear_dir}/.channels/.alias/pecl.txt
448d9ae1
ER
193%{php_pear_dir}/.channels/pecl.php.net.reg
194%{php_pear_dir}/.registry/.channel.pecl.php.net
195
16d1038b
ER
196%{php_pear_dir}/.channels/.alias/phpdocs.txt
197%{php_pear_dir}/.channels/doc.php.net.reg
198%{php_pear_dir}/.registry/.channel.doc.php.net
199
200# addon channels
367add8f
ER
201%{php_pear_dir}/.channels/.alias/phpunit.txt
202%{php_pear_dir}/.channels/pear.phpunit.de.reg
8ffa46a8 203%{php_pear_dir}/.registry/.channel.pear.phpunit.de
799471e8
ER
204
205%{php_pear_dir}/.channels/.alias/phing.txt
206%{php_pear_dir}/.channels/pear.phing.info.reg
8ffa46a8 207%{php_pear_dir}/.registry/.channel.pear.phing.info
799471e8
ER
208
209%{php_pear_dir}/.channels/.alias/phpdb.txt
210%{php_pear_dir}/.channels/pear.phpdb.org.reg
8ffa46a8 211%{php_pear_dir}/.registry/.channel.pear.phpdb.org
fcc14391
ER
212
213%{php_pear_dir}/.channels/.alias/firephp.txt
214%{php_pear_dir}/.channels/pear.firephp.org.reg
57d254d6 215%{php_pear_dir}/.registry/.channel.pear.firephp.org
16d1038b
ER
216
217%{php_pear_dir}/.channels/.alias/symfony.txt
218%{php_pear_dir}/.channels/pear.symfony-project.com.reg
219%{php_pear_dir}/.registry/.channel.pear.symfony-project.com
3e35a10f
ER
220
221%{php_pear_dir}/.channels/.alias/phpseclib.txt
222%{php_pear_dir}/.channels/phpseclib.sourceforge.net.reg
223%{php_pear_dir}/.registry/.channel.phpseclib.sourceforge.net
1275fa38
ER
224
225%{php_pear_dir}/.channels/.alias/horde.txt
226%{php_pear_dir}/.channels/pear.horde.org.reg
227%{php_pear_dir}/.registry/.channel.pear.horde.org
20007f01
ER
228
229%{php_pear_dir}/.channels/.alias/rc.txt
230%{php_pear_dir}/.channels/pear.roundcube.net.reg
231%{php_pear_dir}/.registry/.channel.pear.roundcube.net
d9ff93b5
ER
232
233%{php_pear_dir}/.channels/.alias/ezc.txt
234%{php_pear_dir}/.channels/components.ez.no.reg
235%{php_pear_dir}/.registry/.channel.components.ez.no
4c5242d9
ER
236
237%{php_pear_dir}/.channels/.alias/propel.txt
238%{php_pear_dir}/.channels/pear.propelorm.org.reg
239%{php_pear_dir}/.registry/.channel.pear.propelorm.org
a9af1509
ER
240
241%{php_pear_dir}/.channels/.alias/docblox.txt
242%{php_pear_dir}/.channels/pear.docblox-project.org.reg
243%{php_pear_dir}/.registry/.channel.pear.docblox-project.org
d92a3b44
ER
244
245%{php_pear_dir}/.channels/.alias/michelf.txt
246%{php_pear_dir}/.channels/pear.michelf.com.reg
247%{php_pear_dir}/.registry/.channel.pear.michelf.com
f84845e8
ER
248
249%{php_pear_dir}/.channels/.alias/pdepend.txt
250%{php_pear_dir}/.channels/pear.pdepend.org.reg
251%{php_pear_dir}/.registry/.channel.pear.pdepend.org
252
253%{php_pear_dir}/.channels/.alias/phpmd.txt
254%{php_pear_dir}/.channels/pear.phpmd.org.reg
255%{php_pear_dir}/.registry/.channel.pear.phpmd.org
5f88c87c
ER
256
257%{php_pear_dir}/.channels/.alias/symfony2.txt
258%{php_pear_dir}/.channels/pear.symfony.com.reg
259%{php_pear_dir}/.registry/.channel.pear.symfony.com
d1682f5e
ER
260
261%{php_pear_dir}/.channels/.alias/saucelabs.txt
262%{php_pear_dir}/.channels/saucelabs.github.com_pear.reg
263%{php_pear_dir}/.registry/.channel.saucelabs.github.com_pear
73b1fcbc
ER
264
265%{php_pear_dir}/.channels/.alias/twig.txt
266%{php_pear_dir}/.channels/pear.twig-project.org.reg
267%{php_pear_dir}/.registry/.channel.pear.twig-project.org
3ba22036
ER
268
269%{php_pear_dir}/.channels/.alias/zz.txt
270%{php_pear_dir}/.channels/zustellzentrum.cweiske.de.reg
271%{php_pear_dir}/.registry/.channel.zustellzentrum.cweiske.de
7a1a8238
ER
272
273%{php_pear_dir}/.channels/.alias/theseer.txt
274%{php_pear_dir}/.channels/pear.netpirates.net.reg
275%{php_pear_dir}/.registry/.channel.pear.netpirates.net
7e5dea50
ER
276
277%{php_pear_dir}/.channels/.alias/indeyets.txt
278%{php_pear_dir}/.channels/pear.indeyets.ru.reg
279%{php_pear_dir}/.registry/.channel.pear.indeyets.ru
237c2312
ER
280
281%{php_pear_dir}/.channels/.alias/phpdoc.txt
282%{php_pear_dir}/.channels/pear.phpdoc.org.reg
283%{php_pear_dir}/.registry/.channel.pear.phpdoc.org
902a69a3
ER
284
285%{php_pear_dir}/.channels/.alias/bartlett.txt
286%{php_pear_dir}/.channels/bartlett.laurent-laville.org.reg
287%{php_pear_dir}/.registry/.channel.bartlett.laurent-laville.org
This page took 0.109255 seconds and 4 git commands to generate.