]> git.pld-linux.org Git - packages/php-dkim.git/blame - php-dkim.spec
- use virtual names for php deps
[packages/php-dkim.git] / php-dkim.spec
CommitLineData
20ea9748
ER
1%include /usr/lib/rpm/macros.php
2%define php_min_version 5.0.0
3%define pkgname dkim
4Summary: PHP Implementation of DKIM
5Name: php-%{pkgname}
6Version: 1.0
a61b25e5 7Release: 2
20ea9748
ER
8License: GPL v2
9Group: Development/Languages/PHP
a61b25e5 10Source0: http://downloads.sourceforge.net/php-dkim/php-dkim.zip
20ea9748 11# Source0-md5: 6d7e89b035f76c83ad93e597ffe9f06c
f1e0dca3 12Patch0: library.patch
20ea9748
ER
13URL: http://php-dkim.sourceforge.net/
14BuildRequires: lynx
15BuildRequires: rpm-php-pearprov >= 4.4.2-11
16BuildRequires: rpmbuild(macros) >= 1.533
f127d391 17BuildRequires: unzip
a61b25e5
ER
18Requires: php(core) >= %{php_min_version}
19Requires: php(date)
20Requires: php(openssl)
21Requires: php(pcre)
20ea9748
ER
22BuildArch: noarch
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25# bad depsolver
26%define _noautopear pear
27
28# put it together for rpmbuild
29%define _noautoreq %{?_noautophp} %{?_noautopear}
30
31%description
32PHP-DKIM add a Domain Key Identified Mail (DKIM RFC 4871) signatures
33to emails sent by PHP.
34
35It is based on the openssl extensions of PHP. It can generate DKIM
36signature but cannot verify them. Php-dkim supports RSA signature and
37SHA-1 hash for DKIM. The relaxed header canonicalization is supported
38(only simple body canonicalization).
39
40Php-dkim allows any PHP application to send email with a DKIM
41signature this should decrease the probability of getting this email
42tagged as spam.
43
44%prep
45%setup -qc
46%undos README.html *.php
f1e0dca3 47%patch0 -p1
20ea9748
ER
48
49mv dkim-cfg-dist.php dkim-cfg.php
50
51%build
52lynx -dump --nolist README.html > README
53
54%install
55rm -rf $RPM_BUILD_ROOT
56install -d $RPM_BUILD_ROOT%{php_data_dir}
57cp -a dkim.php $RPM_BUILD_ROOT%{php_data_dir}
58
59install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60cp -a dkim-cfg.php dkim-test.php $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%files
66%defattr(644,root,root,755)
67%{php_data_dir}/dkim.php
68%{_examplesdir}/%{name}-%{version}
This page took 0.059516 seconds and 4 git commands to generate.