]> git.pld-linux.org Git - packages/php-bytekit.git/blame - php-bytekit.spec
- new
[packages/php-bytekit.git] / php-bytekit.spec
CommitLineData
d0a2bbe4
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
5%define modname bytekit
6Summary: An extension to represent the opcodes generated by Zend Engine
7Name: php-%{modname}
8Version: 0.1.1
9Release: 1
10License: Bytekit 1.0 (based on PHP 3.0)
11Group: Development/Languages/PHP
12Source0: http://www.bytekit.org/download/%{modname}-%{version}.tgz
13# Source0-md5: 83d0a325713201947aec441f30be58d8
14URL: http://www.bytekit.org/
15BuildRequires: php-devel >= 4:5.0.4
16BuildRequires: rpmbuild(macros) >= 1.519
17%{?requires_php_extension}
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21Bytekit is a PHP extension that provides a userspace representation of
22the opcodes generated by the Zend engine compiler built into PHP.
23
24This extension provides not only access to the raw op_array data but
25also contains a Zend engine disassembler that exports control flow
26information in form of code flow graphs and basic blocks. Bytekit is
27meant as a tool to understand the internals of PHP better, to debug
28Zend engine error cases and as base to develop all kinds of static and
29dynamic code analysis tools.
30
31%prep
32%setup -q -n %{modname}-%{version}
33
34%build
35phpize
36%configure
37%{__make}
38
39%install
40rm -rf $RPM_BUILD_ROOT
41install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
42install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
43install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir},%{_examplesdir}/%{name}-%{version}}
44
45%{__make} install \
46 EXTENSION_DIR=%{php_extensiondir} \
47 INSTALL_ROOT=$RPM_BUILD_ROOT
48cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
49; Enable %{modname} extension module
50extension=%{modname}.so
51EOF
52
53cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54
55%clean
56rm -rf $RPM_BUILD_ROOT
57
58%files
59%defattr(644,root,root,755)
60%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
61%attr(755,root,root) %{php_extensiondir}/%{modname}.so
62%{_examplesdir}/%{name}-%{version}
This page took 0.065496 seconds and 4 git commands to generate.