]> git.pld-linux.org Git - packages/php-bytekit.git/blame - php-bytekit.spec
php multiversion support; builds with php5.3 only now
[packages/php-bytekit.git] / php-bytekit.spec
CommitLineData
d0a2bbe4
ER
1#
2# Conditional build:
3%bcond_without tests # build without tests
4
bf0ec116 5%define php_name php%{?php_suffix}
d0a2bbe4
ER
6%define modname bytekit
7Summary: An extension to represent the opcodes generated by Zend Engine
bf0ec116 8Name: %{php_name}-%{modname}
d0a2bbe4 9Version: 0.1.1
bf0ec116 10Release: 3
d0a2bbe4
ER
11License: Bytekit 1.0 (based on PHP 3.0)
12Group: Development/Languages/PHP
13Source0: http://www.bytekit.org/download/%{modname}-%{version}.tgz
14# Source0-md5: 83d0a325713201947aec441f30be58d8
15URL: http://www.bytekit.org/
bf0ec116
ER
16BuildRequires: %{php_name}-devel
17BuildRequires: rpmbuild(macros) >= 1.666
d0a2bbe4 18%{?requires_php_extension}
bf0ec116 19Obsoletes: php-bytekit < 0.1.1-3
d0a2bbe4
ER
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Bytekit is a PHP extension that provides a userspace representation of
24the opcodes generated by the Zend engine compiler built into PHP.
25
26This extension provides not only access to the raw op_array data but
27also contains a Zend engine disassembler that exports control flow
28information in form of code flow graphs and basic blocks. Bytekit is
29meant as a tool to understand the internals of PHP better, to debug
30Zend engine error cases and as base to develop all kinds of static and
31dynamic code analysis tools.
32
33%prep
34%setup -q -n %{modname}-%{version}
35
36%build
37phpize
38%configure
39%{__make}
40
8eb8b1bb
ER
41%{?with_tests:%{__make} test}
42
d0a2bbe4
ER
43%install
44rm -rf $RPM_BUILD_ROOT
d0a2bbe4
ER
45%{__make} install \
46 EXTENSION_DIR=%{php_extensiondir} \
47 INSTALL_ROOT=$RPM_BUILD_ROOT
bf0ec116
ER
48
49install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
d0a2bbe4
ER
50cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
51; Enable %{modname} extension module
52extension=%{modname}.so
53EOF
54
bf0ec116 55install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
d0a2bbe4
ER
56cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
64%attr(755,root,root) %{php_extensiondir}/%{modname}.so
65%{_examplesdir}/%{name}-%{version}
This page took 0.074833 seconds and 4 git commands to generate.