]> git.pld-linux.org Git - packages/pesign.git/blame - pesign.spec
- updated to 113
[packages/pesign.git] / pesign.spec
CommitLineData
44bc1bc6
JB
1Summary: Signing tool for PE-COFF binaries
2Summary(pl.UTF-8): Narzędzie do podpisywania binariów PE-COFF
3Name: pesign
f113538e
JB
4Version: 113
5Release: 1
6License: GPL v3+
44bc1bc6 7Group: Applications/System
696c34df
JB
8#Source0Download: https://github.com/rhboot/pesign/releases
9Source0: https://github.com/rhboot/pesign/releases/download/%{version}/%{name}-%{version}.tar.bz2
f113538e 10# Source0-md5: 4710e207b69c17537d3b3f18ce19948e
02f0f164
JB
11Patch0: %{name}-pld.patch
12Patch1: %{name}-build.patch
696c34df 13URL: https://github.com/rhboot/pesign
5be72b8e 14BuildRequires: efivar-devel
f113538e 15BuildRequires: libuuid-devel
44bc1bc6
JB
16BuildRequires: nspr-devel
17BuildRequires: nss-devel
18BuildRequires: pkgconfig
19BuildRequires: popt-devel
20BuildRequires: rpmbuild(macros) >= 1.644
21Requires(pre): /bin/id
22Requires(pre): /usr/bin/getgid
23Requires(pre): /usr/sbin/groupadd
24Requires(pre): /usr/sbin/useradd
25Requires(post,preun): /sbin/chkconfig
26Requires(postun): /usr/sbin/groupdel
27Requires(postun): /usr/sbin/userdel
28Requires: %{name}-libs = %{version}-%{release}
29Requires: rc-scripts
30Provides: group(pesign)
31Provides: user(pesign)
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%description
35Signing tool for PE-COFF binaries, hopefully at least vaguely
36compliant with the PE and Authenticode specifications.
37
38%description -l pl.UTF-8
39Narzędzie do podpisywania binariów PE-COFF, mające być przynajmniej
40w jakiś sposób zgodne ze specyfikacjami PE oraz Authenticode.
41
42%package libs
43Summary: libdpe shared library
44Summary(pl.UTF-8): Biblioteka współdzielona libdpe
45Group: Libraries
46
47%description libs
48libdpe shared library.
49
50%description libs -l pl.UTF-8
51Biblioteka współdzielona libdpe.
52
53%package devel
54Summary: Header files for libdpe library
55Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libdpe
56Group: Development/Libraries
57Requires: %{name}-libs = %{version}-%{release}
58
59%description devel
60Header files for libdpe library.
61
62%description devel -l pl.UTF-8
63Pliki nagłówkowe biblioteki libdpe.
64
65%package static
66Summary: Static libdpe library
67Summary(pl.UTF-8): Statyczna biblioteka libdpe
68Group: Development/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72Static libdpe library.
73
74%description static -l pl.UTF-8
75Statyczna biblioteka libdpe.
76
77%prep
78%setup -q
79%patch0 -p1
02f0f164 80%patch1 -p1
44bc1bc6 81
02f0f164 82%{__sed} -i -e 's,\$(libdatadir)systemd/system,%{systemdunitdir},' src/Makefile
44bc1bc6
JB
83
84%build
f113538e
JB
85# due to checks (to distinguish gcc/clang) in Make.defaults gcc cannot be prefixed with target-
86# -g is required because of -fvar-tracking
87CC="gcc" \
88CFLAGS="%{rpmcflags} -g" \
44bc1bc6 89%{__make} \
02f0f164 90 LIBDIR=%{_libdir} \
f113538e
JB
91 libdir=%{_libdir} \
92 libexecdir=%{_libexecdir}
44bc1bc6
JB
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97%{__make} install install_systemd install_sysvinit \
98 DESTDIR=$RPM_BUILD_ROOT \
f113538e
JB
99 libdir=%{_libdir} \
100 libexecdir=%{_libexecdir}
02f0f164 101
f113538e
JB
102# omitted from install (as of 113)
103install libdpe/libdpe.so $RPM_BUILD_ROOT%{_libdir}/libdpe.so.0.%{version}
104ln -sf libdpe.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/libdpe.so
02f0f164
JB
105cp -p libdpe/libdpe.a $RPM_BUILD_ROOT%{_libdir}
106install -d $RPM_BUILD_ROOT%{_includedir}/libdpe
107cp -p include/libdpe/*.h $RPM_BUILD_ROOT%{_includedir}/libdpe
108
109# just unwanted COPYING file; make space for %doc
110%{__rm} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/COPYING
44bc1bc6
JB
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%pre
116%groupadd -g 312 pesign
117%useradd -u 312 -d /usr/share/empty -g pesign -c "pesign signing daemon user" pesign
118
119%post
120/sbin/chkconfig --add pesign
121%service pesign restart
122
123%preun
124if [ "$1" = "0" ]; then
125 %service -q pesign stop
126 /sbin/chkconfig --del pesign
127fi
128
129%postun
130if [ "$1" = "0" ]; then
131 %userremove pesign
132 %groupremove pesign
133fi
134
135%post libs -p /sbin/ldconfig
136%postun libs -p /sbin/ldconfig
137
138%files
139%defattr(644,root,root,755)
140%doc README TODO
02f0f164 141%attr(755,root,root) %{_bindir}/authvar
44bc1bc6 142%attr(755,root,root) %{_bindir}/efikeygen
02f0f164
JB
143%attr(755,root,root) %{_bindir}/efisiglist
144%attr(755,root,root) %{_bindir}/pesigcheck
44bc1bc6
JB
145%attr(755,root,root) %{_bindir}/pesign
146%attr(755,root,root) %{_bindir}/pesign-client
f113538e
JB
147%dir %{_libexecdir}/pesign
148%attr(755,root,root) %{_libexecdir}/pesign/pesign-authorize
02f0f164
JB
149%dir %{_sysconfdir}/pesign
150%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pesign/groups
151%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pesign/users
a76f9189 152%attr(775,pesign,pesign) %dir /etc/pki/pesign
44bc1bc6
JB
153# what should be proper owner???
154%dir /etc/popt.d
155/etc/popt.d/pesign.popt
156/etc/rpm/macros.pesign
157%attr(754,root,root) /etc/rc.d/init.d/pesign
158%{systemdunitdir}/pesign.service
a76f9189 159%attr(770,pesign,pesign) %dir /var/run/pesign
44bc1bc6 160%{systemdtmpfilesdir}/pesign.conf
02f0f164 161%{_mandir}/man1/authvar.1*
44bc1bc6 162%{_mandir}/man1/efikeygen.1*
02f0f164
JB
163%{_mandir}/man1/efisiglist.1*
164%{_mandir}/man1/pesigcheck.1*
44bc1bc6
JB
165%{_mandir}/man1/pesign.1*
166%{_mandir}/man1/pesign-client.1*
167
168%files libs
169%defattr(644,root,root,755)
f113538e 170%attr(755,root,root) %{_libdir}/libdpe.so.0.%{version}
44bc1bc6
JB
171
172%files devel
173%defattr(644,root,root,755)
02f0f164 174%attr(755,root,root) %{_libdir}/libdpe.so
44bc1bc6
JB
175%{_includedir}/libdpe
176
177%files static
178%defattr(644,root,root,755)
179%{_libdir}/libdpe.a
This page took 0.081259 seconds and 4 git commands to generate.