]> git.pld-linux.org Git - packages/perl-rpm-build-perl.git/blame - perl-rpm-build-perl.spec
- rel 4; fix build
[packages/perl-rpm-build-perl.git] / perl-rpm-build-perl.spec
CommitLineData
68eaae30 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir rpm
7%define pnam build-perl
8Summary: Calculate dependencies for Perl sources
cc3f43f5 9Summary(pl.UTF-8): Znajdowanie zależności dla źródeł perlowych
68eaae30 10Name: perl-rpm-build-perl
cc3f43f5 11Version: 0.82
21fa8c21 12Release: 4
cc3f43f5 13License: GPL v2+
68eaae30 14Group: Development/Languages/Perl
cc3f43f5
JB
15Source0: http://www.cpan.org/modules/by-authors/id/A/AT/ATOURBIN/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 1cfb4f6a0842d04ef39fd945abacce91
17# https://rt.cpan.org/Ticket/Attachment/1513584/807128/rpm-build-perl-0.82-Adjust-to-perl-5.22.patch
18Patch0: %{name}-perl5.22.patch
19# https://rt.cpan.org/Ticket/Attachment/1213691/640915/0001-Fix-non-deterministic-failures-on-newer-perls.patch
20Patch1: %{name}-non-deterministic-failures.patch
21fa8c21 21Patch2: rpm-build-perl-0.82-Port-to-OpSIBLING-like-macros-required-since-Perl-5..patch
68eaae30 22URL: http://search.cpan.org/dist/rpm-build-perl/
23BuildRequires: perl-devel >= 1:5.8.0
24BuildRequires: rpm-perlprov >= 4.1-13
cc3f43f5
JB
25%if %{with tests}
26BuildRequires: perl-Encode
27BuildRequires: perl-Test-Simple
28%endif
68eaae30 29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32Calculate dependencies for Perl sources.
33
34%description -l pl.UTF-8
35Moduł ten znajduje zależności dla źródeł perlowych.
36
37%prep
38%setup -q -n %{pdir}-%{pnam}-%{version}
cc3f43f5
JB
39%patch0 -p1
40%patch1 -p1
21fa8c21 41%patch2 -p1
68eaae30 42
43%build
44%{__perl} Makefile.PL \
45 INSTALLDIRS=vendor
32adebb4
JB
46%{__make} \
47 CC="%{__cc}" \
48 OPTIMIZE="%{rpmcflags}"
68eaae30 49
50%{?with_tests:%{__make} test}
51
52%install
53rm -rf $RPM_BUILD_ROOT
54
55%{__make} pure_install \
56 DESTDIR=$RPM_BUILD_ROOT
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61%files
62%defattr(644,root,root,755)
63%doc Changes README
cc3f43f5
JB
64%attr(755,root,root) %{_bindir}/perl.clean
65%attr(755,root,root) %{_bindir}/perl.prov
66%attr(755,root,root) %{_bindir}/perl.prov.files
67%attr(755,root,root) %{_bindir}/perl.req
68%attr(755,root,root) %{_bindir}/perl.req.files
69%{perl_vendorarch}/B/Clobbers.pm
70%{perl_vendorarch}/B/ConstOptree.pm
71%{perl_vendorarch}/B/PerlReq.pm
72%{perl_vendorarch}/B/Walker.pm
73%dir %{perl_vendorarch}/PerlReq
74%{perl_vendorarch}/PerlReq/Utils.pm
75%{perl_vendorarch}/fake.pm
76%dir %{perl_vendorarch}/auto/B
77%dir %{perl_vendorarch}/auto/B/ConstOptree
78%attr(755,root,root) %{perl_vendorarch}/auto/B/ConstOptree/ConstOptree.so
79%{_mandir}/man1/perl.prov.1p*
80%{_mandir}/man1/perl.req.1p*
81%{_mandir}/man3/B::Clobbers.3pm*
82%{_mandir}/man3/B::ConstOptree.3pm*
83%{_mandir}/man3/B::PerlReq.3pm*
84%{_mandir}/man3/B::Walker.3pm*
85%{_mandir}/man3/PerlReq::Utils.3pm*
This page took 0.149947 seconds and 4 git commands to generate.