]> git.pld-linux.org Git - packages/perl-XML-Filter-Cache.git/blame - perl-XML-Filter-Cache.spec
use generic url
[packages/perl-XML-Filter-Cache.git] / perl-XML-Filter-Cache.spec
CommitLineData
65c74154 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
7f943ad0 4
b32a5e9a 5%define pdir XML
6%define pnam Filter-Cache
7f943ad0 7%include /usr/lib/rpm/macros.perl
65c74154 8Summary: XML::Filter::Cache - a SAX2 recorder/playback mechanism
477f38a4 9Summary(pl.UTF-8): XML::Filter::Cache - mechanizm nagrywania/odtwarzania SAX2
65c74154 10Name: perl-XML-Filter-Cache
11Version: 0.03
35d05300 12Release: 2
65c74154 13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
a543dbde 17# Source0-md5: 2590e2a28c5741aa8cd14503e0ea767e
35d05300 18Patch0: %{name}-weird_test_failure.patch
7f943ad0 19URL: http://search.cpan.org/dist/XML-Filter-Cache/
e9a959be 20BuildRequires: perl-devel >= 1:5.8.0
65c74154 21BuildRequires: rpm-perlprov >= 4.1-13
22%if %{with tests}
23BuildRequires: perl-XML-SAX >= 0.08
24BuildRequires: perl-XML-SAX-Writer >= 0.39
25%endif
26BuildArch: noarch
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
241f2de3 30This is a very simple filter module for SAX2 events. By default it
31caches events into a big binary file on disk (the cache files are
32generally much larger than the original XML at the moment, but I'll
33work on that), but the storage backend is pluggable. It uses Storable
34to do the freeze/thaw thing, and at the moment this is not pluggin
35replaceable, simply because there's no better tool for the task at
36hand.
65c74154 37
27890435
JR
38%description -l pl.UTF-8
39To jest bardzo prosty moduł filtra dla zdarzeń SAX2. Domyślnie
40buforuje on zdarzenia w dużym pliku binarnym na dysku (aktualnie pliki
41bufora są zwykle o wiele większe niż oryginalny XML, ale autor tym się
e9a959be 42zajmie), ale backend przechowywania danych jest wymienny. Do
27890435
JR
43wykonywania freeze/thaw używana jest klasa Storable i aktualnie nie
44jest zamienna, ponieważ po prostu nie ma lepszego narzędzia do tego
e9a959be 45celu.
65c74154 46
47%prep
48%setup -q -n %{pdir}-%{pnam}-%{version}
35d05300 49%patch0 -p0
65c74154 50
51%build
52%{__perl} Makefile.PL \
53 INSTALLDIRS=vendor
54%{__make}
55
56%{?with_tests:%{__make} test}
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%{__make} install \
62 DESTDIR=$RPM_BUILD_ROOT
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
99aa5b31 69%{perl_vendorlib}/XML/*/*
65c74154 70%{_mandir}/man3/*
This page took 0.105972 seconds and 4 git commands to generate.