]> git.pld-linux.org Git - packages/perl-Wx.git/blame - perl-Wx.spec
perl 5.38.0 rebuild
[packages/perl-Wx.git] / perl-Wx.spec
CommitLineData
2e932399
AM
1
2# NOTE: On every new version, we need to manually regenerate the list of XS Provides
3# cd Wx-*
4# for i in `grep -r "PACKAGE=" * | cut -d " " -f 2 | sed 's|PACKAGE=|perl(|g' | grep "Wx::" | sort -n |uniq`; do printf "Provides: $i)\\n"; done &> provides.txt
5# grep -orP '%name{Wx::[^}]*}\s+class' |grep -v "3pm" | cut -d : -f 2- | sed 's|%name{|Provides: perl(|g' | sed 's|} class|)|g' |uniq &>> provides.txt
6# cat provides.txt | uniq | sort -n
7
4de6ff00
JB
8#
9# Conditional build:
5e909227
JB
10%bcond_without unicode # ANSI instead of Unicode version of wxGTK
11%bcond_with gtk3 # wxGTK3 instead of wxGTK2
12%bcond_with tests # "make test" (requires $DISPLAY)
fb705e1e 13
5e909227
JB
14%define wxpkg wxGTK%{?with_gtk3:3}%{!?with_gtk3:2}%{?with_unicode:-unicode}
15%define wx_ver %(rpm -q wxWidgets-devel --qf '%%{VERSION}')
16%define wx_ver_tag %(echo %{wx_ver} | tr . _)
17%define alien_wxcfg gtk%{!?with_gtk3:2}_%{wx_ver_tag}%{?with_unicode:_uni}_gcc_3_4
fb705e1e 18%define pdir Wx
deb8018a 19Summary: wxPerl - a Perl wrapper for the wxWidgets C++ GUI toolkit
5cb4cb25 20Summary(pl.UTF-8): wxPerl - wrapper toolkitu graficznego C++ wxWidgets dla Perla
deb8018a 21Name: perl-Wx
21218061 22Version: 0.9932
3f6719bb 23Release: 7
deb8018a
24# same as perl
25License: GPL v1+ or Artistic
26Group: Development/Languages/Perl
27Source0: http://www.cpan.org/modules/by-module/Wx/Wx-%{version}.tar.gz
21218061 28# Source0-md5: 76f019b04fffec0fda06bf46b0e93046
f01a9c8b 29Source1: perl-provides
21218061 30Patch0: method-typo.patch
1e70ffa7 31URL: http://wxperl.sourceforge.net/
d8901247 32BuildRequires: perl-Alien-wxWidgets >= 0.67
5e909227
JB
33BuildRequires: perl-ExtUtils-MakeMaker >= 6.46
34BuildRequires: perl-ExtUtils-ParseXS >= 3.15
35BuildRequires: perl-ExtUtils-XSpp >= 0.16_02
36%if %{with tests}
37BuildRequires: perl-Test-Harness >= 2.26
38BuildRequires: perl-Test-Simple >= 0.45
39%endif
deb8018a 40BuildRequires: perl-devel >= 1:5.8.0
5e909227 41# require Alien::wxWidgets with config for desired wx variant
2e932399 42BuildRequires: %{wxpkg}-devel >= 2.6.3-1
5e909227
JB
43BuildRequires: perl(Alien::wxWidgets::Config::%{alien_wxcfg})
44BuildRequires: perl(File::Spec::Functions) >= 0.82
45BuildRequires: perl(if) >= 0.03
deb8018a 46BuildRequires: rpm-perlprov >= 4.1-13
0d233067 47BuildRequires: rpmbuild(macros) >= 1.745
5e909227 48Requires: perl-Alien-wxWidgets >= 0.25
f01a9c8b
ER
49# Load manually generated Perl dependencies, see note on top of spec file
50%(cat %{SOURCE1})
2e932399 51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
cdd0a0b2 52
deb8018a 53%description
5e909227 54wxPerl is a Perl wrapper for the wxWidgets C++ GUI toolkit.
deb8018a 55
e9053be2 56%description -l pl.UTF-8
5e909227
JB
57wxPerl to wrapper toolkitu graficznego C++ wxWidgets dla Perla.
58
59%package devel
60Summary: Development package for wxPerl
61Summary(pl.UTF-8): Pakiet do rozwijania oprogramowania przy użyciu wxPerla
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64Requires: %{wxpkg}-devel >= 2.6.3-1
65
66%description devel
67Development package for wxPerl.
68
69%description devel -l pl.UTF-8
70Pakiet do rozwijania oprogramowania przy użyciu wxPerla.
deb8018a
71
72%prep
73%setup -q -n Wx-%{version}
21218061 74%patch0 -p1
deb8018a
75
76%build
deb8018a 77%{__perl} Makefile.PL \
335c9ce5
JB
78 INSTALLDIRS=vendor \
79 --wx-toolkit=gtk%{!?with_gtk3:2} \
80 --%{!?with_unicode:no-}wx-unicode
deb8018a 81%{__make} \
5e909227 82 CC="%{__cxx}" \
1e70ffa7 83 OPTIMIZE="%{rpmcflags}"
deb8018a 84
5e909227
JB
85%{?with_tests:%{__make} test}
86
deb8018a
87%install
88rm -rf $RPM_BUILD_ROOT
89
90%{__make} install \
91 DESTDIR=$RPM_BUILD_ROOT
92
5e909227
JB
93%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Wx/*.pod
94
95# not this OS
96%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Wx/build/MakeMaker/{MacOSX,Win32}* \
97 $RPM_BUILD_ROOT%{_mandir}/man3/Wx::build::MakeMaker::Win32_MSVC.3pm
98
deb8018a
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%files
103%defattr(644,root,root,755)
5e909227
JB
104%doc README.txt docs/todo.txt
105%{perl_vendorarch}/Wx.pm
106%dir %{perl_vendorarch}/Wx
107%{perl_vendorarch}/Wx/Perl
108%{perl_vendorarch}/Wx/*.pm
109%{perl_vendorarch}/Wx/typemap
deb8018a 110%dir %{perl_vendorarch}/auto/Wx
5e909227
JB
111%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Wx.so
112%dir %{perl_vendorarch}/auto/Wx/AUI
113%attr(755,root,root) %{perl_vendorarch}/auto/Wx/AUI/AUI.so
deb8018a 114%dir %{perl_vendorarch}/auto/Wx/Calendar
5e909227 115%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Calendar/Calendar.so
deb8018a 116%dir %{perl_vendorarch}/auto/Wx/DND
5e909227
JB
117%attr(755,root,root) %{perl_vendorarch}/auto/Wx/DND/DND.so
118%dir %{perl_vendorarch}/auto/Wx/DataView
119%attr(755,root,root) %{perl_vendorarch}/auto/Wx/DataView/DataView.so
120%dir %{perl_vendorarch}/auto/Wx/DateTime
121%attr(755,root,root) %{perl_vendorarch}/auto/Wx/DateTime/DateTime.so
deb8018a 122%dir %{perl_vendorarch}/auto/Wx/DocView
5e909227 123%attr(755,root,root) %{perl_vendorarch}/auto/Wx/DocView/DocView.so
deb8018a 124%dir %{perl_vendorarch}/auto/Wx/FS
5e909227 125%attr(755,root,root) %{perl_vendorarch}/auto/Wx/FS/FS.so
deb8018a 126%dir %{perl_vendorarch}/auto/Wx/Grid
5e909227 127%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Grid/Grid.so
deb8018a 128%dir %{perl_vendorarch}/auto/Wx/Help
5e909227 129%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Help/Help.so
deb8018a 130%dir %{perl_vendorarch}/auto/Wx/Html
5e909227
JB
131%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Html/Html.so
132%dir %{perl_vendorarch}/auto/Wx/IPC
133%attr(755,root,root) %{perl_vendorarch}/auto/Wx/IPC/IPC.so
deb8018a 134%dir %{perl_vendorarch}/auto/Wx/MDI
5e909227
JB
135%attr(755,root,root) %{perl_vendorarch}/auto/Wx/MDI/MDI.so
136%dir %{perl_vendorarch}/auto/Wx/Media
137%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Media/Media.so
138%dir %{perl_vendorarch}/auto/Wx/PerlTest
139%attr(755,root,root) %{perl_vendorarch}/auto/Wx/PerlTest/PerlTest.so
deb8018a 140%dir %{perl_vendorarch}/auto/Wx/Print
5e909227
JB
141%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Print/Print.so
142%dir %{perl_vendorarch}/auto/Wx/PropertyGrid
143%attr(755,root,root) %{perl_vendorarch}/auto/Wx/PropertyGrid/PropertyGrid.so
144%dir %{perl_vendorarch}/auto/Wx/Ribbon
145%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Ribbon/Ribbon.so
146%dir %{perl_vendorarch}/auto/Wx/RichText
147%attr(755,root,root) %{perl_vendorarch}/auto/Wx/RichText/RichText.so
deb8018a 148%dir %{perl_vendorarch}/auto/Wx/STC
5e909227
JB
149%attr(755,root,root) %{perl_vendorarch}/auto/Wx/STC/STC.so
150%dir %{perl_vendorarch}/auto/Wx/Socket
151%attr(755,root,root) %{perl_vendorarch}/auto/Wx/Socket/Socket.so
152%dir %{perl_vendorarch}/auto/Wx/WebView
153%attr(755,root,root) %{perl_vendorarch}/auto/Wx/WebView/WebView.so
deb8018a 154%dir %{perl_vendorarch}/auto/Wx/XRC
5e909227
JB
155%attr(755,root,root) %{perl_vendorarch}/auto/Wx/XRC/XRC.so
156%{_mandir}/man3/Wx.3pm*
157%{_mandir}/man3/Wx::Api.3pm*
158%{_mandir}/man3/Wx::Loader.3pm*
159%{_mandir}/man3/Wx::NewClass.3pm*
160%{_mandir}/man3/Wx::Perl::*.3pm*
161%{_mandir}/man3/Wx::Socket.3pm*
162%{_mandir}/man3/Wx::Thread.3pm*
163
164%files devel
165%defattr(644,root,root,755)
166%attr(755,root,root) %{_bindir}/wxperl_overload
167%{perl_vendorarch}/Wx/Overload
168%{perl_vendorarch}/Wx/XSP
169%{perl_vendorarch}/Wx/build
170%{perl_vendorarch}/Wx/cpp
171%{_mandir}/man1/wxperl_overload.1p*
172%{_mandir}/man3/Wx::XSP::*.3pm*
173%{_mandir}/man3/Wx::build::*.3pm*
This page took 0.126435 seconds and 4 git commands to generate.