]> git.pld-linux.org Git - packages/perl-Variable-Magic.git/blame - perl-Variable-Magic.spec
- updated to 0.62
[packages/perl-Variable-Magic.git] / perl-Variable-Magic.spec
CommitLineData
ee20fd4e 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Variable
7%define pnam Magic
8Summary: Variable::Magic - Associate user-defined magic to variables from Perl
eee9af0e 9Summary(pl.UTF-8): Variable::Magic - dowiązanie magii zdefiniowanej przez użytkownika do zmiennych w Perlu
ee20fd4e 10Name: perl-Variable-Magic
bc1f1f6d
MK
11Version: 0.62
12Release: 1
ee20fd4e 13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
48be34ef 16Source0: http://www.perl.com/CPAN/modules/by-module/Variable/%{pdir}-%{pnam}-%{version}.tar.gz
bc1f1f6d 17# Source0-md5: 588d94ec3d98dece878a776d161c1dda
ee20fd4e 18URL: http://search.cpan.org/dist/Variable-Magic/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Magic is Perl way of enhancing objects.
25
26This mechanism let the user add extra data to any variable and hook
27syntaxical operations (such as access, assignation or destruction)
28that can be applied to it.
29
30With this module, you can add your own magic to any variable without
31the pain of the C API.
32
eee9af0e
JB
33%description -l pl.UTF-8
34Magia to perlowy sposób rozszerzania obiektów.
35
36Ten mechanizm pozwala użytkownikowi dodać dodatkowe dane do dowolnej
37zmiennej i przechwycić operacje składniowe (takie jak dostęp,
38powiązanie czy destrukcję), które można na niej wykonać.
39
40Przy użyciu tego modułu można dodawać własną magię do dowolnej
41zmiennej unikając bólu API języka C.
ee20fd4e 42
43%prep
44%setup -q -n %{pdir}-%{pnam}-%{version}
45
46%build
47%{__perl} Makefile.PL \
48 INSTALLDIRS=vendor
49%{__make} \
50 CC="%{__cc}" \
51 OPTIMIZE="%{rpmcflags}"
52
53%{?with_tests:%{__make} test}
54
55%install
56rm -rf $RPM_BUILD_ROOT
57
58%{__make} pure_install \
59 DESTDIR=$RPM_BUILD_ROOT
60
61install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62cp -a samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc Changes README
eee9af0e 70%{perl_vendorarch}/Variable/Magic.pm
ee20fd4e 71%dir %{perl_vendorarch}/auto/Variable/Magic
eee9af0e
JB
72%attr(755,root,root) %{perl_vendorarch}/auto/Variable/Magic/Magic.so
73%{_mandir}/man3/Variable::Magic.3pm*
ee20fd4e 74%{_examplesdir}/%{name}-%{version}
This page took 0.111519 seconds and 4 git commands to generate.