]> git.pld-linux.org Git - packages/perl-Variable-Magic.git/blame - perl-Variable-Magic.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Variable-Magic.git] / perl-Variable-Magic.spec
CommitLineData
ee20fd4e 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
ee20fd4e 5%define pdir Variable
6%define pnam Magic
7Summary: Variable::Magic - Associate user-defined magic to variables from Perl
eee9af0e 8Summary(pl.UTF-8): Variable::Magic - dowiązanie magii zdefiniowanej przez użytkownika do zmiennych w Perlu
ee20fd4e 9Name: perl-Variable-Magic
bc1f1f6d 10Version: 0.62
3b2bc2af 11Release: 2
ee20fd4e 12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
48be34ef 15Source0: http://www.perl.com/CPAN/modules/by-module/Variable/%{pdir}-%{pnam}-%{version}.tar.gz
bc1f1f6d 16# Source0-md5: 588d94ec3d98dece878a776d161c1dda
ee20fd4e 17URL: http://search.cpan.org/dist/Variable-Magic/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Magic is Perl way of enhancing objects.
24
25This mechanism let the user add extra data to any variable and hook
26syntaxical operations (such as access, assignation or destruction)
27that can be applied to it.
28
29With this module, you can add your own magic to any variable without
30the pain of the C API.
31
eee9af0e
JB
32%description -l pl.UTF-8
33Magia to perlowy sposób rozszerzania obiektów.
34
35Ten mechanizm pozwala użytkownikowi dodać dodatkowe dane do dowolnej
36zmiennej i przechwycić operacje składniowe (takie jak dostęp,
37powiązanie czy destrukcję), które można na niej wykonać.
38
39Przy użyciu tego modułu można dodawać własną magię do dowolnej
40zmiennej unikając bólu API języka C.
ee20fd4e 41
42%prep
43%setup -q -n %{pdir}-%{pnam}-%{version}
44
45%build
46%{__perl} Makefile.PL \
47 INSTALLDIRS=vendor
48%{__make} \
49 CC="%{__cc}" \
50 OPTIMIZE="%{rpmcflags}"
51
52%{?with_tests:%{__make} test}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56
57%{__make} pure_install \
58 DESTDIR=$RPM_BUILD_ROOT
59
60install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61cp -a samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files
67%defattr(644,root,root,755)
68%doc Changes README
eee9af0e 69%{perl_vendorarch}/Variable/Magic.pm
ee20fd4e 70%dir %{perl_vendorarch}/auto/Variable/Magic
eee9af0e
JB
71%attr(755,root,root) %{perl_vendorarch}/auto/Variable/Magic/Magic.so
72%{_mandir}/man3/Variable::Magic.3pm*
ee20fd4e 73%{_examplesdir}/%{name}-%{version}
This page took 0.054282 seconds and 4 git commands to generate.