]> git.pld-linux.org Git - packages/perl-Variable-Magic.git/blame - perl-Variable-Magic.spec
- rebuild with perl 5.18.0
[packages/perl-Variable-Magic.git] / perl-Variable-Magic.spec
CommitLineData
ee20fd4e 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Variable
7%define pnam Magic
8Summary: Variable::Magic - Associate user-defined magic to variables from Perl
9#Summary(pl.UTF-8):
10Name: perl-Variable-Magic
c916eacf 11Version: 0.47
61e241ae 12Release: 2
ee20fd4e 13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
48be34ef 16Source0: http://www.perl.com/CPAN/modules/by-module/Variable/%{pdir}-%{pnam}-%{version}.tar.gz
c916eacf 17# Source0-md5: ee8b101120e7971d6232aac339fb3472
ee20fd4e 18URL: http://search.cpan.org/dist/Variable-Magic/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24Magic is Perl way of enhancing objects.
25
26This mechanism let the user add extra data to any variable and hook
27syntaxical operations (such as access, assignation or destruction)
28that can be applied to it.
29
30With this module, you can add your own magic to any variable without
31the pain of the C API.
32
33# %description -l pl.UTF-8
34# TODO
35
36%prep
37%setup -q -n %{pdir}-%{pnam}-%{version}
38
39%build
40%{__perl} Makefile.PL \
41 INSTALLDIRS=vendor
42%{__make} \
43 CC="%{__cc}" \
44 OPTIMIZE="%{rpmcflags}"
45
46%{?with_tests:%{__make} test}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51%{__make} pure_install \
52 DESTDIR=$RPM_BUILD_ROOT
53
54install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55cp -a samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57%clean
58rm -rf $RPM_BUILD_ROOT
59
60%files
61%defattr(644,root,root,755)
62%doc Changes README
63%{perl_vendorarch}/Variable/*.pm
64%dir %{perl_vendorarch}/auto/Variable/Magic
65%attr(755,root,root) %{perl_vendorarch}/auto/Variable/Magic/*.so
66%{_mandir}/man3/*
67%{_examplesdir}/%{name}-%{version}
This page took 0.076514 seconds and 4 git commands to generate.