]> git.pld-linux.org Git - packages/perl-Text-Soundex.git/blame - perl-Text-Soundex.spec
- release 2 (by relup.sh)
[packages/perl-Text-Soundex.git] / perl-Text-Soundex.spec
CommitLineData
8c988e5c
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Text
6%define pnam Soundex
7%include /usr/lib/rpm/macros.perl
8Summary: Text::Soundex - Implementation of the soundex algorithm
9Summary(pl.UTF-8): Text::Soundex - implementacja algorytmu soundex
10Name: perl-Text-Soundex
11Version: 3.04
a1b31dde 12Release: 2
8c988e5c
JB
13License: free (see COPYING)
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
16# Source0-md5: 4630d47b42b92470df7b447984a71446
17URL: http://search.cpan.org/dist/Text-Soundex/
18BuildRequires: perl-devel >= 1:5.8.0
19BuildRequires: rpm-perlprov >= 4.1-13
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23Soundex is a phonetic algorithm for indexing names by sound, as
24pronounced in English. The goal is for names with the same
25pronunciation to be encoded to the same representation so that they
26can be matched despite minor differences in spelling. Soundex is the
27most widely known of all phonetic algorithms and is often used
28(incorrectly) as a synonym for "phonetic algorithm". Improvements to
29Soundex are the basis for many modern phonetic algorithms. (Wikipedia,
302007)
31
32This module implements the original soundex algorithm developed by
33Robert Russell and Margaret Odell, patented in 1918 and 1922, as well
34as a variation called "American Soundex" used for US census data, and
35current maintained by the National Archives and Records Administration
36(NARA).
37
38The soundex algorithm may be recognized from Donald Knuth's
39The Art of Computer Programming. The algorithm described by
40Knuth is the NARA algorithm.
41
42%description -l pl.UTF-8
43Soundex to algorytm fonetyczny do indeksowania nazw według brzmienia w
44języku angielskim. Celem jest, aby nazwy o tej samej wymowie miały
45taką samą reprezentację, przez co mogą być dopasowane niezależnie od
46niewielkich różnic w pisowni. Soundex to najbardziej znany algorytm
47fonetyczny, zwykle używany (niewłaściwie) jako synonim algorytmu
48fonetycznego. (Wikipedia angielska, 2007)
49
50Ten moduł implementuje oryginalny algorytm soundex opracowany przez
51Roberta Russella oraz Margaret Odell, opatentowany w 1918 i 1922, oraz
52wariację o nazwie "soundex amerykański" używany dla danych ludności w
53USA, obecnie zarządzany przez NARA (National Archives and Records
54Administration).
55
56Algorytm soundex można znaleźć w "The Art of Computer Programming"
57Donalda Knutha. Algorytm opisany przez Knutha to algorytm NARA.
58
59%prep
60%setup -q -n %{pdir}-%{pnam}-%{version}
61
62# extract copyright information
63%{__sed} -n -e '3,12p' Soundex.pm > COPYING
64
65%build
66%{__perl} Makefile.PL \
67 INSTALLDIRS=vendor
68%{__make} \
69 CC="%{__cc}" \
70 OPTIMIZE="%{rpmcflags}"
71
72%{?with_tests:%{__make} test}
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77%{__make} pure_install \
78 DESTDIR=$RPM_BUILD_ROOT
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(644,root,root,755)
85%doc COPYING Changes
86%{perl_vendorarch}/Text/Soundex.pm
87%dir %{perl_vendorarch}/auto/Text/Soundex
88%attr(755,root,root) %{perl_vendorarch}/auto/Text/Soundex/Soundex.so
89%{_mandir}/man3/Text::Soundex.3pm*
This page took 0.073511 seconds and 4 git commands to generate.