]> git.pld-linux.org Git - packages/perl-Text-Soundex.git/blame - perl-Text-Soundex.spec
rebuild with perl 5.32
[packages/perl-Text-Soundex.git] / perl-Text-Soundex.spec
CommitLineData
8c988e5c
JB
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Text
6%define pnam Soundex
8c988e5c
JB
7Summary: Text::Soundex - Implementation of the soundex algorithm
8Summary(pl.UTF-8): Text::Soundex - implementacja algorytmu soundex
9Name: perl-Text-Soundex
d81991bc 10Version: 3.05
065017c5 11Release: 3
8c988e5c
JB
12License: free (see COPYING)
13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-module/Text/%{pdir}-%{pnam}-%{version}.tar.gz
d81991bc 15# Source0-md5: cb40ded7a5d27aa3a411d274d6ec18ae
8c988e5c
JB
16URL: http://search.cpan.org/dist/Text-Soundex/
17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22Soundex is a phonetic algorithm for indexing names by sound, as
23pronounced in English. The goal is for names with the same
24pronunciation to be encoded to the same representation so that they
25can be matched despite minor differences in spelling. Soundex is the
26most widely known of all phonetic algorithms and is often used
27(incorrectly) as a synonym for "phonetic algorithm". Improvements to
28Soundex are the basis for many modern phonetic algorithms. (Wikipedia,
292007)
30
31This module implements the original soundex algorithm developed by
32Robert Russell and Margaret Odell, patented in 1918 and 1922, as well
33as a variation called "American Soundex" used for US census data, and
34current maintained by the National Archives and Records Administration
35(NARA).
36
37The soundex algorithm may be recognized from Donald Knuth's
38The Art of Computer Programming. The algorithm described by
39Knuth is the NARA algorithm.
40
41%description -l pl.UTF-8
42Soundex to algorytm fonetyczny do indeksowania nazw według brzmienia w
43języku angielskim. Celem jest, aby nazwy o tej samej wymowie miały
44taką samą reprezentację, przez co mogą być dopasowane niezależnie od
45niewielkich różnic w pisowni. Soundex to najbardziej znany algorytm
46fonetyczny, zwykle używany (niewłaściwie) jako synonim algorytmu
47fonetycznego. (Wikipedia angielska, 2007)
48
49Ten moduł implementuje oryginalny algorytm soundex opracowany przez
50Roberta Russella oraz Margaret Odell, opatentowany w 1918 i 1922, oraz
51wariację o nazwie "soundex amerykański" używany dla danych ludności w
52USA, obecnie zarządzany przez NARA (National Archives and Records
53Administration).
54
55Algorytm soundex można znaleźć w "The Art of Computer Programming"
56Donalda Knutha. Algorytm opisany przez Knutha to algorytm NARA.
57
58%prep
59%setup -q -n %{pdir}-%{pnam}-%{version}
60
61# extract copyright information
62%{__sed} -n -e '3,12p' Soundex.pm > COPYING
63
64%build
65%{__perl} Makefile.PL \
66 INSTALLDIRS=vendor
67%{__make} \
68 CC="%{__cc}" \
69 OPTIMIZE="%{rpmcflags}"
70
71%{?with_tests:%{__make} test}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76%{__make} pure_install \
77 DESTDIR=$RPM_BUILD_ROOT
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%files
83%defattr(644,root,root,755)
84%doc COPYING Changes
85%{perl_vendorarch}/Text/Soundex.pm
86%dir %{perl_vendorarch}/auto/Text/Soundex
87%attr(755,root,root) %{perl_vendorarch}/auto/Text/Soundex/Soundex.so
88%{_mandir}/man3/Text::Soundex.3pm*
This page took 0.129026 seconds and 4 git commands to generate.