]> git.pld-linux.org Git - packages/perl-Scope-Upper.git/blame - perl-Scope-Upper.spec
- release 3 (by relup.sh)
[packages/perl-Scope-Upper.git] / perl-Scope-Upper.spec
CommitLineData
0ace432b 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Scope
7%define pnam Upper
8Summary: Scope::Upper - Act on upper scopes.
9#Summary(pl.UTF-8):
10Name: perl-Scope-Upper
b9a0c6c2 11Version: 0.24
7f8d88b3 12Release: 3
0ace432b 13# same as perl
14License: GPL v1+ or Artistic
15Group: Development/Languages/Perl
16Source0: http://www.cpan.org/modules/by-module/Scope/%{pdir}-%{pnam}-%{version}.tar.gz
b9a0c6c2 17# Source0-md5: e3b80bef3703399870081e08a04b0c79
0ace432b 18URL: http://search.cpan.org/dist/Scope-Upper/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22%endif
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26This module lets you defer actions at run-time that will take place
27when the control flow returns into an upper scope.
28
29# %description -l pl.UTF-8
30# TODO
31
32%prep
33%setup -q -n %{pdir}-%{pnam}-%{version}
34
35%build
36%{__perl} Makefile.PL \
37 INSTALLDIRS=vendor
38%{__make} \
39 CC="%{__cc}" \
40 OPTIMIZE="%{rpmcflags}"
41
42%{?with_tests:%{__make} test}
43
44%install
45rm -rf $RPM_BUILD_ROOT
46
47%{__make} pure_install \
48 DESTDIR=$RPM_BUILD_ROOT
49
50install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51cp -a samples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%files
57%defattr(644,root,root,755)
58%doc Changes
59%dir %{perl_vendorarch}/Scope
60%dir %{perl_vendorarch}/auto/Scope
61%{perl_vendorarch}/Scope/*.pm
62%dir %{perl_vendorarch}/auto/Scope/Upper
0ace432b 63%attr(755,root,root) %{perl_vendorarch}/auto/Scope/Upper/*.so
64%{_mandir}/man3/*
65%{_examplesdir}/%{name}-%{version}
This page took 0.106894 seconds and 4 git commands to generate.