]> git.pld-linux.org Git - packages/perl-Qt.git/blame - perl-Qt.spec
- release 7 (by relup.sh)
[packages/perl-Qt.git] / perl-Qt.spec
CommitLineData
d6238da6 1#
2# Conditional build:
19371c3b 3%bcond_with tests # do not perform "make test"
d6238da6 4#
5%include /usr/lib/rpm/macros.perl
0df9867a 6%define pdir PerlQt
d6238da6 7Summary: Qt - A Perl module interface to Qt
8Summary(pl.UTF-8): Qt - interfejs Perla do Qt
9Name: perl-Qt
0df9867a 10Version: 3.008
58004acc 11Release: 7
0df9867a 12License: GPL
d6238da6 13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-module/Qt/%{pdir}-%{version}.tar.gz
0df9867a 15# Source0-md5: a0cdc0c86b3e79c56f09f2af8c4c2c39
4a619ed3 16Patch0: format-security.patch
d6238da6 17URL: http://search.cpan.org/dist/Qt/
19371c3b 18BuildRequires: libstdc++-devel
d6238da6 19BuildRequires: perl-devel >= 1:5.8.0
19371c3b 20BuildRequires: qt-devel
d6238da6 21BuildRequires: rpm-perlprov >= 4.1-13
19371c3b 22BuildRequires: xorg-lib-libXext-devel
23BuildRequires: xorg-lib-libXi-devel
24BuildRequires: xorg-lib-libXt-devel
25BuildRequires: zlib-devel
d6238da6 26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29The Qt module itself only creates a $qApp and exports some QGlobal
30imports.
31
32This module is not the whole of the Qt interface, though. Each header
33in Qt which holds a class is represented by a module with the name of
34that class. Classes like QWidget and QApplication are represented by
35modules of the same name. QResizeEvent is not a module, but rather is
36part of the QEvent module, just as the QResizeEvent class is a part of
37qevent.h.
38
39Each class header that has been interfaced to Perl has a pod attached
40which describes the function interface from Qt.
41
42%description -l pl.UTF-8
43Interfejs Perla do Qt.
44
45%prep
46%setup -q -n %{pdir}-%{version}
4a619ed3
JR
47%patch0 -p1
48
19371c3b 49%{__sed} 's/ -Wmissing-prototypes / /' -i configure
d6238da6 50
51%build
52%{__perl} Makefile.PL \
7b34b910 53 --prefix=%{_prefix} \
0df9867a 54 --with-qt-dir=%{_libdir} \
d6238da6 55 INSTALLDIRS=vendor
56
7b34b910
AM
57%configure
58
59cd PerlQt
60%{__perl} Makefile.PL \
61 INSTALLDIRS=vendor
62cd ..
63
19371c3b 64%{__make}
d6238da6 65
66%{?with_tests:%{__make} test}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70
19371c3b 71%{__make} install \
d6238da6 72 DESTDIR=$RPM_BUILD_ROOT
73
d6238da6 74%clean
75rm -rf $RPM_BUILD_ROOT
76
9bdf7e59
AM
77%post -p /sbin/ldconfig
78%postun -p /sbin/ldconfig
79
d6238da6 80%files
81%defattr(644,root,root,755)
19371c3b 82%doc INSTALL README TODO
9bdf7e59
AM
83%attr(755,root,root) %{_bindir}/pqtapi
84%attr(755,root,root) %{_bindir}/pqtsh
85%attr(755,root,root) %{_bindir}/puic
7b34b910
AM
86%{perl_vendorarch}/Qt.pm
87%dir %{perl_vendorarch}/Qt
88%{perl_vendorarch}/Qt/*.pm
89%dir %{perl_vendorarch}/auto/Qt
90%attr(755,root,root) %{perl_vendorarch}/auto/Qt/*.bs
91%attr(755,root,root) %{perl_vendorarch}/auto/Qt/*.so
9bdf7e59 92%{_mandir}/man1/puic.1*
7b34b910 93%{_mandir}/man3/Qt.3*
9bdf7e59
AM
94%attr(755,root,root) %{_libdir}/libsmokeqt.so.*.*.*
95%ghost %attr(755,root,root) %{_libdir}/libsmokeqt.so.1
This page took 0.069951 seconds and 4 git commands to generate.