]> git.pld-linux.org Git - packages/perl-Proc-Wait3.git/blame - perl-Proc-Wait3.spec
- release 7 (by relup.sh)
[packages/perl-Proc-Wait3.git] / perl-Proc-Wait3.spec
CommitLineData
ba4ae80c 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
9fadb4ba 4
ba4ae80c 5%define pdir Proc
6%define pnam Wait3
7%include /usr/lib/rpm/macros.perl
8Summary: Proc::Wait3 - Perl extension for wait3 system call
ba4ae80c 9Name: perl-Proc-Wait3
10Version: 0.04
8d7b3330 11Release: 7
ba4ae80c 12License: unknown
13Group: Development/Languages/Perl
14Source0: http://www.cpan.org/modules/by-module/Proc/%{pdir}-%{pnam}-%{version}.tar.gz
15# Source0-md5: d87ce5f3557eb86bfa5bafb9f2e028e3
9fadb4ba 16URL: http://search.cpan.org/dist/Proc-Wait3/
ba4ae80c 17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
ba4ae80c 19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22If any child processes have exited, this call will "reap" the zombies
23similar to the perl "wait" function.
24
25By default, it will return immediately and if there are no dead
26children, everything will be undefined. If you pass in a true
27argument, it will block until a child exits (or it gets a signal).
28
29 $pid PID of exiting child
30
31 $status exit status of child, just like C<$?>
32
33 $utime floating point user cpu seconds
34
35 $stime floating point system cpu seconds
36
37 $maxrss the maximum resident set size utilized (in kilobytes).
38
39 $minflt the number of page faults serviced without any I/O
40 activity; here I/O activity is avoided by "reclaiming" a
41 page frame from the list of pages awaiting reallocation.
42
43 $majflt the number of page faults serviced that required I/O
44 activity.
45
46 $nswap the number of times a process was "swapped" out of main
47 memory.
48
49 $inblock the number of times the file system had to perform input.
50
51 $oublock the number of times the file system had to perform output.
52
53 $msgsnd the number of messages sent over sockets.
54
55 $msgrcv the number of messages received from sockets.
56
57 $nsignals the number of signals delivered.
58
59 $nvcsw the number of times a context switch resulted due to a
60 process voluntarily giving up the processor before its
61 time slice was completed (usually to await availability of
62 a resource).
63
64 $nivcsw the number of times a context switch resulted due to a
65 higher priority process becoming runnable or because the
66 current process exceeded its time slice.
67
68
69
70# %description -l pl.UTF-8
71# TODO
72
73%prep
74%setup -q -n %{pdir}-%{pnam}-%{version}
75
76%build
77%{__perl} Makefile.PL \
78 INSTALLDIRS=vendor
79%{__make} \
80 CC="%{__cc}" \
81 OPTIMIZE="%{rpmcflags}"
82
83%{?with_tests:%{__make} test}
84
85%install
86rm -rf $RPM_BUILD_ROOT
87
88%{__make} pure_install \
89 DESTDIR=$RPM_BUILD_ROOT
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(644,root,root,755)
96%doc Changes README
97%{perl_vendorarch}/Proc/*.pm
98%dir %{perl_vendorarch}/auto/Proc/Wait3
ba4ae80c 99%attr(755,root,root) %{perl_vendorarch}/auto/Proc/Wait3/*.so
100%{_mandir}/man3/*
This page took 0.114906 seconds and 4 git commands to generate.