]> git.pld-linux.org Git - packages/perl-PathTools.git/blame - perl-PathTools.spec
- up to 3.25
[packages/perl-PathTools.git] / perl-PathTools.spec
CommitLineData
4c430311 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir PathTools
61beee4e 7Summary: Get pathname of current working directory
d5fea3c0 8Summary(pl.UTF-8): Pobieranie ścieżki bieżącego katalogu
4c430311 9Name: perl-PathTools
ed79af87 10Version: 3.25
4c430311 11Release: 1
fbec8818 12# same as perl
e58ea473 13License: GPL v1+ or Artistic
4c430311 14Group: Development/Languages/Perl
e4412c4b 15Source0: http://www.cpan.org/modules/by-authors/id/K/KW/KWILLIAMS/%{pdir}-%{version}.tar.gz
ed79af87 16# Source0-md5: 242b8a6355927625f57048f6c59577ca
4c430311 17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
4c430311 19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22PathTools merges Cwd and File::Spec into a single distribution.
23This was done because the two modules use each other fairly extensively,
24and extracting the common stuff into another distribution was deemed
25nigh-impossible.
26
27Cwd provides functions for determining the pathname of the current
28working directory. It is recommended that getcwd (or another *cwd()
29function) be used in _all_ code to ensure portability.
30
31File::Spec is designed to support operations commonly performed on file
32specifications (usually called "file names", but not to be confused with
33the contents of a file, or Perl's file handles), such as concatenating
34several directory and file names into a single path, or determining
35whether a path is rooted.
36
ee7f189f
JR
37%description -l pl.UTF-8
38PathTools łączy Cwd i File::Spec w jeden pakiet. Został zrobiony
39ponieważ te dwa moduły używają intensywnie siebie nawzajem i
40wyciągnięcie wspólnego kodu do oddzielnego pakietu zostało uznane za
41prawie niemożliwe.
61beee4e 42
ee7f189f
JR
43Cwd dostarcza funkcje do określania ścieżki bieżącego katalogu.
44Zalecane jest używanie getcwd (lub innej funkcji *cwd()) w _całym_
45kodzie dla zapewnienia przenośności.
61beee4e 46
ee7f189f
JR
47File::Spec jest zaprojektowany do obsługi operacji zwykle
48przeprowadzanych na określeniach plików (zwykle nazywanych "nazwami
49plików", których nie należy mylić z zawartością plików czy perlowymi
50uchwytami plików), takich jak łączenie kilku katalogów i nazw plików w
51pojedynczą ścieżkę albo określanie czy ścieżka jest podana względem
52głównego katalogu.
4c430311 53
54%prep
55%setup -q -n %{pdir}-%{version}
56
57%build
58%{__perl} Makefile.PL \
59 INSTALLDIRS=vendor
60%{__make} \
61 OPTIMIZE="%{rpmcflags}"
62
63%{?with_tests:%{__make} test}
64
65%install
66rm -rf $RPM_BUILD_ROOT
67
68%{__make} install \
69 DESTDIR=$RPM_BUILD_ROOT
70
e58ea473 71rm -f $RPM_BUILD_ROOT{%{perl_vendorarch}/File/Spec/,%{_mandir}/man3/File::Spec::}{Cygwin,Epoc,Mac,OS2,VMS,Win32}*
72
4c430311 73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(644,root,root,755)
78%doc Changes
79%{perl_vendorarch}/*.pm
80%{perl_vendorarch}/File/Spec*
81%dir %{perl_vendorarch}/auto/Cwd
82%{perl_vendorarch}/auto/Cwd/*.bs
83%attr(755,root,root) %{perl_vendorarch}/auto/Cwd/*.so
84%{_mandir}/man3/*
This page took 0.077837 seconds and 4 git commands to generate.